Bug 169141 - ping -f is horribly slow
ping -f is horribly slow
Status: CLOSED DUPLICATE of bug 134859
Product: Fedora
Classification: Fedora
Component: iputils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-23 11:41 EDT by Jörn Engel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 03:37:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jörn Engel 2005-09-23 11:41:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050802 Debian/1.7.10-1

Description of problem:
Below reproduction works on old rh7 and rh8 systems, on fc2 and according to dwmw2 also on fc4.  "ping -f" has been completely useless on RedHat for the last couple or years.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
# time ping -f 192.168.0.20 -c 1000
PING 192.168.0.20 (192.168.0.20) 56(84) bytes of data.
 
--- 192.168.0.20 ping statistics ---
1000 packets transmitted, 1000 received, 0% packet loss, time 15806ms
rtt min/avg/max/mdev = 0.280/0.291/0.368/0.025 ms, pipe 2, ipg/ewma 15.822/0.287 ms

real    0m15.809s
user    0m0.001s
sys     0m0.001s


Additional info:
Comment 1 Jörn Engel 2005-09-23 12:28:02 EDT
For comparison, I've written a private version of ping that only does floodping:
# time ~joern/floodping -c1000000 192.168.0.20
PING 192.168.1.20 (192.168.1.20): 1 data bytes

--- 192.168.1.20 ping statistics ---
1000000 packets transmitted

real    0m7.293s
user    0m1.414s
sys     0m5.882s

Tested on the same machine.  floodping doesn't test for errors or received
packets, it just sends them as fast as possible.  Still, that's not a reason for
regular ping to be 2000x slower.
Comment 2 Radek Vokal 2005-09-26 03:34:29 EDT
Strange that there are no big changes in ping used in RH9 and todays rawhide
ping. The changes are rather cosmetic and should not affect the transfer speed.
Will look at it closer. 
Comment 3 Radek Vokal 2005-09-26 03:37:38 EDT

*** This bug has been marked as a duplicate of 134859 ***

Note You need to log in before you can comment on or make changes to this bug.