Bug 1691444 - the nodeSelector won't works for kibana and curator in CLO
Summary: the nodeSelector won't works for kibana and curator in CLO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-21 15:45 UTC by Anping Li
Modified: 2019-06-04 10:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:28 UTC
Github openshift cluster-logging-operator pull 128 None None None 2019-03-21 19:03:59 UTC

Description Anping Li 2019-03-21 15:45:50 UTC
Description of problem:
Specify the nodeSelector in CLO.  the nodeSelector is not added into deployment/kibana and cronjob/curator.

Version-Release number of selected component (if applicable):
v4.x

How reproducible:
always

Steps to Reproduce:
1. Add nodeSelector for ES, kibana,curator as following
spec:
  collection:
    logs:
      fluentd:
        resources: null
      rsyslog:
        resources: null
      type: fluentd
  curation:
    curator:
      nodeSelector:
        logging: curator
      resources: null
      schedule: '*/10 * * * *'
    type: curator
  logStore:
    elasticsearch:
      nodeCount: 1
      nodeSelector:
        logging: es
      redundancyPolicy: ZeroRedundancy
      resources:
        limits:
          memory: 2Gi
        requests:
          cpu: 200m
          memory: 2Gi
      storage:
        size: 20G
        storageClassName: gp2
    type: elasticsearch

2. Check the nodeSelector in deployment and crontab

Actual results:
The nodeSelector are added in ES deployment. But it wasn't added to the deployment/kibana and cronjob/curator

Expected results:


Additional info:

Comment 1 Qiaoling Tang 2019-03-26 08:53:47 UTC
Verified in quay.io/openshift/origin-cluster-logging-operator@sha256:2193bbb23eba530cd76574e0c25f9b3a7f966a7f10f7eb0739f465644614df48

Comment 3 errata-xmlrpc 2019-06-04 10:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.