Bug 169146 - Firefox reports itself as "mozilla" to the a11y framework
Summary: Firefox reports itself as "mozilla" to the a11y framework
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Keywords: Reopened
Depends On:
Blocks: 169147
TreeView+ depends on / blocked
 
Reported: 2005-09-23 17:14 UTC by Dave Malcolm
Modified: 2018-04-11 15:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (29.19 KB, image/png)
2006-10-12 08:12 UTC, Yan Tian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 309789 None None None Never

Description Dave Malcolm 2005-09-23 17:14:39 UTC
Description of problem:
Firefox reports itself as "mozilla" to the a11y framework.

Version-Release number of selected component (if applicable):
firefox-1.1-0.2.8.deerpark.alpha2

How reproducible:
100%

Steps to Reproduce:
1.  Launch firefox
2.  Launch at-poke
  
Actual results:
Firefox has name and description of "Mozilla" (looking elsewhere it appears that
the description is set to "Mozilla Root Accessible"; perhaps at-poke is buggy)

Expected results:
Firefox should have name of "Firefox", or some way of identifying it.

Additional info:

Comment 1 Christopher Aillon 2005-09-23 20:40:03 UTC
https://bugzilla.mozilla.org/show_bug.cgi?id=309789

Comment 2 Zack Cerza 2005-12-01 19:27:25 UTC
This is still a problem. Only it's "Gecko" now.

Comment 3 Dave Malcolm 2006-01-13 22:45:04 UTC
Still reporting as "Mozilla" with firefox-1.5-4

Comment 4 Yan Tian 2006-10-12 08:12:32 UTC
Created attachment 138309 [details]
Screenshot

Reported as 'Gecko' and no children widgets in RHEL5-Client-20060927.0
Workstation system. 
firefox-1.5.0.7-5.fc6

Comment 5 Red Hat Bugzilla 2007-02-05 19:09:17 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 6 Matěj Cepl 2007-02-05 23:42:02 UTC
still true with firefox-1.5.0.9-2.fc6

Comment 7 Matěj Cepl 2007-12-20 16:47:42 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.