Bug 1691505 - openshift-controller-manager-operator does not report 'Progressing=true' during daemonset rollout
Summary: openshift-controller-manager-operator does not report 'Progressing=true' duri...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Corey Daley
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-21 18:45 UTC by Adam Kaplan
Modified: 2019-06-04 10:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:28 UTC
Red Hat Bugzilla 1694216 None MODIFIED openshift controller manager failed to upgrade 2019-04-15 12:34:28 UTC

Internal Links: 1694216

Description Adam Kaplan 2019-03-21 18:45:02 UTC
Description of problem: During a daemonset rollout, the openshift-controller-manager-operator reports that it is not progressing, even though the operand (openshift-controller-manager) is rolling out an update.


Version-Release number of selected component (if applicable): 4.0.0-0.alpha-2019-03-21-045513


How reproducible: Always


Steps to Reproduce:
1. Push a custom version of origin-hypershift to an external registry (ex: quay.io)
2. Set the openshift-controller-manager-operator to be unmanaged:
  a. oc edit clusterversion/version
  b. Add the following:
```
spec:
  overrides:
  - kind: Deployment
    name: openshift-controller-manager-operator
    namespace: openshift-controller-manager-operator
    unmanaged: true
``
3. Update the openshift-controller-manager-operator to deploy your custom version of origin-hypershift:
  a. oc edit deployment openshift-controller-manager-operator -n openshift-controller-manager-operator
  b. Update the IMAGE env var in the deployment:
```
spec:
...
  env:
  - name: IMAGE
    value: quay.io/myusername/origin-hypershift:mytag
...
```

Actual results: oc get clusteroperator/openshift-controller-manager always returns Progressing=false


Expected results: oc get clusteroperator/openshift-controller-manager should return Progressing=true during the daemonset rollout


Additional info:

Comment 1 Adam Kaplan 2019-04-04 13:13:51 UTC
Corey - this may be end up being a duplicate of 1694216. Once your fix is in we can re-evaluate.

Comment 2 Adam Kaplan 2019-04-11 12:55:57 UTC
Corey's openshift-controller-manager-operator PR: https://github.com/openshift/cluster-openshift-controller-manager-operator/pull/85

Comment 4 wewang 2019-04-16 05:41:58 UTC
When the daemonset rollout, clusteroperator/openshift-controller-manager returns Progressing=true now
version:
4.1.0-0.ci-2019-04-15-224704

logs:
I0416 03:35:30.231803       1 status_controller.go:152] clusteroperator/openshift-controller-manager diff {"status":{"conditions":[{"lastTransitionTime":"2019-04-16T03:35:29Z","reason":"AsExpected","status":"False","type":"Failing"},{"lastTransitionTime":"2019-04-16T03:35:30Z","message":"Progressing: daemonset/controller-manager: observed generation is 6, desired generation is 7.\nProgressing: openshiftcontrollermanagers.operator.openshift.io/cluster: observed generation is 3, desired generation is 4.","reason":"Progressing","status":"True","type":"Progressing"},{"lastTransitionTime":"2019-04-16T03:35:29Z","reason":"AsExpected","status":"True","type":"Available"},{"lastTransitionTime":"2019-04-16T03:35:29Z","reason":"NoData","status":"Unknown","type":"Upgradeable"}],"versions":[{"name":"operator","version":"4.1.0-0.ci-2019-04-15-224704"}]}}
I0416 03:35:30.237320       1 event.go:221] Event(v1.ObjectReference{Kind:"Deployment", Namespace:"openshift-controller-manager-operator", Name:"openshift-controller-manager-operator", UID:"996a0c7e-5fec-11e9-bae2-0279093214fc", APIVersion:"apps/v1", ResourceVersion:"", FieldPath:""}): type: 'Normal' reason: 'OperatorStatusChanged' Status for operator openshift-controller-manager changed: Progressing changed from False to True ("Progressing: daemonset/controller-manager: observed generation is 6, desired generation is 7.\nProgressing: openshiftcontrollermanagers.operator.openshift.io/cluster: observed generation is 3, desired generation is 4.")

Comment 6 errata-xmlrpc 2019-06-04 10:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.