Bug 1691745 - [abrt] xorg-x11-server-Xwayland: OsLookupColor(): Display server crashed
Summary: [abrt] xorg-x11-server-Xwayland: OsLookupColor(): Display server crashed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8861115ae89d507df4dbe59fc19...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 11:56 UTC by Soeren Grunewald
Modified: 2019-06-30 00:56 UTC (History)
9 users (show)

Fixed In Version: xorg-x11-server-1.20.5-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-30 00:56:51 UTC


Attachments (Terms of Use)
File: backtrace (1.74 KB, text/plain)
2019-03-22 11:56 UTC, Soeren Grunewald
no flags Details
File: cpuinfo (1.16 KB, text/plain)
2019-03-22 11:56 UTC, Soeren Grunewald
no flags Details
File: dmesg (68.32 KB, text/plain)
2019-03-22 11:56 UTC, Soeren Grunewald
no flags Details
File: dso_list (333 bytes, text/plain)
2019-03-22 11:56 UTC, Soeren Grunewald
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (492 bytes, application/octet-stream)
2019-03-22 11:56 UTC, Soeren Grunewald
no flags Details
File: usr_share_xorg_conf_d.tar.gz (2.12 KB, application/octet-stream)
2019-03-22 11:56 UTC, Soeren Grunewald
no flags Details
journal around the time of crash (21.91 KB, application/octet-stream)
2019-03-22 14:09 UTC, Soeren Grunewald
no flags Details
Journal log for gnome-shell arround the time of crash (3.49 KB, application/octet-stream)
2019-03-22 14:25 UTC, Soeren Grunewald
no flags Details


Links
System ID Priority Status Summary Last Updated
freedesktop.org Gitlab xorg xserver issues 661 None None None 2019-03-22 14:01:10 UTC

Description Soeren Grunewald 2019-03-22 11:56:34 UTC
Version-Release number of selected component:
xorg-x11-server-Xwayland-1.20.4-1.fc29

Additional info:
reporter:       libreport-2.10.0
crash_function: OsLookupColor
executable:     /usr/bin/Xwayland
kernel:         5.0.3-200.fc29.x86_64
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/bin/Xwayland (OsLookupColor+0x13d) [0x562ce3de631d]
1: /lib64/libpthread.so.0 (funlockfile+0x50) [0x7f91dc24a07f]
2: /lib64/libc.so.6 (gsignal+0x10f) [0x7f91dc0a953f]
3: /lib64/libc.so.6 (abort+0x127) [0x7f91dc093895]
4: /lib64/libc.so.6 (__assert_fail_base.cold.0+0xf) [0x7f91dc093769]
5: /lib64/libc.so.6 (__assert_fail+0x46) [0x7f91dc0a19f6]
6: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_nouveau_vieux+0x41cbb5) [0x7f91db738675]
7: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_nouveau_vieux+0x41d125) [0x7f91db738c15]
8: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_i915+0x137c8b) [0x7f91dafbf16b]
9: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_i915+0x1381ff) [0x7f91dafbfe9f]
10: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_i915+0x130049) [0x7f91dafaf8d9]
11: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_i915+0x11b04c) [0x7f91daf851cc]
12: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_nouveau_vieux+0x1d17ba) [0x7f91db2a1e0a]
13: /usr/lib64/dri/i965_dri.so (__driDriverGetExtensions_nouveau_vieux+0x1d1b2e) [0x7f91db2a250e]
14: /usr/bin/Xwayland (glamor_create_gc+0xd5e5) [0x562ce3cae8c5]
15: /usr/bin/Xwayland (DamageRegionAppend+0x1a0c) [0x562ce3d5689c]
16: /usr/bin/Xwayland (miPaintWindow+0x24f) [0x562ce3cce83f]
17: /usr/bin/Xwayland (miWindowExposures+0x142) [0x562ce3cce5b2]
18: /usr/bin/Xwayland (miHandleValidateExposures+0x6e) [0x562ce3cdc1ce]
19: /usr/bin/Xwayland (MapWindow+0x159) [0x562ce3ddc309]
20: /usr/bin/Xwayland (ProcBadRequest+0x69b) [0x562ce3daa7db]
21: /usr/bin/Xwayland (SendErrorToClient+0x35e) [0x562ce3db035e]
22: /usr/bin/Xwayland (InitFonts+0x3c6) [0x562ce3db4396]
23: /lib64/libc.so.6 (__libc_start_main+0xf3) [0x7f91dc095413]
24: /usr/bin/Xwayland (_start+0x2e) [0x562ce3c8237e]

Comment 1 Soeren Grunewald 2019-03-22 11:56:36 UTC
Created attachment 1546828 [details]
File: backtrace

Comment 2 Soeren Grunewald 2019-03-22 11:56:37 UTC
Created attachment 1546829 [details]
File: cpuinfo

Comment 3 Soeren Grunewald 2019-03-22 11:56:39 UTC
Created attachment 1546830 [details]
File: dmesg

Comment 4 Soeren Grunewald 2019-03-22 11:56:40 UTC
Created attachment 1546831 [details]
File: dso_list

Comment 5 Soeren Grunewald 2019-03-22 11:56:42 UTC
Created attachment 1546832 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 6 Soeren Grunewald 2019-03-22 11:56:43 UTC
Created attachment 1546833 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 7 Olivier Fourdan 2019-03-22 12:17:30 UTC
Can you please provide the journalctl logs of gnome-shell around the time of the crash?

Comment 9 Soeren Grunewald 2019-03-22 14:09:27 UTC
Created attachment 1546907 [details]
journal around the time of crash

Comment 10 Olivier Fourdan 2019-03-22 14:17:52 UTC
Sorry, that's not what I'm asking for... I am after the content of the journalctl log for gnome-shell around the time of the crash (ie something "journalctl /usr/bin/gnome-shell" around the time of the crash)

More precisely, I am looking for a message like "XXX fail to create fbo" because I reckon your crash is the same as the one I fixed upstream.

Comment 11 Soeren Grunewald 2019-03-22 14:25:45 UTC
Created attachment 1546908 [details]
Journal log for gnome-shell arround the time of crash

I see, but the message you are looking for, is not in there.

Comment 12 Olivier Fourdan 2019-03-22 15:19:36 UTC
Right, not even before the crash? (I mean, the log starts precisely at the exact time of the crash -11:08:23- whereas I would expect the message to show up slightly before that).

Anyway, if not the same, then we can't rule out a bug in mesa itself (the abort is caused by an assertion failed in mesa code).

Comment 13 Fedora Update System 2019-06-28 17:15:22 UTC
FEDORA-2019-84694484f4 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-84694484f4

Comment 14 Fedora Update System 2019-06-28 18:26:00 UTC
xorg-x11-server-1.20.5-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-84694484f4

Comment 15 Fedora Update System 2019-06-30 00:56:51 UTC
xorg-x11-server-1.20.5-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.