Bug 169177 - should obsolete battstat_applet?
should obsolete battstat_applet?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2005-09-23 21:55 EDT by Bill Nottingham
Modified: 2014-03-16 22:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 21:07:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-09-23 21:55:29 EDT
Realistically, if you're running g-p-m, having battstat_applet running is
superfluous. Perhaps we just shouldn't build it?
Comment 1 Ray Strode [halfline] 2005-09-23 22:22:07 EDT
Yea, we should do something on this front.

At the very minimum we should take away the panel %post snippet away that adds
it to the panel by default.
Comment 2 Matthias Clasen 2005-10-02 01:34:08 EDT
%post snipplet should be gone now
Comment 3 Havoc Pennington 2005-11-25 06:33:14 EST
Personally I think you should keep battstat by default and turn off the g-p-m
tray icon. Longer rationale in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174160

battstat is a plausible UI, the g-p-m tray icon is just "check it out, we can
dump /proc/acpi into a dialog!" more or less.
Comment 4 Ray Strode [halfline] 2006-01-11 15:47:34 EST
Adding Bryan to this.  We can discuss what to do for FC5 on monday.  Handing to
caillon because...well...I don't know, he looks like he wants to work on it.
Comment 5 Christopher Aillon 2006-01-27 15:34:42 EST
Bryan, what's your expert opinion here?
Comment 6 Bryan W Clark 2006-01-27 18:19:11 EST
Havoc has some good points in the other bug, I can't tell if they've been
addressed or not.  I haven't seen the g-p-m thing myself yet since I can't get
my machine to update to rawhide so I only have hearsay and rumors to go off of. ;)

Not sure if this is being addressed, but at minimum we should be showing
whatever battery thing we have by default.  Like how batstat made it's way into
the panel somehow.  There's no need to regress that part.
Comment 8 Richard Hughes 2006-02-18 16:32:22 EST
>Not sure if this is being addressed, but at minimum we should be showing
>whatever battery thing we have by default.  Like how batstat made it's way into
>the panel somehow.  There's no need to regress that part.

g-p-m loads at startup and displays the current device according to quite a few
policy rules.

>I haven't seen the g-p-m thing myself yet since I can't get
>my machine to update to rawhide so I only have hearsay and rumors to go off of. 

You can also run g-p-m from the FC4 repo here:
http://www.gnome.org/projects/gnome-power-manager/packages.html if you don't
want rawhide goodness. :-)

Richard.
Comment 9 Matthias Clasen 2006-09-10 12:26:23 EDT
We're not going to get changes into fc6 at this point. 
Lets pick this up again for Gnome 2.18/FC7
Comment 10 Matthias Clasen 2007-04-18 17:54:19 EDT
another release goes by...
Comment 11 Matthias Clasen 2008-02-01 21:07:05 EST
its finally gone

Note You need to log in before you can comment on or make changes to this bug.