Bug 169186 - ls hangs on krb5 mountd when user has not kinit-ed
Summary: ls hangs on krb5 mountd when user has not kinit-ed
Status: CLOSED DUPLICATE of bug 169184
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-24 08:17 UTC by Steve Dickson
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-24 08:18:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Dickson 2005-09-24 08:17:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.3.2

Description of problem:
The ls-ing of a NFS mounted directory hangs when
the filesystem is mounted with the -o sec=krb5 option and
the user has not have Kerberos ticket.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. root# mount -o sec=krb5 server:/export /mnt/export
2. user$ ls /mnt/export
3.
  

Actual Results:  ls hangs 

Expected Results:  ls should return Permission denied

Additional info:

The following patch fixes the problem:

@@ -486,8 +486,6 @@ gss_pipe_downcall(struct file *filp, con
        spin_lock(&gss_auth->lock);
        gss_msg = __gss_find_upcall(gss_auth, acred.uid);
        if (gss_msg) {
+               if (gss_err)
+                       gss_msg->msg.errno = -EACCES;
                __gss_unhash_msg(gss_msg);
                spin_unlock(&gss_auth->lock);
                gss_release_msg(gss_msg);

Comment 1 Steve Dickson 2005-09-24 08:18:24 UTC

*** This bug has been marked as a duplicate of 169184 ***


Note You need to log in before you can comment on or make changes to this bug.