Bug 169189 - compiler notices dodgy code
compiler notices dodgy code
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-24 07:20 EDT by David Binderman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 06:09:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2005-09-24 07:20:01 EDT
Description of problem:
I just tried to compile Fedora development package kdegraphics-3.4.2-5
with the extra compiler flag -Wall.

The compiler said

kpcursorlightcross.cpp:75: warning: 'colorValue' is used uninitialized in this
function

The source code is

    if (colorValue)
        colorBitmap [y * (width / 8) + (x / 8)] |= (1 << (x % 8));

There seems to be a missing default section in the previous switch statement.

Suggest initialise the local variable "colorValue" at its declaration
to make the code bulletproof and to shut the compiler up.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ngo Than 2006-02-07 06:09:21 EST
it's now fixed in 3.5.1-2. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.