Bug 1691908 - Legacy warning on boot
Summary: Legacy warning on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vpnc
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Schwarz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1588047 1678148 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 19:29 UTC by Frank Büttner
Modified: 2019-05-08 03:04 UTC (History)
6 users (show)

Fixed In Version: vpnc-0.5.3-35.svn550.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-07 05:41:32 UTC


Attachments (Terms of Use)

Description Frank Büttner 2019-03-22 19:29:22 UTC
Description of problem:
Legacy warning on boot

Version-Release number of selected component (if applicable):
vpnc-0.5.3-33.svn550.fc29.x86_64

How reproducible:
On every boot

Steps to Reproduce:
1. boot the system

Actual results:
Warning about legacy config

Message:
systemd-tmpfiles[13903]: [/etc/tmpfiles.d/vpnc.conf:1] Line references path below legacy directory /var/run/, updating /var/run/vpnc → /run/vpnc; please update the tmpfiles.d/ drop-in file accordingly.

Comment 1 Christian Stadelmann 2019-04-17 08:59:13 UTC
*** Bug 1678148 has been marked as a duplicate of this bug. ***

Comment 2 Christian Stadelmann 2019-04-17 09:01:56 UTC
See https://src.fedoraproject.org/rpms/vpnc/pull-request/1 for a fix.

Comment 3 Felix Schwarz 2019-04-23 20:52:51 UTC
I have some more local fixes to align the spec more with https://fedoraproject.org/wiki/Packaging:Tmpfiles.d but I need to test these locally first.

Comment 4 Felix Schwarz 2019-04-23 20:53:12 UTC
*** Bug 1588047 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2019-04-29 08:22:09 UTC
vpnc-0.5.3-35.svn550.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-35f4e5c584

Comment 6 Fedora Update System 2019-04-29 08:29:04 UTC
vpnc-0.5.3-34.svn550.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-66aec6d9e4

Comment 7 Felix Schwarz 2019-04-29 08:31:44 UTC
I pushed the changes to git/updates-testing for Fedora 29+30 and rawhide. If you can please test the package to ensure it works for you.

Update for Fedora 30: https://bodhi.fedoraproject.org/updates/vpnc-0.5.3-35.svn550.fc30

Comment 8 Fedora Update System 2019-04-30 02:49:00 UTC
vpnc-0.5.3-35.svn550.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-35f4e5c584

Comment 9 Fedora Update System 2019-04-30 03:40:10 UTC
vpnc-0.5.3-34.svn550.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-66aec6d9e4

Comment 10 Fedora Update System 2019-05-07 05:41:32 UTC
vpnc-0.5.3-35.svn550.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-05-08 03:04:27 UTC
vpnc-0.5.3-34.svn550.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.