Bug 1691911 - [unbound] systemd complains about deprecated pidfile directory
Summary: [unbound] systemd complains about deprecated pidfile directory
Keywords:
Status: CLOSED DUPLICATE of bug 1694831
Alias: None
Product: Fedora
Classification: Fedora
Component: unbound
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 19:35 UTC by Joachim Frieben
Modified: 2019-08-27 14:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-27 14:28:42 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2019-03-22 19:35:43 UTC
Description of problem:
On current Fedora 29, service unbound produces a warning reported by systemd because the pidfile directory is /var/run/unbound whereas it should be /run/unbound.

Version-Release number of selected component (if applicable):
unbound-1.8.3-2.fc29

How reproducible:
Always

Steps to Reproduce:
1. Enable and start service unbound.
2. Check output of journalctl for entries related to service unbound.

Actual results:
Mar 22 19:32:38 noname systemd-tmpfiles[4871]: [/usr/lib/tmpfiles.d/unbound.conf:1] Line references path below legacy directory /var/run/, updating /var/run/unbound → /run/unbound; please update the tmpfiles.d/ drop-in file accordingly.

Expected results:
No complaint about unbound using the deprecated pidfile directory /var/run/unbound.

Additional info:
Changing line 357 of vendor-bundled configuration file unbound.conf from
        pidfile: "/var/run/unbound/unbound.pid"
to
        pidfile: "/run/unbound/unbound.pid"
solves this issue.

Comment 1 Joachim Frieben 2019-03-22 19:52:17 UTC
Note: vendor-bundled configuration file tmpfiles-unbound.conf reading
D /var/run/unbound 0755 unbound unbound -
needs to be changed, too.

Comment 2 Paul Wouters 2019-08-27 14:28:42 UTC

*** This bug has been marked as a duplicate of bug 1694831 ***


Note You need to log in before you can comment on or make changes to this bug.