Bug 1691956 - OperatorGroup annotates all deployments in namespace instead of just operator deployments
Summary: OperatorGroup annotates all deployments in namespace instead of just operator...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Peter Ruan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-22 23:27 UTC by Peter Ruan
Modified: 2019-06-04 10:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:28 UTC

Description Peter Ruan 2019-03-22 23:27:01 UTC
Description of problem:
every deployment in the namespace is getting the following annotations added to their pod template:

"olm.operatorGroup": "metering-operators",
 "olm.operatorNamespace": "openshift-metering",
 "olm.targetNamespaces": "openshift-metering",

causing the rollout of new replicasets because it happens so shortly after create
it's causing 2 pods to be created and with lack of resources; 1 pod is stuck pending and the roll out doesn't complete.  This is a replication of a JIRA issue 

https://jira.coreos.com/browse/OLM-981


Version-Release number of selected component (if applicable):


How reproducible:
always.

Steps to Reproduce:
1. try to install metering via OLM steps as described in https://github.com/operator-framework/operator-metering/blob/master/Documentation/olm-install.md
2.
3.

Actual results:
pruan@MacBook-Pro ~/workspace/testcases/OLM $ oc get deployment                                                                                                                                                                                                                                                                                          
NAME                 READY   UP-TO-DATE   AVAILABLE   AGE
metering-operator    1/1     1            1           35m
presto-coordinator   1/1     1            1           32m
presto-worker        0/0     0            0           32m
reporting-operator   0/1     1            0           32m
pruan@MacBook-Pro ~/workspace/testcases/OLM $ oc get replicaset                                                                                                                                                                                                                                                                                          
NAME                            DESIRED   CURRENT   READY   AGE
metering-operator-7bc5555779    1         1         1       37m
presto-coordinator-655f979584   1         1         1       32m
presto-coordinator-b7bc974db    0         0         0       33m
presto-worker-557795b4c6        0         0         0       33m
presto-worker-7498b7f66b        0         0         0       32m
reporting-operator-6fd6c57d55   1         1         0       33m
reporting-operator-7df5f69d6f   1         1         0       32m

$ oc get pods                                                                                                                                                                                 
NAME                                  READY   STATUS    RESTARTS   AGE
hdfs-datanode-0                       1/1     Running   0          9m33s
hdfs-namenode-0                       1/1     Running   0          9m33s
hive-metastore-0                      1/1     Running   0          9m33s
hive-server-0                         1/1     Running   0          9m33s
metering-operator-7bc5555779-wzjck    2/2     Running   0          10m
presto-coordinator-7494778947-4xkd8   1/1     Running   0          9m33s
presto-coordinator-c768498d9-467bc    0/1     Pending   0          8m8s
reporting-operator-6684ffb68d-z6zrv   0/1     Running   1          8m7s
reporting-operator-7c7d846d6-pk2xk    0/1     Running   1          9m33s
Expected results:


Additional info:

Comment 1 Evan Cordell 2019-03-29 17:55:58 UTC
This is fixed in: https://github.com/operator-framework/operator-lifecycle-manager/pull/792

Comment 3 Wei Sun 2019-04-08 08:48:35 UTC
Hi Peter,could you help check if it could be verified?

Comment 4 Peter Ruan 2019-04-11 03:26:19 UTC
I can now successfully install metering via OLM and only 1 pod is generated.

Comment 6 errata-xmlrpc 2019-06-04 10:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.