Bug 1692066 - Got stuck at final stage - Upgrade complete! Cleaning up and rebooting...
Summary: Got stuck at final stage - Upgrade complete! Cleaning up and rebooting...
Keywords:
Status: CLOSED DUPLICATE of bug 1685471
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-23 22:48 UTC by Artem
Modified: 2019-03-27 08:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-25 14:42:28 UTC


Attachments (Terms of Use)
system-upgrade log file (2.35 MB, text/plain)
2019-03-23 22:48 UTC, Artem
no flags Details
Shram's DNF log (2.04 MB, text/plain)
2019-03-23 23:07 UTC, shram
no flags Details
journal-03.23.log (1.00 MB, text/plain)
2019-03-25 13:27 UTC, Artem
no flags Details

Description Artem 2019-03-23 22:48:59 UTC
Created attachment 1547329 [details]
system-upgrade log file

Description of problem:
  Upgrade from F29 to F30 was successful overall but it being stuck at final stage:
    Upgrade complete! Cleaning up and rebooting...

Version-Release number of selected component (if applicable):
  python3-dnf-plugin-system-upgrade.noarch 4.0.4-1.fc29

How reproducible:
  Run dnf system-upgrade

Steps to Reproduce:
  sudo dnf system-upgrade download --refresh --releasever=30 --setopt='module_platform_id=platform:f30' --enablerepo=*ing

Actual results:
  Upgrade complete! Cleaning up and rebooting...

Expected results:
  Reboot.

Additional info:
  Attached system-upgrade log file.

Comment 1 shram 2019-03-23 23:07:58 UTC
Created attachment 1547330 [details]
Shram's DNF log

I have the same illness as Artem. DNF longs pinned.

Comment 2 Jaroslav Mracek 2019-03-25 13:01:43 UTC
I don't believe that this a bug in DNF. At this point it only removes cache and reboot. Please could you investigate the issue from systemd side?

Comment 3 Artem 2019-03-25 13:27:20 UTC
Created attachment 1547702 [details]
journal-03.23.log

Sure. Attached log file since 2019-03-23 10:48:00.

Probably something there:

Mar 23 11:15:33 pc systemd[1]: Stopping Firmware update daemon...
Mar 23 11:15:33 pc systemd[1]: fwupd.service: Succeeded.
Mar 23 11:15:33 pc systemd[1]: Stopped Firmware update daemon.
Mar 23 11:15:33 pc audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fwupd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 23 11:15:33 pc audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fwupd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 23 11:15:33 pc kernel: audit: type=1130 audit(1553332533.751:116): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fwupd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 23 11:15:33 pc kernel: audit: type=1131 audit(1553332533.751:117): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fwupd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 23 11:15:33 pc systemd[1]: Starting Firmware update daemon...
Mar 23 11:17:03 pc systemd[1]: fwupd.service: Start operation timed out. Terminating.
Mar 23 11:17:03 pc systemd[1]: fwupd.service: Failed with result 'timeout'.
-- Reboot --

Comment 4 Artem 2019-03-25 13:30:04 UTC
Could this is a some kind of kernel (5.0.3) bug?

Comment 5 Zbigniew Jędrzejewski-Szmek 2019-03-25 14:42:28 UTC
Seems to be the same issue...

*** This bug has been marked as a duplicate of bug 1685471 ***


Note You need to log in before you can comment on or make changes to this bug.