Bug 169208 - (fc5-imake) [TRACKER] Packages that use imake, need updating for X.Org X11R7 for FC5
[TRACKER] Packages that use imake, need updating for X.Org X11R7 for FC5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Bill Nottingham
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-09-24 17:50 EDT by Mike A. Harris
Modified: 2014-03-16 22:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-02 05:01:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2005-09-24 17:50:22 EDT
X.Org X11R7 now uses GNU autotools for it's primary buildsystem instead
of imake.  As such, imake has been more or less deprecated for this purpose,
and will likely be phased out in the next couple of years.

A variety of 3rd party application software currently uses imake as a
build system as well, and expects that the X Window System provides imake,
and various config files used to build X.  Since imake is not used to build
X anymore, those Imake config files no longer exist currently, however the
final release of X11R7 is likely to provide something for backwards compatiblity
for 3rd party software for a year or so.

As such, all 3rd party software which currently relies on imake as a build
system, will need to either move to GNU autotools or some other build
system for the long term, or will need to be tweaked to keep working with
imake for the short term.

It is unknown currently what the full impact of this will be to software
packages currently in Fedora Core, Fedora Extras, 3rd party rpm
repositories, as well as other 3rd party OSS and commercial software.

This bug is a tracker bug to track the names of various software and
software packages that currently use imake, and to track them getting
fixed to either: 1) use another build system such as GNU autotools,
2) get tweaked to continue to work with Imake,  3) Be removed from
Fedora Core/Extras or some other resolution.

Currently, this bug is just an information gathering tool.  Once enough
information has been gathered, we can work with the community to decide
what the best approach will be to finding solutions for as many problems
that arise as possible.

If anyone is aware of any software out there currently relying on Imake,
please add a comment here listing as many packages/apps as you can.  For
software which is part of Fedora Core or Extras, please file bug reports
against those packages as well to indicate the Imake deprecation issue,
and mark the new bug reports as Blocking this bug.
Comment 1 Mike A. Harris 2005-09-26 13:14:17 EDT
Comments sent to me in email via Fedora devel mailing list:



'gv' requires imake, to build, right off the top of my head.

But it is in my head, because I heard the 'warning' at Ottawa's x.org BoF ;) and
so went looking through packages I use and rely on; 'ggv' just doesn't come near
'gv' for usability or speed)

Repositories with hits:
  Altlinux
  Fedora
  Netwinder
  OpenNA
  Red Hat

Checking my SRPM archives (14547 packages) with a semi-smart scriptlet, I find
these candidates:

awemidi     (Alt)
Canna
cernlib     (Alt)
fvwm         (Netwinder)
glut         (Netwinder)
gv
libxview     (Alt)
mgetty         (Alt)
mxp         (Netwinder)
openmotif     (Netwinder)
speyes         (Alt)
synaptics
transfig
x2x
x3270  [ouch - I use this -- will test further]
Xaw3d         (Netwinder)
xfig
xfishtank     (Alt)
xforms         (Alt) [the LyX component]
XFree86 (duhhh)
xgammon     (Alt)
xjewel         (Alt)
XmHTML         (Alt)
xpm         (Alt)
xtoolwait     (Alt)

Comment 2 Mike A. Harris 2006-02-02 05:01:37 EST
All of the Fedora Core packages have been updated for X11R7 now for some time.
There are probably latent package bugs yet to find, but for all useful
purposes this tracker is no longer necessary.

Any 3rd party apps that haven't yet been updated, will probably end up
getting updated between now and FC5, or they're unmaintained and nobody
cares about them enough to fix them.  ;o)

Closing as resolved in RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.