Bug 1692089 - cannot install Eclipse (conflict between modular and nonmodular packages)
Summary: cannot install Eclipse (conflict between modular and nonmodular packages)
Status: CLOSED ERRATA
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: ant
Version: unspecified
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException RejectedBlock...
Keywords: CommonBugs
: 1702839 1709249 1709582 (view as bug list)
Depends On:
Blocks: F30FailsToInstall F30FinalFreezeException 1698504
TreeView+ depends on / blocked
 
Reported: 2019-03-24 07:58 UTC by lejeczek
Modified: 2019-05-22 02:41 UTC (History)
45 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-05-17 06:43:24 UTC


Attachments (Terms of Use)
dnf.log (20.47 KB, text/plain)
2019-04-24 08:59 UTC, Mikolaj Izdebski
no flags Details
System upgrade from fc29 to fc30 as of 25th April 2019 (26.58 KB, text/plain)
2019-04-25 15:49 UTC, Michael
no flags Details

Description lejeczek 2019-03-24 07:58:03 UTC
Description of problem:

$ sudo dnf install eclipse-pdt 
Copr repo for themes owned by tcg                                                 1.7 kB/s | 3.0 kB     00:01    
Fedora Modular 30 - x86_64                                                        9.5 kB/s |  20 kB     00:02    
Fedora Modular 30 - x86_64 - Updates                                               25 kB/s |  25 kB     00:01    
Fedora 30 - x86_64 - Updates                                                       21 kB/s |  26 kB     00:01    
Fedora 30 - x86_64                                                                 63 kB/s |  17 kB     00:00    
google-chrome                                                                      16 kB/s | 1.3 kB     00:00    
RPM Fusion for Fedora Rawhide - Free                                              7.9 kB/s |  10 kB     00:01    
RPM Fusion for Fedora Rawhide - Nonfree                                            18 kB/s |  11 kB     00:00    
skype (stable)                                                                    849  B/s | 2.9 kB     00:03    
Error: 
 Problem: package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.ui), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.debug.core), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.launch), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.managedbuilder.core), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.managedbuilder.ui), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.debug.ui), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.doc.user), but none of the providers can be installed
  - package eclipse-cdt-2:9.6.0-5.fc30.x86_64 requires hamcrest, but none of the providers can be installed
  - package eclipse-pdt-6.2.0-2.fc30.noarch requires osgi(org.eclipse.ptp.rdt.sync.ui), but none of the providers can be installed
  - package hamcrest-1.3-25.fc30.noarch requires hamcrest-core = 1.3-25.fc30, but none of the providers can be installed
  - conflicting requests
  - package hamcrest-core-1.3-25.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)


$ sudo dnf install eclipse-pdt --skip-broken
Last metadata expiration check: 0:00:41 ago on Sun 24 Mar 2019 07:30:26 GMT.
Dependencies resolved.

 Problem: package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.ui), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.debug.core), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.launch), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.managedbuilder.core), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.managedbuilder.ui), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.debug.ui), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt), but none of the providers can be installed
  - package eclipse-ptp-9.2.1-2.fc30.x86_64 requires osgi(org.eclipse.cdt.doc.user), but none of the providers can be installed
  - package eclipse-cdt-2:9.6.0-5.fc30.x86_64 requires hamcrest, but none of the providers can be installed
  - package eclipse-pdt-6.2.0-2.fc30.noarch requires osgi(org.eclipse.ptp.rdt.sync.ui), but none of the providers can be installed
  - package hamcrest-1.3-25.fc30.noarch requires hamcrest-core = 1.3-25.fc30, but none of the providers can be installed
  - conflicting requests
  - package hamcrest-core-1.3-25.fc30.noarch is excluded
==================================================================================================================
 Package                     Architecture           Version                          Repository              Size
==================================================================================================================
Skipping packages with broken dependencies:
 eclipse-cdt                 x86_64                 2:9.6.0-5.fc30                   fedora                 121 M
 eclipse-pdt                 noarch                 6.2.0-2.fc30                     fedora                  15 M
 eclipse-ptp                 x86_64                 9.2.1-2.fc30                     fedora                  39 M
 hamcrest                    noarch                 1.3-25.fc30                      fedora                 120 k

Transaction Summary
==================================================================================================================
Skip  4 Packages

Nothing to do.
Complete!
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Michael 2019-04-02 18:29:50 UTC
A system upgrade from fc29 fails because of that:

sudo dnf system-upgrade download --refresh --releasever=30 --setopt='module_platform_id=platform:f30'

Error: 
 Problem 1: ----- REMOVED BECAUSE IT'S NOT RELATED TO ECLIPSE -----
 Problem 2: package eclipse-recommenders-2.5.4-2.fc29.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-recommenders-2.5.4-2.fc29.noarch requires osgi(org.eclipse.jdt.launching), but none of the providers can be installed
  - package eclipse-recommenders-2.5.4-2.fc29.noarch requires osgi(org.eclipse.jdt.ui), but none of the providers can be installed
  - package eclipse-recommenders-2.5.4-2.fc29.noarch requires osgi(org.eclipse.jdt.annotation), but none of the providers can be installed
  - package eclipse-jdt-1:4.11-2.fc30.noarch requires junit5 >= 5.4.0, but none of the providers can be installed
  - eclipse-jdt-1:4.10.0-2.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package eclipse-recommenders-2.5.4-2.fc29.noarch
  - package junit5-5.4.0-1.fc30.noarch is excluded
 Problem 3: package eclipse-cdt-2:9.6.0-5.fc30.x86_64 requires hamcrest, but none of the providers can be installed
  - problem with installed package eclipse-cdt-2:9.6.0-4.fc29.x86_64
  - package hamcrest-1.3-25.fc30.noarch requires hamcrest-core = 1.3-25.fc30, but none of the providers can be installed
  - hamcrest-1.3-24.fc29.noarch does not belong to a distupgrade repository
  - eclipse-cdt-2:9.6.0-4.fc29.x86_64 does not belong to a distupgrade repository
  - package hamcrest-core-1.3-25.fc30.noarch is excluded
 Problem 4: package eclipse-epp-logging-2.0.7-8.fc30.noarch requires osgi(org.apache.httpcomponents.httpclient-cache), but none of the providers can be installed
  - problem with installed package eclipse-epp-logging-2.0.7-5.fc29.noarch
  - package httpcomponents-client-cache-4.5.6-3.fc30.noarch requires mvn(org.apache.httpcomponents:httpclient) = 4.5.6, but none of the providers can be installed
  - httpcomponents-client-cache-4.5.5-5.fc29.noarch does not belong to a distupgrade repository
  - eclipse-epp-logging-2.0.7-5.fc29.noarch does not belong to a distupgrade repository
  - package httpcomponents-client-4.5.6-3.fc30.noarch is excluded
 Problem 5: problem with installed package maven-resolver-transport-file-1:1.1.1-3.fc29.noarch
  - package maven-resolver-transport-file-1:1.3.1-2.fc30.noarch requires mvn(org.apache.maven.resolver:maven-resolver-spi) = 1.3.1, but none of the providers can be installed
  - maven-resolver-transport-file-1:1.1.1-3.fc29.noarch does not belong to a distupgrade repository
  - package maven-resolver-spi-1:1.3.1-2.fc30.noarch is excluded
 Problem 6: problem with installed package maven-resolver-transport-http-1:1.1.1-3.fc29.noarch
  - package maven-resolver-transport-http-1:1.3.1-2.fc30.noarch requires mvn(org.apache.maven.resolver:maven-resolver-util) = 1.3.1, but none of the providers can be installed
  - maven-resolver-transport-http-1:1.1.1-3.fc29.noarch does not belong to a distupgrade repository
  - package maven-resolver-util-1:1.3.1-2.fc30.noarch is excluded
 Problem 7: ----- REMOVED BECAUSE IT'S NOT RELATED TO ECLIPSE -----
 Problem 8: package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.core) = 3.17.0.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.launching) = 3.13.0.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.ui) = 3.17.0.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.ant.launching) = 1.2.400.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.ant.ui) = 3.7.400.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.annotation) = 2.2.200.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.core.manipulation) = 1.11.100.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.debug) = 3.12.200.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.debug.ui) = 3.10.200.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.junit) = 3.11.300.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.junit.runtime) = 3.4.900.v20190308.0658, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires eclipse-jdt = 1:4.11-2.fc30, but none of the providers can be installed
  - package eclipse-pde-1:4.11-2.fc30.x86_64 requires osgi(org.eclipse.jdt.junit.core) = 3.10.200.v20190308.0658, but none of the providers can be installed
  - problem with installed package eclipse-pde-1:4.10.0-2.fc29.x86_64
  - package eclipse-jdt-1:4.11-2.fc30.noarch requires junit5 >= 5.4.0, but none of the providers can be installed
  - eclipse-pde-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - package junit5-5.4.0-1.fc30.noarch is excluded
 Problem 9: problem with installed package eclipse-jdt-1:4.10.0-2.fc29.noarch
  - package eclipse-jdt-1:4.10.0-2.fc29.noarch requires eclipse-platform = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-jdt-1:4.11-2.fc30.noarch requires junit5 >= 5.4.0, but none of the providers can be installed
  - eclipse-platform-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - package junit5-5.4.0-1.fc30.noarch is excluded
 Problem 10: problem with installed package hamcrest-1.3-24.fc29.noarch
  - package hamcrest-1.3-24.fc29.noarch requires hamcrest-core = 1.3-24.fc29, but none of the providers can be installed
  - package hamcrest-1.3-25.fc30.noarch requires hamcrest-core = 1.3-25.fc30, but none of the providers can be installed
  - hamcrest-core-1.3-24.fc29.noarch does not belong to a distupgrade repository
  - package hamcrest-core-1.3-25.fc30.noarch is excluded
 Problem 11: package eclipse-jdt-1:4.10.0-2.fc29.noarch requires eclipse-platform = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-egit-5.3.0-2.fc30.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-egit-5.3.0-2.fc30.noarch requires osgi(org.eclipse.jdt.launching), but none of the providers can be installed
  - package eclipse-egit-5.3.0-2.fc30.noarch requires osgi(org.eclipse.jdt.ui), but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires eclipse-equinox-osgi = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires osgi(org.eclipse.osgi) = 3.13.200, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires osgi(org.eclipse.osgi.services) = 3.7.100, but none of the providers can be installed
  - problem with installed package eclipse-egit-5.2.0-1.fc29.noarch
  - package eclipse-jdt-1:4.11-2.fc30.noarch requires junit5 >= 5.4.0, but none of the providers can be installed
  - eclipse-equinox-osgi-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - eclipse-egit-5.2.0-1.fc29.noarch does not belong to a distupgrade repository
  - package junit5-5.4.0-1.fc30.noarch is excluded
 Problem 12: package eclipse-jdt-1:4.10.0-2.fc29.noarch requires eclipse-platform = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-emf-runtime-2.16.0-2.fc30.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-emf-runtime-2.16.0-2.fc30.noarch requires osgi(org.eclipse.jdt.launching), but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires eclipse-swt = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires osgi(org.eclipse.swt) = 3.109.0, but none of the providers can be installed
  - problem with installed package eclipse-emf-runtime-2.16.0-1.fc29.noarch
  - package eclipse-jdt-1:4.11-2.fc30.noarch requires junit5 >= 5.4.0, but none of the providers can be installed
  - eclipse-swt-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - eclipse-emf-runtime-2.16.0-1.fc29.noarch does not belong to a distupgrade repository
  - package junit5-5.4.0-1.fc30.noarch is excluded
 Problem 13: cannot install both eclipse-platform-1:4.11-2.fc30.x86_64 and eclipse-platform-1:4.10.0-2.fc29.x86_64
  - package eclipse-jdt-1:4.10.0-2.fc29.noarch requires eclipse-platform = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-p2-discovery-1:4.11-2.fc30.noarch requires eclipse-platform = 1:4.11-2.fc30, but none of the providers can be installed
  - package eclipse-linuxtools-changelog-2:7.2.0-4.fc30.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-linuxtools-changelog-2:7.2.0-4.fc30.noarch requires osgi(org.eclipse.jdt.ui), but none of the providers can be installed
  - problem with installed package eclipse-p2-discovery-1:4.10.0-2.fc29.noarch
  - problem with installed package eclipse-linuxtools-changelog-2:7.1.0-3.fc29.noarch
  - package eclipse-jdt-1:4.11-2.fc30.noarch requires junit5 >= 5.4.0, but none of the providers can be installed
  - eclipse-p2-discovery-1:4.10.0-2.fc29.noarch does not belong to a distupgrade repository
  - eclipse-linuxtools-changelog-2:7.1.0-3.fc29.noarch does not belong to a distupgrade repository
  - package junit5-5.4.0-1.fc30.noarch is excluded
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Comment 2 František Zatloukal 2019-04-08 15:27:35 UTC
(In reply to Michael from comment #1)
> A system upgrade from fc29 fails because of that


You should use --allowerasing to upgrade the system when there are such dependency problems. GNOME Software will do that in such cases by default if I am not mistaken.

Comment 3 Michael 2019-04-08 15:32:50 UTC
(In reply to František Zatloukal from comment #2)
> (In reply to Michael from comment #1)
> > A system upgrade from fc29 fails because of that
> 
> 
> You should use --allowerasing to upgrade the system when there are such
> dependency problems. GNOME Software will do that in such cases by default if
> I am not mistaken.

Yes, I'm aware of that. But that would cause eclipse to get removed.
As of now, there's no possibility to have eclipse on fedora 30; neither via an upgrade nor via an installation onto a clean system.

Comment 4 Adam Williamson 2019-04-09 00:37:18 UTC
Discussed at 2019-04-08 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2019-04-08/ . Rejected as a blocker, as Eclipse is not a default part of any release-blocking Fedora configuration, so this doesn't violate any criteria (either about expected components not being included, or out-of-the-box installs upgrading correctly). However, as many people *do* install Eclipse, it is accepted as a freeze exception issue so that upgrades for those folks can be fixed promptly if the fix arrives during Final freeze.

Comment 5 Mikolaj Izdebski 2019-04-09 01:03:31 UTC
The problem seems to be related to JUnit and JavaHamcrest packages.
Root causes that I can see:
- eclipse-jdt requires junit5 >= 5.4.0, but F30 has junit5 5.3.1
- hamcrest requires hamcrest-core 1.3-25, but F30 has hamcrest-core 1.3-23

Comment 6 Mikolaj Izdebski 2019-04-09 09:25:38 UTC
FEDORA-MODULAR-2019-1a862123b9 update should fix the issue.
https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-1a862123b9

Comment 7 Michael 2019-04-10 11:05:14 UTC
Something seems to be still wrong.

With
sudo dnf system-upgrade download --refresh --releasever=30 --setopt='module_platform_id=platform:f30' --enablerepo=updates-testing-modular --enablerepo=updates-testing
I'm getting:

Error: 
 Problem 1: package eclipse-recommenders-2.5.4-2.fc29.noarch requires maven-resolver-transport-file, but none of the providers can be installed
  - package eclipse-recommenders-2.5.4-2.fc29.noarch requires osgi(org.apache.maven.resolver.transport.file), but none of the providers can be installed
  - package maven-resolver-transport-file-1:1.3.1-2.fc30.noarch requires mvn(org.apache.maven.resolver:maven-resolver-spi) = 1.3.1, but none of the providers can be installed
  - maven-resolver-transport-file-1:1.1.1-3.fc29.noarch does not belong to a distupgrade repository
  - problem with installed package eclipse-recommenders-2.5.4-2.fc29.noarch
  - package maven-resolver-spi-1:1.3.1-2.fc30.noarch is excluded
 Problem 2: problem with installed package httpcomponents-client-cache-4.5.5-5.fc29.noarch
  - package httpcomponents-client-cache-4.5.6-3.fc30.noarch requires mvn(org.apache.httpcomponents:httpclient) = 4.5.6, but none of the providers can be installed
  - httpcomponents-client-cache-4.5.5-5.fc29.noarch does not belong to a distupgrade repository
  - package httpcomponents-client-4.5.6-3.fc30.noarch is excluded
 Problem 3: problem with installed package maven-resolver-transport-http-1:1.1.1-3.fc29.noarch
  - package maven-resolver-transport-http-1:1.3.1-2.fc30.noarch requires mvn(org.apache.maven.resolver:maven-resolver-util) = 1.3.1, but none of the providers can be installed
  - maven-resolver-transport-http-1:1.1.1-3.fc29.noarch does not belong to a distupgrade repository
  - package maven-resolver-util-1:1.3.1-2.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)

Comment 8 Mikolaj Izdebski 2019-04-10 13:38:30 UTC
The issue described in this bug (installing eclipse-pdt) is resolved.
I've just tested it with "dnf --enablerepo updates-testing-modular install eclipse-pdt" and it works as expected.

The problem described in comment #7 is a different issue - eclipse-recommenders was retired in Fedora 30, but it is not obsoleted. Please open a separate bug against eclipse-recommenders.

Comment 9 lejeczek 2019-04-13 06:18:27 UTC
Though eclipse-pdt installs now I still see:

$ sudo dnf update --enablerepo=updates-testing-modular
Fedora Modular 30 - x86_64 - Updates                                                21 kB/s |  24 kB     00:01    
Fedora Modular 30 - x86_64 - Test Updates                                           30 kB/s |  21 kB     00:00    
Fedora 30 - x86_64 - Updates                                                        25 kB/s |  25 kB     00:00    
Dependencies resolved.

 Problem: package hamcrest-1.3-23.module_f28+3872+5b76729e.noarch requires hamcrest-core = 1.3-23.module_f28+3872+5b76729e, but none of the providers can be installed
  - cannot install both hamcrest-core-1.3-23.module_2512+68251d4e.noarch and hamcrest-core-1.3-23.module_f28+3872+5b76729e.noarch
  - cannot install both hamcrest-core-1.3-23.module_f28+3872+5b76729e.noarch and hamcrest-core-1.3-23.module_2512+68251d4e.noarch
  - cannot install the best update candidate for package hamcrest-core-1.3-23.module_f28+3872+5b76729e.noarch
  - cannot install the best update candidate for package hamcrest-1.3-23.module_f28+3872+5b76729e.noarch
===================================================================================================================
 Package                Arch        Version                                     Repository                    Size
===================================================================================================================
Upgrading:
 gimp                   x86_64      2:2.10.10-1.module_f30+3878+d4400ad3        updates-testing-modular       24 M
 gimp-libs              x86_64      2:2.10.10-1.module_f30+3878+d4400ad3        updates-testing-modular      2.6 M
 opentest4j             noarch      1.1.1-1.module_f28+3873+06cd63fa            updates-testing-modular       23 k
 univocity-parsers      noarch      2.5.5-5.module_f28+3873+06cd63fa            updates-testing-modular      339 k
Enabling module streams:
 gimp                               2.10                                                                          
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 hamcrest-core          noarch      1.3-23.module_2512+68251d4e                 fedora-modular                58 k

Comment 10 Mikolaj Izdebski 2019-04-13 11:08:49 UTC
First, you should be enabling both updates-testing and updates-testing-modular. Enabling just one of these repos may lead to dependency issues.

Secondly, you'll need to provide a better reproducer. "dnf update" is not a good reproducer as I don't know what packages you have installed, what repos enabled and I can't test all possible update scenarios.

Comment 11 lejeczek 2019-04-13 13:57:49 UTC
hamcrest is required by eclipse-cdt, have them installed, then

These repos I have enabled:

*updates                                       
*updates-modular                             
*updates-testing
*updates-testing-modular  

then just do: dnf update

Comment 12 Fedora Update System 2019-04-17 13:23:13 UTC
ant-1.10-2820190409091957.819b5873 has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Diederik van Lierop 2019-04-21 09:38:24 UTC
Did a clean install of Fedora 30, using the live workstation image of April 19th. 

I'm still having problems installing Eclipse, even after enabling the testing repos:

Am I still missing something? 

[username@localhost ~]$ sudo dnf repolist
Last metadata expiration check: 0:00:40 ago on Sun 21 Apr 2019 11:23:07 AM CEST.
repo id                                           repo name                                                status
*fedora                                           Fedora 30 - x86_64                                       56,586
*fedora-modular                                   Fedora Modular 30 - x86_64                                  132
*updates                                          Fedora 30 - x86_64 - Updates                                  0
*updates-modular                                  Fedora Modular 30 - x86_64 - Updates                          0
*updates-testing                                  Fedora 30 - x86_64 - Test Updates                         8,900
*updates-testing-modular                          Fedora Modular 30 - x86_64 - Test Updates                   136

[username@localhost ~]$ sudo dnf --refresh update 
Fedora Modular 30 - x86_64                         36 kB/s |  19 kB     00:00    
Fedora Modular 30 - x86_64 - Updates               31 kB/s |  24 kB     00:00    
Fedora Modular 30 - x86_64 - Test Updates         101 kB/s |  22 kB     00:00    
Fedora 30 - x86_64 - Test Updates                  27 kB/s |  21 kB     00:00    
Fedora 30 - x86_64 - Updates                       51 kB/s |  24 kB     00:00    
Fedora 30 - x86_64                                 35 kB/s |  20 kB     00:00    
Dependencies resolved.
Nothing to do.
Complete!

[username@localhost ~]$ sudo dnf install eclipse 
Last metadata expiration check: 0:00:15 ago on Sun 21 Apr 2019 11:23:57 AM CEST.
Error: 
 Problem: conflicting requests
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)
[username@localhost ~]$

Comment 14 aziz 2019-04-21 20:02:48 UTC
Enabling the testing repos isn't solving the problem for me either.

[username@localhost ~]$ sudo dnf install eclipse --enablerepo=updates-testing --enablerepo=updates-testing-modular
Last metadata expiration check: 0:00:31 ago on Sun 21 Apr 2019 02:58:41 PM CDT.
Error: 
 Problem: conflicting requests
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)

Comment 15 wyte_sk133 2019-04-22 05:07:35 UTC
I had eclipse-avr (and its dependencies installed).
I also had the similar problem when trying to upgrade to Fedora 30 beta from Fedora 29 using `sudo dnf system-upgrade download --refresh --releasever=30 --setopt=module_platform_id=platform:f30`.

 Problem 1: problem with installed package ant-junit5-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - ant-junit5-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 2: package eclipse-epp-logging-2.0.7-8.fc30.noarch requires osgi(org.apache.httpcomponents.httpclient-cache), but none of the providers can be installed
  - problem with installed package eclipse-epp-logging-2.0.7-5.fc29.noarch
  - package httpcomponents-client-cache-4.5.6-3.fc30.noarch requires mvn(org.apache.httpcomponents:httpclient) = 4.5.6, but none of the providers can be installed
  - httpcomponents-client-cache-4.5.5-5.fc29.noarch does not belong to a distupgrade repository
  - eclipse-epp-logging-2.0.7-5.fc29.noarch does not belong to a distupgrade repository
  - package httpcomponents-client-4.5.6-3.fc30.noarch is excluded
 Problem 3: package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - problem with installed package eclipse-platform-1:4.10.0-2.fc29.x86_64
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-platform-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - ant-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 4: package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-abrt-0.0.3-9.fc30.noarch requires eclipse-platform >= 1:4.3.2, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires eclipse-equinox-osgi = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires osgi(org.eclipse.osgi) = 3.13.200, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires osgi(org.eclipse.osgi.services) = 3.7.100, but none of the providers can be installed
  - problem with installed package eclipse-abrt-0.0.3-7.fc29.noarch
  - package ant-1.10.5-2.fc29.noarch requires ant-lib = 1.10.5-2.fc29, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-equinox-osgi-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - eclipse-abrt-0.0.3-7.fc29.noarch does not belong to a distupgrade repository
  - ant-lib-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 5: package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package ant-antlr-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires eclipse-swt = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires osgi(org.eclipse.swt) = 3.109.0, but none of the providers can be installed
  - problem with installed package eclipse-cdt-native-2:9.6.0-4.fc29.x86_64
  - problem with installed package ant-antlr-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-swt-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - eclipse-cdt-native-2:9.6.0-4.fc29.x86_64 does not belong to a distupgrade repository
  - ant-antlr-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-antlr-1.10.5-4.fc30.noarch is excluded
 Problem 6: package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package ant-apache-bcel-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-jdt-1:4.10.0-2.fc29.noarch
  - problem with installed package ant-apache-bcel-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-jdt-1:4.10.0-2.fc29.noarch does not belong to a distupgrade repository
  - ant-apache-bcel-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-bcel-1.10.5-4.fc30.noarch is excluded
 Problem 7: package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-pde-1:4.11-4.fc30.x86_64 requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package ant-apache-bsf-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-pde-1:4.10.0-2.fc29.x86_64
  - problem with installed package ant-apache-bsf-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-pde-1:4.10.0-2.fc29.x86_64 does not belong to a distupgrade repository
  - ant-apache-bsf-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-bsf-1.10.5-4.fc30.noarch is excluded
 Problem 8: package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.core) = 6.7.0.201903141504, but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.native.serial) = 1.1.100.201903141504, but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.core.native) = 5.10.1.201903141504, but none of the providers can be installed
  - package ant-apache-log4j-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-cdt-2:9.6.0-4.fc29.x86_64
  - problem with installed package ant-apache-log4j-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-cdt-2:9.6.0-4.fc29.x86_64 does not belong to a distupgrade repository
  - ant-apache-log4j-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-log4j-1.10.5-4.fc30.noarch is excluded
 Problem 9: package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-cdt-llvm-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.core) = 6.7.0.201903141504, but none of the providers can be installed
  - package ant-apache-oro-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-cdt-llvm-2:9.6.0-4.fc29.x86_64
  - problem with installed package ant-apache-oro-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-cdt-llvm-2:9.6.0-4.fc29.x86_64 does not belong to a distupgrade repository
  - ant-apache-oro-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-oro-1.10.5-4.fc30.noarch is excluded
 Problem 10: package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-cdt-qt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.core) = 6.7.0.201903141504, but none of the providers can be installed
  - package ant-apache-regexp-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-cdt-qt-2:9.6.0-4.fc29.x86_64
  - problem with installed package ant-apache-regexp-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-cdt-qt-2:9.6.0-4.fc29.x86_64 does not belong to a distupgrade repository
  - ant-apache-regexp-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-regexp-1.10.5-4.fc30.noarch is excluded
 Problem 11: package eclipse-egit-5.3.0-2.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-apache-resolver-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-egit-5.2.0-1.fc29.noarch
  - problem with installed package ant-apache-resolver-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-egit-5.2.0-1.fc29.noarch does not belong to a distupgrade repository
  - ant-apache-resolver-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-resolver-1.10.5-4.fc30.noarch is excluded
 Problem 12: package eclipse-jgit-5.3.0-5.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-apache-xalan2-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-jgit-5.2.0-4.fc29.noarch
  - problem with installed package ant-apache-xalan2-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-jgit-5.2.0-4.fc29.noarch does not belong to a distupgrade repository
  - ant-apache-xalan2-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-apache-xalan2-1.10.5-4.fc30.noarch is excluded
 Problem 13: package eclipse-launchbar-1:2.2.3-1.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-commons-logging-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-launchbar-1:2.2.2-1.fc29.noarch
  - problem with installed package ant-commons-logging-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-launchbar-1:2.2.2-1.fc29.noarch does not belong to a distupgrade repository
  - ant-commons-logging-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-commons-logging-1.10.5-4.fc30.noarch is excluded
 Problem 14: package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-commons-net-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-mylyn-3.25.0-0.4.fc29.noarch
  - problem with installed package ant-commons-net-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-mylyn-3.25.0-0.4.fc29.noarch does not belong to a distupgrade repository
  - ant-commons-net-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-commons-net-1.10.5-4.fc30.noarch is excluded
 Problem 15: package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.workbench) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.net) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.repositories.core) = 1.17.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.repositories.http.core) = 1.17.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.xmlrpc) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package ant-javamail-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-mylyn-tasks-bugzilla-3.25.0-0.4.fc29.noarch
  - problem with installed package ant-javamail-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-mylyn-tasks-bugzilla-3.25.0-0.4.fc29.noarch does not belong to a distupgrade repository
  - ant-javamail-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-javamail-1.10.5-4.fc30.noarch is excluded
 Problem 16: package eclipse-remote-3.0.1-2.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-jdepend-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-remote-3.0.0-0.6.git14c6611.fc29.noarch
  - problem with installed package ant-jdepend-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-remote-3.0.0-0.6.git14c6611.fc29.noarch does not belong to a distupgrade repository
  - ant-jdepend-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-jdepend-1.10.5-4.fc30.noarch is excluded
 Problem 17: package eclipse-usage-4.11.0-1.fc30.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc30.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-epp-logging-2.0.7-8.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-epp-logging-2.0.7-5.fc29.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-jmf-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-usage-4.9.0-1.fc29.noarch
  - problem with installed package ant-jmf-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-usage-4.9.0-1.fc29.noarch does not belong to a distupgrade repository
  - ant-jmf-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-jmf-1.10.5-4.fc30.noarch is excluded
 Problem 18: package eclipse-emf-runtime-2.16.0-2.fc30.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-emf-runtime-2.16.0-2.fc30.noarch requires osgi(org.eclipse.jdt.launching), but none of the providers can be installed
  - package eclipse-jdt-1:4.10.0-2.fc29.noarch requires eclipse-platform = 1:4.10.0-2.fc29, but none of the providers can be installed
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-jsch-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-emf-runtime-2.16.0-1.fc29.noarch
  - problem with installed package ant-jsch-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-emf-runtime-2.16.0-1.fc29.noarch does not belong to a distupgrade repository
  - ant-jsch-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-jsch-1.10.5-4.fc30.noarch is excluded
 Problem 19: package eclipse-avr-2.4.2-8.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.6.0-4.fc29.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-junit-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-avr-2.4.2-6.fc29.noarch
  - problem with installed package ant-junit-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-avr-2.4.2-6.fc29.noarch does not belong to a distupgrade repository
  - ant-junit-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-junit-1.10.5-4.fc30.noarch is excluded
 Problem 20: package eclipse-linuxtools-libhover-7.2.0-5.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.6.0-4.fc29.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-swing-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-linuxtools-libhover-7.1.0-3.fc29.noarch
  - problem with installed package ant-swing-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-linuxtools-libhover-7.1.0-3.fc29.noarch does not belong to a distupgrade repository
  - ant-swing-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-swing-1.10.5-4.fc30.noarch is excluded
 Problem 21: package eclipse-tm-terminal-connectors-4.5.100-1.fc30.noarch requires osgi(org.eclipse.cdt.core.native), but none of the providers can be installed
  - package eclipse-tm-terminal-connectors-4.5.100-1.fc30.noarch requires osgi(org.eclipse.cdt.native.serial), but none of the providers can be installed
  - package eclipse-tm-terminal-connectors-4.5.100-1.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.6.0-4.fc29.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-testutil-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-tm-terminal-connectors-4.4.0-4.fc29.noarch
  - problem with installed package ant-testutil-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-tm-terminal-connectors-4.4.0-4.fc29.noarch does not belong to a distupgrade repository
  - ant-testutil-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-testutil-1.10.5-4.fc30.noarch is excluded
 Problem 22: package eclipse-tm-terminal-4.5.100-1.fc30.noarch requires osgi(org.eclipse.egit.ui), but none of the providers can be installed
  - package eclipse-egit-5.2.0-1.fc29.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-egit-5.3.0-2.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.10.0-2.fc29.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-2.fc29.noarch requires ant = 1.10.5-2.fc29, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-2.fc29.noarch
  - package ant-xz-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - problem with installed package eclipse-tm-terminal-4.4.0-4.fc29.noarch
  - problem with installed package ant-xz-1.10.5-2.fc29.noarch
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - eclipse-tm-terminal-4.4.0-4.fc29.noarch does not belong to a distupgrade repository
  - ant-xz-1.10.5-2.fc29.noarch does not belong to a distupgrade repository
  - package ant-1.10.5-4.fc30.noarch is excluded
  - package ant-xz-1.10.5-4.fc30.noarch is excluded

Comment 16 Zbigniew Jędrzejewski-Szmek 2019-04-24 07:41:30 UTC
On up-to-date F30 installation:
$ sudo dnf install eclipse --enablerepo=updates-testing --enablerepo=updates-testing-modular --best --allowerasing
Last metadata expiration check: 0:31:44 ago on Wed 24 Apr 2019 09:05:59 AM CEST.
Error: 
 Problem: package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-xz, but none of the providers can be installed
  - package ant-xz-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant = 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
  - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and ant-1.10.5-4.fc30.noarch
  - cannot install the best candidate for the job
  - package ant-xz-1.10.5-4.fc30.noarch is excluded
  - package ant-1.10.5-4.fc30.noarch is excluded

It seems dnf tried to install ant-xz-1.10.5-1.module_f28+3873+06cd63fa over ant-xz-1.10.5-4.fc30.noarch.
I haven't the leastest idea whether this is right or wrong.

Comment 17 Mikolaj Izdebski 2019-04-24 08:59 UTC
Created attachment 1558025 [details]
dnf.log

Not reproducible for me - on fully-updated x86_64 Fedora 30 installation with testing repos enabled I can install eclipse just fine. Log attached.

Comment 18 Michael 2019-04-24 09:28:34 UTC
(In reply to Mikolaj Izdebski from comment #17)
> Created attachment 1558025 [details]
> dnf.log
> 
> Not reproducible for me - on fully-updated x86_64 Fedora 30 installation
> with testing repos enabled I can install eclipse just fine. Log attached.

On an up-to-date fedora 30, eclipse cannot be installed on my side as well:

sudo dnf groupinstall "Fedora Eclipse" --enablerepo=updates-testing --enablerepo=updates-testing-modular
Fedora Modular 30 - x86_64 - Test Updates                                                                                      22 kB/s |  23 kB     00:01    
Fedora Modular 30 - x86_64 - Test Updates                                                                                     520 kB/s | 257 kB     00:00    
Fedora 30 - x86_64 - Test Updates                                                                                             190 kB/s |  23 kB     00:00    
Fedora 30 - x86_64 - Test Updates                                                                                             2.2 MB/s | 4.2 MB     00:01    
Last metadata expiration check: 0:00:01 ago on Wed 24 Apr 2019 11:25:17 CEST.
Error: 
 Problem 1: conflicting requests
  - package eclipse-pydev-1:7.1.0-2.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 2: conflicting requests
  - package eclipse-pde-1:4.11-4.fc30.x86_64 requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 3: conflicting requests
  - package eclipse-packagekit-0.2.0-11.fc30.noarch requires eclipse-platform >= 3.4.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 4: conflicting requests
  - package eclipse-mpc-1.7.5-2.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 5: conflicting requests
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 6: conflicting requests
  - package eclipse-epp-logging-2.0.7-8.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 7: conflicting requests
  - package eclipse-egit-github-5.3.0-1.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 8: conflicting requests
  - package eclipse-egit-5.3.0-2.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 9: conflicting requests
  - package eclipse-abrt-0.0.3-9.fc30.noarch requires eclipse-platform >= 1:4.3.2, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 10: conflicting requests
  - package eclipse-linuxtools-valgrind-7.2.0-5.fc30.noarch requires osgi(org.swtchart), but none of the providers can be installed
  - package swt-chart-0.10.0-7.fc30.noarch requires eclipse-platform >= 3.4.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 11: conflicting requests
  - package eclipse-linuxtools-systemtap-7.2.0-5.fc30.noarch requires osgi(org.swtchart), but none of the providers can be installed
  - package swt-chart-0.10.0-7.fc30.noarch requires eclipse-platform >= 3.4.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 12: conflicting requests
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.remote.core), but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.remote.ui), but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires eclipse-remote >= 2.1.0, but none of the providers can be installed
  - package eclipse-remote-3.0.1-2.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 13: conflicting requests
  - package eclipse-pydev-mylyn-1:7.1.0-2.fc30.noarch requires eclipse-pydev = 1:7.1.0-2.fc30, but none of the providers can be installed
  - package eclipse-pydev-mylyn-1:7.1.0-2.fc30.noarch requires osgi(org.python.pydev) = 7.1.0.v20190220.1623, but none of the providers can be installed
  - package eclipse-pydev-1:7.1.0-2.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 14: conflicting requests
  - package eclipse-mylyn-versions-cvs-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.team.cvs.core), but none of the providers can be installed
  - package eclipse-pde-1:4.11-4.fc30.x86_64 requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 15: conflicting requests
  - package eclipse-mylyn-context-pde-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.pde.ui), but none of the providers can be installed
  - package eclipse-mylyn-context-pde-3.25.0-0.6.fc30.noarch requires eclipse-pde, but none of the providers can be installed
  - package eclipse-mylyn-context-pde-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.pde.api.tools.ui), but none of the providers can be installed
  - package eclipse-mylyn-context-pde-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.team.cvs.core), but none of the providers can be installed
  - package eclipse-mylyn-context-pde-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.team.cvs.ui), but none of the providers can be installed
  - package eclipse-pde-1:4.11-4.fc30.x86_64 requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 16: conflicting requests
  - package eclipse-subclipse-4.3.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core), but none of the providers can be installed
  - package eclipse-subclipse-4.3.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui), but none of the providers can be installed
  - package eclipse-subclipse-4.3.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.team.ui), but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 17: conflicting requests
  - package eclipse-mylyn-versions-subclipse-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 18: conflicting requests
  - package eclipse-mylyn-versions-git-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 19: conflicting requests
  - package eclipse-mylyn-tasks-web-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-web-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.net) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-web-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-web-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.workbench) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-web-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-web-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 20: conflicting requests
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.net) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.workbench) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.xmlrpc) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-trac-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 21: conflicting requests
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.net) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.repositories.core) = 1.17.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.repositories.http.core) = 1.17.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.workbench) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.xmlrpc) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-tasks-bugzilla-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 22: conflicting requests
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.workbench) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.context.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.context.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.ide.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.monitor.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.monitor.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.resources.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-java-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 23: conflicting requests
  - package eclipse-mylyn-context-cdt-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-cdt-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-cdt-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.context.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-cdt-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.context.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-cdt-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.monitor.core) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-context-cdt-3.25.0-0.6.fc30.noarch requires osgi(org.eclipse.mylyn.monitor.ui) = 3.25.0.v20190316.2127, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 24: conflicting requests
  - package eclipse-egit-mylyn-5.3.0-2.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.core), but none of the providers can be installed
  - package eclipse-egit-mylyn-5.3.0-2.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui), but none of the providers can be installed
  - package eclipse-egit-mylyn-5.3.0-2.fc30.noarch requires osgi(org.eclipse.mylyn.context.core), but none of the providers can be installed
  - package eclipse-egit-mylyn-5.3.0-2.fc30.noarch requires osgi(org.eclipse.mylyn.team.ui), but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 25: conflicting requests
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.tasks.ui), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.commons.core), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.commons.ui), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.context.core), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.context.ui), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.ide.ui), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.monitor.core), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.monitor.ui), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires osgi(org.eclipse.mylyn.resources.ui), but none of the providers can be installed
  - package eclipse-dltk-mylyn-5.11.0-1.fc30.noarch requires eclipse-mylyn >= 3.21.0-4, but none of the providers can be installed
  - package eclipse-mylyn-3.25.0-0.6.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 26: conflicting requests
  - package eclipse-cdt-docker-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.launchbar.ui), but none of the providers can be installed
  - package eclipse-launchbar-1:2.2.3-1.fc30.noarch requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 27: conflicting requests
  - package eclipse-linuxtools-docker-7.2.0-5.fc30.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-linuxtools-docker-7.2.0-5.fc30.noarch requires osgi(org.eclipse.jdt.launching), but none of the providers can be installed
  - package eclipse-linuxtools-docker-7.2.0-5.fc30.noarch requires osgi(org.eclipse.jdt.debug.ui), but none of the providers can be installed
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 28: conflicting requests
  - package eclipse-linuxtools-changelog-2:7.2.0-5.fc30.noarch requires osgi(org.eclipse.jdt.core), but none of the providers can be installed
  - package eclipse-linuxtools-changelog-2:7.2.0-5.fc30.noarch requires osgi(org.eclipse.jdt.ui), but none of the providers can be installed
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 29: conflicting requests
  - package eclipse-usage-4.11.0-1.fc30.noarch requires osgi(org.eclipse.epp.logging.aeri.core), but none of the providers can be installed
  - package eclipse-usage-4.11.0-1.fc30.noarch requires osgi(org.eclipse.epp.logging.aeri.ide), but none of the providers can be installed
  - package eclipse-epp-logging-2.0.7-8.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 30: conflicting requests
  - package eclipse-dltk-sh-5.11.0-1.fc30.noarch requires osgi(org.eclipse.dltk.core) = 5.11.0.201903141314, but none of the providers can be installed
  - package eclipse-dltk-sh-5.11.0-1.fc30.noarch requires osgi(org.eclipse.dltk.debug.ui) = 5.11.0.201903141314, but none of the providers can be installed
  - package eclipse-dltk-sh-5.11.0-1.fc30.noarch requires osgi(org.eclipse.dltk.launching) = 5.11.0.201903141314, but none of the providers can be installed
  - package eclipse-dltk-sh-5.11.0-1.fc30.noarch requires osgi(org.eclipse.dltk.ui) = 5.11.0.201903141314, but none of the providers can be installed
  - package eclipse-dltk-5.11.0-1.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 31: conflicting requests
  - package eclipse-linuxtools-perf-7.2.0-5.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 32: conflicting requests
  - package eclipse-linuxtools-libhover-7.2.0-5.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 33: conflicting requests
  - package eclipse-linuxtools-gprof-7.2.0-5.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 34: conflicting requests
  - package eclipse-linuxtools-gcov-7.2.0-5.fc30.noarch requires osgi(org.eclipse.cdt.core), but none of the providers can be installed
  - package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 35: conflicting requests
  - package eclipse-linuxtools-rpm-editor-7.2.0-5.fc30.noarch requires osgi(org.eclipse.linuxtools.profiling.launch) = 3.3.0.201904081410, but none of the providers can be installed
  - package eclipse-linuxtools-rpm-editor-7.2.0-5.fc30.noarch requires osgi(org.eclipse.linuxtools.tools.launch.core) = 3.3.0.201904081410, but none of the providers can be installed
  - package eclipse-linuxtools-7.2.0-5.fc30.noarch requires osgi(org.swtchart), but none of the providers can be installed
  - package swt-chart-0.10.0-7.fc30.noarch requires eclipse-platform >= 3.4.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problem 36: conflicting requests
  - package eclipse-linuxtools-vagrant-7.2.0-5.fc30.noarch requires osgi(org.eclipse.tm.terminal.view.core), but none of the providers can be installed
  - package eclipse-linuxtools-vagrant-7.2.0-5.fc30.noarch requires osgi(org.eclipse.tm.terminal.view.ui), but none of the providers can be installed
  - package eclipse-linuxtools-vagrant-7.2.0-5.fc30.noarch requires osgi(org.eclipse.tm.terminal.connector.ssh), but none of the providers can be installed
  - package eclipse-tm-terminal-4.5.100-1.fc30.noarch requires osgi(org.eclipse.egit.ui), but none of the providers can be installed
  - package eclipse-egit-5.3.0-2.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)

Comment 19 Michael 2019-04-24 09:39:46 UTC
(In reply to Michael from comment #18)
> 
> On an up-to-date fedora 30, eclipse cannot be installed on my side as well:
> 
> sudo dnf groupinstall "Fedora Eclipse" --enablerepo=updates-testing --enablerepo=updates-testing-modular

I forgot to mention that 'up-to-date fedora 30' means testing-repos disabled on my side.
So the update path from stable to testing seems to be broken.

Comment 20 space88man 2019-04-24 12:15:10 UTC
I encountered this trying to dnf system-upgrade from f29 -> f30.

Somehow both modular ant/maven are enabled (I didn't  explicitly do this) by either
the upgrade process or f29's Eclipse. 

I had to

dnf module disable ant 
dnf module disable maven

for this to work.

Comment 21 Yann Droneaud 2019-04-24 12:42:11 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #16)
> On up-to-date F30 installation:
> $ sudo dnf install eclipse --enablerepo=updates-testing
> --enablerepo=updates-testing-modular --best --allowerasing
> Last metadata expiration check: 0:31:44 ago on Wed 24 Apr 2019 09:05:59 AM
> CEST.
> Error: 
>  Problem: package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform
> = 1:4.11-4.fc30, but none of the providers can be installed
>   - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but
> none of the providers can be installed
>   - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30,
> but none of the providers can be installed
>   - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-xz, but none
> of the providers can be installed
>   - package ant-xz-1.10.5-1.module_f28+3873+06cd63fa.noarch requires ant =
> 1.10.5-1.module_f28+3873+06cd63fa, but none of the providers can be installed
>   - cannot install both ant-1.10.5-1.module_f28+3873+06cd63fa.noarch and
> ant-1.10.5-4.fc30.noarch
>   - cannot install the best candidate for the job
>   - package ant-xz-1.10.5-4.fc30.noarch is excluded
>   - package ant-1.10.5-4.fc30.noarch is excluded
> 

This seems related to bug #1631451

Comment 22 Michael 2019-04-25 15:49 UTC
Created attachment 1558728 [details]
System upgrade from fc29 to fc30 as of 25th April 2019

As of today, a perfectly up-to-date Fedora 29 installation (testing repos disabled ) with Eclipse cannot be upgraded to Fedora 30 because of ant releated problems. See attached output.

Comment 23 Zbigniew Jędrzejewski-Szmek 2019-04-25 18:36:40 UTC
Since multiple people are reporting that they see this, I'll reset the status.

Comment 24 lejeczek 2019-04-26 18:12:41 UTC
On f30 which now installs eclipse-pdt okey, which was the original issue for me, I see this:

$ sudo dnf update 
Copr repo for themes owned by tcg                                             2.3 kB/s | 3.5 kB     00:01    
Fedora Modular 30 - x86_64                                                     17 kB/s |  19 kB     00:01    
Fedora Modular 30 - x86_64 - Updates                                           30 kB/s |  24 kB     00:00    
Fedora Modular 30 - x86_64 - Test Updates                                      23 kB/s |  22 kB     00:00    
Fedora 30 - x86_64 - Test Updates                                              19 kB/s |  21 kB     00:01    
Fedora 30 - x86_64 - Updates                                                   20 kB/s |  25 kB     00:01    
Fedora 30 - x86_64                                                             16 kB/s |  16 kB     00:00    
google-chrome                                                                 5.8 kB/s | 1.3 kB     00:00    
RPM Fusion for Fedora 30 - Free - Updates                                      19 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Free                                                28 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree - Updates                                   19 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree                                             45 kB/s |  10 kB     00:00    
skype (stable)                                                                1.4 kB/s | 2.9 kB     00:02    
Dependencies resolved.

 Problem: package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - cannot install the best update candidate for package ant-junit5-1.10.5-3.module_2512+68251d4e.noarch
  - package ant-1.10.5-4.fc30.noarch is excluded
==============================================================================================================
 Package                    Architecture           Version                       Repository              Size
==============================================================================================================
Skipping packages with broken dependencies:
 ant-junit5                 noarch                 1.10.5-4.fc30                 fedora                  63 k

Transaction Summary
==============================================================================================================
Skip  1 Package

Nothing to do.
Complete!

Comment 25 Mat Booth 2019-05-01 11:10:55 UTC
(In reply to Michael from comment #22)
> Created attachment 1558728 [details]
> System upgrade from fc29 to fc30 as of 25th April 2019
> 
> As of today, a perfectly up-to-date Fedora 29 installation (testing repos
> disabled ) with Eclipse cannot be upgraded to Fedora 30 because of ant
> releated problems. See attached output.

So you didn't get the ant module updates for F29 from updates-testing before upgrading.

@mizdebsk -- Will pushing the F29 ant module updates to stable fix this for users?

Comment 26 Michael 2019-05-01 12:11:49 UTC
(In reply to Mat Booth from comment #25)
> So you didn't get the ant module updates for F29 from updates-testing before
> upgrading.

Well, that could be a reason for one of the aspects.

But there's another aspect too:
On a system where I installed Fedora 30 with Eclipse (which was possible during a short time window), I cannot perform an update of ant.
There the output is:

sudo dnf upgrade --refresh
...
 Problem: package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - cannot install the best update candidate for package ant-junit5-1.10.5-3.module_2512+68251d4e.noarch
  - package ant-1.10.5-4.fc30.noarch is excluded
=======================================================================================
 Package              Architecture     Version                  Repository        Size
=======================================================================================
Skipping packages with broken dependencies:
 ant-junit5           noarch           1.10.5-4.fc30            fedora            63 k

Transaction Summary
=======================================================================================
Skip  1 Package

Comment 27 Mat Booth 2019-05-01 14:02:27 UTC
(In reply to Mat Booth from comment #25)
> (In reply to Michael from comment #22)
> > Created attachment 1558728 [details]
> > System upgrade from fc29 to fc30 as of 25th April 2019
> > 
> > As of today, a perfectly up-to-date Fedora 29 installation (testing repos
> > disabled ) with Eclipse cannot be upgraded to Fedora 30 because of ant
> > releated problems. See attached output.
> 
> So you didn't get the ant module updates for F29 from updates-testing before
> upgrading.
> 
> @mizdebsk -- Will pushing the F29 ant module updates to stable fix this for
> users?

Looking close, the "ant-junit5" appears to be missing from recent module builds, e.g.: https://koji.fedoraproject.org/koji/buildinfo?buildID=1247018

Is this intentional, Mikolaj?

Comment 28 Gerrit Slomma 2019-05-02 09:58:02 UTC
Somehow I had to disable module ant too.
Before doing so it was not flaged with either x, e, or i, afterwards it got flaged with x.
Now the "dnf system-upgrade download --refresh --releasever=30" runs without problems (after deleting an old python2-libdnf manually).

Comment 29 Jan Vlug 2019-05-02 12:00:31 UTC
I also had problems upgrading to Fedora 30.
I had to do:
# dnf module disable ant
# dnf remove python2-hawkey
# dnf remove python2-libdnf

After this:
# dnf system-upgrade download --releasever=30
asked whether it was ok to download the packages.

I did not do the upgrade yet.

I cannot remember to have ever enabled a module for ant.

The python2-* issues are probably not related to this bug. I will create a new one for that.

Comment 30 Mattias Ellert 2019-05-02 21:10:19 UTC
Description of problem:

The ant package is provided by both a normal rpm and a module declared to be default. The version provided by the default module is missing some subpackages that the normal rpm provides:

 - ant-javadoc
 - ant-junit5
 - ant-manual

Since the module is declared default, the packages in the module override the package from the normal rpm, and the packages from the normal rpm are not available for installation (dnf says they are excluded).

The ant-junit5 package is not provided by the module, so the normal rpm version is not overridden. However, it is not installable since it depends on the non-module version of packages built from the same srpm (as it should according to the guidelines).

# dnf install ant-junit5
Last metadata expiration check: 4:26:59 ago on Thu May  2 17:56:10 2019.
Error: 
 Problem: package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded

A srpm built as part of a module declared default must provide all subpackages that the non-module srpm builds, or alternatively obsolete the subpackages it does not build (this choice is only acceptable if there are no other packages with dependencies or build dependencies on the subpackage). Otherwise the subpackages provided by the normal rpm that are not excluded by the module become uninstallable.

Since ant-junit5 is uninstallable, eclipse-platform that depends on ant-junit5 is also uninstallable, as are all packages that in turn depend on eclipse-platform, which is quite a long list:

# dnf repoquery --whatrequires eclipse-platform
Last metadata expiration check: 4:47:59 ago on Thu May  2 17:56:10 2019.
eclipse-abrt-0:0.0.3-9.fc30.noarch
eclipse-cdt-native-2:9.7.0-1.fc30.x86_64
eclipse-color-theme-0:1.0.0-11.fc30.noarch
eclipse-contributor-tools-1:4.11-4.fc30.x86_64
eclipse-dltk-0:5.11.0-1.fc30.noarch
eclipse-egit-0:5.3.0-2.fc30.noarch
eclipse-egit-github-0:5.3.0-1.fc30.noarch
eclipse-epic-0:0.7.5-4.fc30.noarch
eclipse-epp-logging-0:2.0.7-8.fc30.noarch
eclipse-gef-0:3.11.0-9.fc30.noarch
eclipse-jdt-1:4.11-4.fc30.noarch
eclipse-jgit-0:5.3.0-5.fc30.noarch
eclipse-launchbar-1:2.2.3-1.fc30.noarch
eclipse-mpc-0:1.7.5-2.fc30.noarch
eclipse-mylyn-0:3.25.0-0.6.fc30.noarch
eclipse-p2-discovery-1:4.11-4.fc30.noarch
eclipse-packagekit-0:0.2.0-11.fc30.noarch
eclipse-pde-1:4.11-4.fc30.x86_64
eclipse-pydev-1:7.1.0-2.fc30.x86_64
eclipse-quickrex-0:3.5.0-31.fc30.noarch
eclipse-remote-0:3.0.1-2.fc30.noarch
eclipse-rse-0:3.7.100-2.fc30.noarch
jacoco-0:0.7.8-7.fc30.noarch
jetty-httpservice-0:9.4.15-1.v20190215.fc30.noarch
swt-chart-0:0.10.0-7.fc30.noarch
tycho-0:1.3.0-4.fc30.noarch

Version-Release number of selected component (if applicable):

ant-1.10.5-1.module_f28+3873+06cd63fa
ant-1.10.5-4.fc30

How reproducible:

Always

Steps to Reproduce:
1. dnf install ant-junit5

Actual results:

Failed install of ant-junit5 because it is not compatible with the ant package.

Expected results:

Install of ant-junit5 compatible with the ant package.

Additional info:

When I did the dnf system-upgrade from 29 to 30 I had to use --allowerasing, and dnf removed all packages previously installed that had ant-junit5 in its dependency chain, including eclipse and jetty.

Comment 31 Douglas 2019-05-02 21:53:45 UTC
Unable to install eclipse on Fedora Workstation 30. Clean install. Default repositories.

Package eclipse:

Error:
 Problem: package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)



Package eclipse-pdt:

Error:
 Problem: package eclipse-dltk-5.11.0-1.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires eclipse-dltk >= 5.9.0, but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.annotations), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.core), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.core.manipulation), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.debug.ui), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.launching), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.ui), but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)

Comment 32 Simone Marchioni 2019-05-05 12:13:42 UTC
Same problem here.

Fresh install of Fedora Workstation 30 (no upgrade). Default repositories active.

sudo dnf install eclipse-platform eclipse-pdt

Ultima verifica della scadenza dei metadati: 0:06:16 fa il dom 5 mag 2019, 14:04:40.
Errore: 
 Problema 1: package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded
 Problema 2: package eclipse-dltk-5.11.0-1.fc30.noarch requires eclipse-platform >= 1:4.6.0, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires eclipse-dltk >= 5.9.0, but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.annotations), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.core), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.core.manipulation), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.debug.ui), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.launching), but none of the providers can be installed
  - package eclipse-pdt-6.2.0-3.fc30.noarch requires osgi(org.eclipse.dltk.ui), but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded

Comment 33 Bruce Bigby 2019-05-05 16:06:24 UTC
I'm unable to install eclipse as well, after a fresh upgrade.  The issue is involving ant:

--------

"bbigby@beast dnfdrgora]$ dnf install eclipse-cdt
Error: This command has to be run under the root user.
[bbigby@beast dnfdrgora]$ sudo dnf install eclipse-cdt
Last metadata expiration check: 0:01:08 ago on Sun 05 May 2019 12:01:43 PM EDT.
Error: 
 Problem: package eclipse-cdt-native-2:9.7.0-1.fc30.x86_64 requires eclipse-platform, but none of the providers can be installed
  - package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.core) = 6.7.0.201903141504, but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.native.serial) = 1.1.100.201903141504, but none of the providers can be installed
  - package eclipse-cdt-2:9.7.0-1.fc30.x86_64 requires osgi(org.eclipse.cdt.core.native) = 5.10.1.201903141504, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)

----

Comment 34 Mat Booth 2019-05-07 09:27:40 UTC
Does the workaround documented above work for you?

Doing "dnf module disable ant" before installing Eclipse?

Comment 35 Simone Marchioni 2019-05-07 09:33:18 UTC
Can confirm the workaround works: after a "dnf module disable ant" Eclipse installs flawlessly.

Comment 36 Mikolaj Izdebski 2019-05-07 09:44:17 UTC
ant-junit5 package is expected to be available as part of ant:1.10 module stream, which is delivered in Fedora 30 as default stream. However, ant component build pointed out by Mat in comment #27 is part of javapackages-tools module, not ant module. ant-junit5 subpackage is indeed missing in that build, but that build is not shipped in Fedora, so that should not be relevant to the issue described in this bug.

Many people have reported issues, but so far I haven't found any way to reproduce them. Last time I tried (before Fedora 30 release) I was able to successfully install eclipse-platform and various other Eclipse plugins in a clean Fedora 30 system (Cloud variant). I will try several different ways (like non-Cloud variants, upgrades from Fedora 29), but if someone has a clear reproducer, that would be very helpful.

Comment 37 Michael 2019-05-07 09:58:55 UTC
Well, for me it appeared on two different paths:

#1:
-> Install Fedora 29.
-> Install package group "Fedora Eclipse".
-> Apply all stable updates (testing repos disabled).
-> Try a system upgrade to Fedora 30 (this will auto-enable the ant module and cause the issue).

#2:
-> Install Fedora 30 beta.
-> Apply all stable updates (testing repos disabled).
-> Try to install package group "Fedora Eclipse" (this will auto-enable the ant module and cause the issue).


I haven't tried yet starting from the released version of Fedora 30 but it shouldn't make any difference when all the updates are installed.

Comment 38 pdimitrov 2019-05-07 12:24:59 UTC
Happens for me too, with completely fresh Fedora 30 install.


$ sudo dnf install eclipse
Fedora Modular 30 - x86_64                                                                                                                                            578  B/s | 4.5 kB     00:07    
Fedora Modular 30 - x86_64 - Updates                                                                                                                                  734  B/s | 6.6 kB     00:09    
Fedora 30 - x86_64 - Updates                                                                                                                                          3.5 kB/s | 5.5 kB     00:01    
Fedora 30 - x86_64                                                                                                                                                    2.2 kB/s | 4.5 kB     00:02    
RPM Fusion for Fedora 30 - Free - Updates                                                                                                                             2.3 kB/s |  14 kB     00:06    
RPM Fusion for Fedora 30 - Free                                                                                                                                       778  B/s | 2.6 kB     00:03    
RPM Fusion for Fedora 30 - Nonfree - Updates                                                                                                                          2.0 kB/s |  13 kB     00:06    
RPM Fusion for Fedora 30 - Nonfree                                                                                                                                    1.9 kB/s |  15 kB     00:07    
Error: 
 Problem: package eclipse-platform-1:4.11-4.fc30.x86_64 requires ant-junit5, but none of the providers can be installed
  - package eclipse-jdt-1:4.11-4.fc30.noarch requires eclipse-platform = 1:4.11-4.fc30, but none of the providers can be installed
  - package ant-junit5-1.10.5-4.fc30.noarch requires ant = 1.10.5-4.fc30, but none of the providers can be installed
  - conflicting requests
  - package ant-1.10.5-4.fc30.noarch is excluded
(try to add '--skip-broken' to skip uninstallable packages)

Comment 39 Mikolaj Izdebski 2019-05-07 13:59:02 UTC
I can't reproduce the issue using steps from comment #38 - "dnf install eclipse" works fine on a clean, fully-updated Fedora 30 Cloud system.

But I found a different way to reproduce the issue:
1. dnf module enable ant:1.10
2. dnf install eclipse-platform

This gives the familiar error message about dependency issues.

I am investigating the root cause of the issue.

Comment 40 Mikolaj Izdebski 2019-05-07 14:52:15 UTC
I've commited a fix and I am building updated ant module.

Comment 41 Michael 2019-05-07 14:54:09 UTC
What causes those modules to get enabled at first place?

I haven't explicitly enabled any module but I have those:

sudo dnf module list --enabled
Last metadata expiration check: 0:00:13 ago on Tue 07 May 2019 16:50:32 CEST.
Fedora Modular 30 - x86_64
Name                 Stream                  Profiles                       Summary                                                                                 
ant                  1.10 [d][e]             default [d]                    Java build tool                                                                         
gimp                 2.10 [d][e]             devel, default [d]             GIMP                                                                                    
jmc                  latest [e]              core, default [d]              Java Mission Control is a profiling and diagnostics tool for the Hotspot JVM            
libgit2              0.27 [d][e]                                            Library implementation of Git                                                           
maven                3.5 [d][e]              default [d]                    Java project management and project comprehension tool                                  
scala                2.10 [d][e]             default [d]                    A hybrid functional/object-oriented language for the JVM                                

Fedora Modular 30 - x86_64 - Updates
Name                 Stream                  Profiles                       Summary                                                                                 
ant                  1.10 [d][e]             default [d]                    Java build tool                                                                         
gimp                 2.10 [d][e]             devel, default [d]             GIMP                                                                                    
jmc                  latest [e]              core, default [d]              Java Mission Control is a profiling and diagnostics tool for the Hotspot JVM            
libgit2              0.27 [d][e]                                            Library implementation of Git                                                           
maven                3.5 [d][e]              default [d]                    Java project management and project comprehension tool                                  
scala                2.10 [d][e]             default [d]                    A hybrid functional/object-oriented language for the JVM                                

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled


I'm very certain that ant, maven and scala are caused by some eclipse packages...

Comment 42 Mikolaj Izdebski 2019-05-07 15:13:41 UTC
(In reply to Michael from comment #41)
> What causes those modules to get enabled at first place?

ant, maven and scala modules have default streams, which is indicated by "[d]" marker next to stream name. In certain situations DNF can enable default streams by itself. This is documented at https://docs.fedoraproject.org/en-US/modularity/architecture/consuming/dnf-behavior/#_module_auto_enablement

Comment 43 Mat Booth 2019-05-07 16:15:00 UTC
*** Bug 1702839 has been marked as a duplicate of this bug. ***

Comment 44 pdimitrov 2019-05-08 04:06:08 UTC
(In reply to Mikolaj Izdebski from comment #39)
> I can't reproduce the issue using steps from comment #38 - "dnf install
> eclipse" works fine on a clean, fully-updated Fedora 30 Cloud system.
> 
> But I found a different way to reproduce the issue:
> 1. dnf module enable ant:1.10
> 2. dnf install eclipse-platform
> 
> This gives the familiar error message about dependency issues.
> 
> I am investigating the root cause of the issue.

Sorry, by "with completely fresh Fedora 30 install" I meant no updating from lower Fedora version but a standard Fedora 30 KDE Spin ISO install. I might have installed a package or two afterwards even though I am not convinced this should be related.

Comment 46 Michael 2019-05-09 12:10:20 UTC
Works for me on Fedora 30:

sudo dnf distrosync --refresh --enablerepo=updates-testing-modular
Fedora Modular 30 - x86_64                                                 30 kB/s |  19 kB     00:00    
Fedora Modular 30 - x86_64 - Updates                                      142 kB/s |  23 kB     00:00    
Fedora Modular 30 - x86_64 - Test Updates                                 267 kB/s | 827 kB     00:03    
Fedora 30 - x86_64 - Updates                                               26 kB/s |  23 kB     00:00    
Fedora 30 - x86_64                                                         24 kB/s |  19 kB     00:00    
RPM Fusion for Fedora 30 - Free - Updates                                  21 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Free                                            73 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree - Updates                               47 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree                                         70 kB/s |  10 kB     00:00    
Dependencies resolved.
==========================================================================================================
 Package                Arch      Version                                Repository                  Size
==========================================================================================================
Downgrading:
 ant                    noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular    192 k
 ant-antlr              noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     44 k
 ant-apache-bcel        noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     47 k
 ant-apache-bsf         noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     42 k
 ant-apache-log4j       noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     41 k
 ant-apache-oro         noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     46 k
 ant-apache-regexp      noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     42 k
 ant-apache-resolver    noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     42 k
 ant-apache-xalan2      noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     41 k
 ant-commons-logging    noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     42 k
 ant-commons-net        noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular    115 k
 ant-javamail           noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     46 k
 ant-jdepend            noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     51 k
 ant-jmf                noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     44 k
 ant-jsch               noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     82 k
 ant-junit              noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular    181 k
 ant-junit5             noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     85 k
 ant-lib                noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular    2.0 M
 ant-swing              noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     46 k
 ant-testutil           noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     58 k
 ant-xz                 noarch    1.10.5-3.module_f28+4207+d722d224      updates-testing-modular     43 k

Transaction Summary
==========================================================================================================
Downgrade  21 Packages

Total download size: 3.3 M
Is this ok [y/N]

Comment 47 Diederik van Lierop 2019-05-09 16:43:36 UTC
Now the ant module moved into Fedora Modular Updates Testing today (was still pending yesterday evening), I can install Eclipse again!

Thanks a lot, the problem has been solved for me!

Diederik

Comment 48 Bruce Bigby 2019-05-10 03:00:31 UTC
After running, ...

sudo dnf module disable ant

I was able to install eclipse.  However, should I reenable the 'ant' module after installing eclipse, or leave it in the disabled state, period?

Comment 49 pdimitrov 2019-05-10 03:47:38 UTC
(In reply to Diederik van Lierop from comment #47)
> Now the ant module moved into Fedora Modular Updates Testing today (was
> still pending yesterday evening), I can install Eclipse again!
> 

It has been solved for me too when running

sudo dnf install eclipse --enablerepo=updates-testing-modular

Thanks for the fix!

Comment 50 Bruce Bigby 2019-05-10 12:38:27 UTC
I tried the command,

sudo dnf install eclipse --enablerepo=updates-testing-modular

but it didn't work.  I had to disable the ant module first, and then my installation of eclipse worked.

Comment 51 Mikolaj Izdebski 2019-05-13 09:34:16 UTC
*** Bug 1709249 has been marked as a duplicate of this bug. ***

Comment 52 Bill Chatfield 2019-05-14 03:19:41 UTC
I have this same problem on a fresh install of Fedora 30 WORKSTATION. Eclipse doesn't make sense on any other edition of Fedora. I had to do a fresh install because upgrading from Fedora 29 WORKSTATION was blocked by this same issue.

Comment 53 Mikolaj Izdebski 2019-05-14 05:18:13 UTC
*** Bug 1709582 has been marked as a duplicate of this bug. ***

Comment 54 Kamal Mehta 2019-05-14 13:36:57 UTC
(In reply to Diederik van Lierop from comment #47)
> Now the ant module moved into Fedora Modular Updates Testing today (was
> still pending yesterday evening), I can install Eclipse again!
> 
> Thanks a lot, the problem has been solved for me!
> 
> Diederik

Thanks! Diederik!!
I executed below and installed eclipse successfully.

sudo dnf install eclipse --enablerepo=updates-testing-modular

Kamal Mehta
System Administrator
Organization: https://www.smiansh.com

Comment 55 Fedora Update System 2019-05-15 02:52:01 UTC
ant-1.10-2820190508055149.819b5873 has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 56 Fedora Update System 2019-05-17 03:26:15 UTC
ant-1.10-2820190507144348.819b5873 has been pushed to the Fedora 28 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 57 Fedora Update System 2019-05-17 03:49:58 UTC
ant-1.10-2820190507144406.819b5873 has been pushed to the Fedora 29 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 58 wyte_sk133 2019-05-22 02:41:39 UTC
Successfully ran `sudo dnf system-upgrade download --refresh --releasever=30` on Fedora 29 with eclipse-avr (and its dependencies) installed. Thanks for the fix!


Note You need to log in before you can comment on or make changes to this bug.