Bug 1692135 - Possible regression: Spinner will not always terminate unless window titlebar grabbed and window moved
Summary: Possible regression: Spinner will not always terminate unless window titlebar...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
: 1696987 1697140 (view as bug list)
Depends On:
Blocks: F30FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-03-24 14:59 UTC by Phil Wyett
Modified: 2019-04-21 20:32 UTC (History)
17 users (show)

Fixed In Version: mutter-3.32.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-21 20:32:55 UTC
Type: Bug


Attachments (Terms of Use)
Issue using and image and image viewer (2.76 MB, video/webm)
2019-03-24 14:59 UTC, Phil Wyett
no flags Details
Issue using generated text file. (534.14 KB, video/webm)
2019-03-24 15:01 UTC, Phil Wyett
no flags Details
All apps closed and spinner still active (300.36 KB, video/webm)
2019-03-26 02:25 UTC, Phil Wyett
no flags Details
strace gnomeshell (2.88 MB, text/plain)
2019-03-27 03:00 UTC, Chris Murphy
no flags Details
Patch from upstream, will submit as fedora PR (938 bytes, application/mbox)
2019-04-01 06:48 UTC, Phil Wyett
no flags Details

Description Phil Wyett 2019-03-24 14:59:44 UTC
Created attachment 1547426 [details]
Issue using and image and image viewer

Description of problem:

Spinner will not terminate unless window titlebar grabbed and window moved

Version-Release number of selected component (if applicable):

3.32.0-1

How reproducible:

Always

Steps to Reproduce:
1. Install fedora rawhide or f30 pre beta drop 1.7.
2. Open terminal.
3. cp -f /usr/share/backgrounds/f30/default/standard/f30.png Pictures/ or echo "Roses are red, violets are blue." > Documents/roses.txt
4 Open nautilus (Files). Navigate to either in [3]. Right click and open with default application offered.

Actual results:

Move mouse away from window or perform other actions and spinner is still going.

See attached videos.

Expected results:

Spinner to terminate on file loading completion.

Additional info:


Affects rawhide and f30 pre beta ISO compose 1.7.

Comment 1 Phil Wyett 2019-03-24 15:01:08 UTC
Created attachment 1547427 [details]
Issue using generated text file.

Comment 2 Phil Wyett 2019-03-26 02:20:59 UTC
Further testing. Changed from component 'gnome-shell' to 'wayland' for now.

- Issue is on rawhide wayland
- Issue is not on rawhide xorg
- Issue is on f30 pre beta 1.7 wayland
- Issue is not on f30 pre beta 1.7 xorg
- Issue is not on f29 wayland
- Issue is not on f29 xorg

All testing with VMs and not on bare metal as not available to me.

Comment 3 Phil Wyett 2019-03-26 02:25:01 UTC
Created attachment 1547876 [details]
All apps closed and spinner still active

Comment 4 Fedora Blocker Bugs Application 2019-03-27 00:29:03 UTC
Proposed as a Blocker for 30-beta by Fedora user kathenas using the blocker tracking app because:

 Alters and interferes with normal default desktop functionality and usability. Violation: final.

Comment 5 Phil Wyett 2019-03-27 00:34:34 UTC
Still present on f30 pre beta ISO compose 1.8.

Comment 6 Adam Williamson 2019-03-27 01:41:31 UTC
You were right the first time - 'wayland' is almost never the right component for a bug. Something in the GNOME stack is much more appropriate (possibly mutter or GTK+ or something rather than gnome-shell, but gnome-shell is close enough that the right people should see the bug).

I can't reproduce this bug here, though. Just tried on both my desktop and a test box I just installed Beta-1.8 on and, nope, not happening...

Comment 7 Chris Murphy 2019-03-27 02:55:51 UTC
I can reproduce this on Fedora 30, GNOME on Wayland. I've seen this off and on since upgrading from Fedora 29 also GNOME on Wayland. But I don't think it's a blocker. Beta or final.

Comment 8 Chris Murphy 2019-03-27 03:00:30 UTC
Created attachment 1548361 [details]
strace gnomeshell

strace of gnome shell while spinner is active (mostly). When I move the cursor away from the desktop area, spinner doesn't happen and gnome-shell uses ~1% CPU and then when over the desktop gnome-shell process uses ~25% CPU with spinner.

Comment 9 Geoffrey Marr 2019-03-27 14:14:54 UTC
cmurf, what version of F30 are you running when you see this? Also, are you in a VM or baremetal?

I am -1 blocker based on the given criteria and my inability to reproduce this bug (baremetal). I believe the following might be a more appropriate criteria to present this as a blocker though, as I searched the F30 Basic and Beta criteria for one that officially would fit this bug:

"No part of any release-blocking desktop's panel (or equivalent) configuration may crash on startup or be entirely non-functional."

However, in either scenario, I do not believe this bug to violate either of the above, so -1 blocker from me.

Comment 10 Adam Williamson 2019-03-27 14:32:23 UTC
this has nothing to do with the panel, though, really.

Comment 11 Chris Murphy 2019-03-27 16:04:43 UTC
(In reply to Geoffrey Marr from comment #9)
> cmurf, what version of F30 are you running when you see this?

Latest from updates-testing. It was a F29 to F30 upgrade using gnome-software. 

o Also, are you
> in a VM or baremetal?

Baremetal. i915 graphics.

The spinner doesn't block anything from working, or require me to alter my interaction. But while it does increase my carbon footprint from time to time, we don't block on minor performance issues.

Comment 12 Ben Cotton 2019-03-28 20:44:17 UTC
Discussed in the F30 Beta Go/No-Go meeting today[1]. We voted to reject this as a blocker because it does not violate any release criteria.

[1] https://meetbot.fedoraproject.org/fedora-meeting-1/2019-03-28/f30-beta-go_no_go-meeting.2019-03-28-17.00.html

Comment 13 Phil Wyett 2019-03-28 22:04:46 UTC
Was present on IRC for the meeting. Put forward the bug brought eyes upon it.

Would the bug rate mentioning in the release notes, even though not a blocker?

Comment 14 Phil Wyett 2019-03-31 15:53:41 UTC
Upstream: https://gitlab.gnome.org/GNOME/gnome-shell/issues/1126

Comment 15 Phil Wyett 2019-04-01 06:47:41 UTC
Changed component to mutter.

Duplicate of: https://gitlab.gnome.org/GNOME/mutter/issues/501

Patch associated with bug report upstream fixes issue for me.

Comment 16 Phil Wyett 2019-04-01 06:48:51 UTC
Created attachment 1550381 [details]
Patch from upstream, will submit as fedora PR

Comment 17 Phil Wyett 2019-04-01 06:59:15 UTC
Duplicate of: https://gitlab.gnome.org/GNOME/gtk/issues/1754

Comment 18 Phil Wyett 2019-04-07 00:15:26 UTC
*** Bug 1696987 has been marked as a duplicate of this bug. ***

Comment 19 Phil Wyett 2019-04-07 21:23:06 UTC
*** Bug 1697140 has been marked as a duplicate of this bug. ***

Comment 20 Phil Wyett 2019-04-07 21:26:48 UTC
FYI: Fix due in mutter 3.32.1 due in this coming week.

Comment 21 Phil Wyett 2019-04-16 16:09:56 UTC
PR's:

https://src.fedoraproject.org/rpms/mutter/pull-request/16
https://src.fedoraproject.org/rpms/mutter/pull-request/17

Backport patch to fix timeout of application startup sequences (rhbz#1692135)

Not a blocker, so would like it in before freeze hits.

This is second submission of same patch, but was closed as advised 3.32.1 was imminent. That release of mutter has not happened.

Comment 22 Adam Williamson 2019-04-16 16:20:11 UTC
The freeze already happened. This would need a freeze exception to go in before Final. Proposing.

Comment 23 Adam Williamson 2019-04-17 15:57:20 UTC
Phil: both your PRs seem broken. I'll just do it myself.

Comment 24 Phil Wyett 2019-04-17 16:18:36 UTC
Adam: Something gone sideways this morning and I should not do things when I am tired. Was fine, will try harder next time.

Comment 25 Adam Williamson 2019-04-17 16:34:39 UTC
=) It seems like you started from an older checkout before my changes yesterday and that's what probably sent things sideways.

Comment 26 Fedora Update System 2019-04-18 15:11:05 UTC
gnome-shell-3.32.1-1.fc30 gnome-shell-extensions-3.32.1-1.fc30 mutter-3.32.1-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 27 Fedora Update System 2019-04-18 18:24:33 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 28 Zbigniew Jędrzejewski-Szmek 2019-04-19 09:01:25 UTC
+1 FE

Comment 29 Fedora Update System 2019-04-21 20:32:55 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.