Bug 1692227 - wrong doc link on networkpolicy page
Summary: wrong doc link on networkpolicy page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.0
Assignee: Zac Herman
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1775457 1775458
TreeView+ depends on / blocked
 
Reported: 2019-03-25 05:29 UTC by shahan
Modified: 2020-01-23 11:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Outdated link Consequence: Users who clicked on link went to the wrong page Fix: Updated link URL Result: Users now click on the link and it goes to the current docs
Clone Of:
: 1775457 1775458 (view as bug list)
Environment:
Last Closed: 2020-01-23 11:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3343 'None' 'closed' 'Bug 1692227: Update network policies doc link to use openshift docs' 2019-11-21 02:21:10 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:04:13 UTC

Description shahan 2019-03-25 05:29:37 UTC
Description of problem:
  wrong doc link on networkpolicy page

Version-Release number of selected component (if applicable):
Cluster version is 4.0.0-0.nightly-2019-03-23-222829
console commit :4cb747009adf95fc9409714a4df52ff1e7522912

How reproducible:
Always

Steps to Reproduce:
1. Login console and create networkpolicy for a project
2. check doc link 'Network Policies Documentation.' under Ingress Rules part on the newtworkpolicy detail page 
3.

Actual results:
2. The link is 'https://kubernetes.io/docs/concepts/services-networking/network-policies/'

Expected results:
2. It should not refer to upstream's documentation, or just remove the link.
such as link for v3.11 https://docs.openshift.com/container-platform/3.11/admin_guide/managing_networking.html#admin-guide-networking-networkpolicy

Additional info:

Comment 4 Samuel Padgett 2019-11-11 15:20:25 UTC
Makes sense to me. We should add an OpenShift flag check.

Comment 5 Samuel Padgett 2019-11-11 15:22:06 UTC
We should centralize our doc links in one place like we had previously: https://github.com/openshift/console/commit/2dae49a86c0d3a34c6ed969a575be3c54d47195a#diff-12887fc2371d38a701d3799cb2766141

Comment 7 shahan 2019-11-22 02:47:32 UTC
The doc link has changed to the on https://docs.openshift.com/container-platform/4.3/networking/configuring-networkpolicy.html  for 4.3 cluster.
Verified this bug.
4.3.0-0.nightly-2019-11-21-122827

Comment 9 errata-xmlrpc 2020-01-23 11:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.