Bug 169231 - no history with bash
Summary: no history with bash
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Target 163235
TreeView+ depends on / blocked
 
Reported: 2005-09-25 17:42 UTC by Lars G
Modified: 2007-12-11 14:08 UTC (History)
0 users

Fixed In Version: 3.0-41
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-06 18:10:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lars G 2005-09-25 17:42:52 UTC
bash-3.0-34 doesn't create entries in .bash_history here.

Comment 1 Tim Waugh 2005-09-26 09:18:29 UTC
The .bash_history file is written when bash exits.  How are you exiting bash?

Note that the signal handler itself had previously been writing the bash_history
file, using all sorts of C library functions that must not be called during a
signal handler, and so that particular instance of writing bash_history files
has been disabled.

Comment 2 Lars G 2005-09-26 11:35:38 UTC
using the gnome terminal,
.bash_history is not updated after closing it via the "close window" widget or
"file/close window".

when typing "exit" it closes and writes the .bash_profile OK here.



Comment 3 Tim Waugh 2005-09-27 13:08:36 UTC
This is just a consequence of fixing the signal handler issue. :-/

Comment 4 Tim Waugh 2005-11-29 12:32:54 UTC
Hmm, need to fix this *somehow*.

Comment 5 Tim Waugh 2005-12-06 18:10:21 UTC
Let's see how bash-3.0-38 behaves.

Comment 6 Tim Waugh 2005-12-07 11:27:43 UTC
Hmm, 'while :; do :; done' doesn't get interrupted by SIGHUP now.  Fixed in 3.0-39.

Comment 7 Tim Waugh 2005-12-08 11:31:51 UTC
Also 'read line' didn't get interrupted by SIGHUP.  Fixed in 3.0-40.

Comment 8 Tim Waugh 2005-12-15 10:57:10 UTC
Also bug #175786 is caused by this change.

Comment 10 Bob Johnson 2006-04-11 16:03:32 UTC
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.


Note You need to log in before you can comment on or make changes to this bug.