Bug 1692319 - fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64 breaks Workstation netinst installation
Summary: fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64 breaks Workstation netinst in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fuse-overlayfs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 10:49 UTC by Kamil Páral
Modified: 2019-04-02 00:01 UTC (History)
5 users (show)

Fixed In Version: fuse-overlayfs-0.3-8.dev.gita6958ce.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-02 00:01:55 UTC


Attachments (Terms of Use)

Description Kamil Páral 2019-03-25 10:49:00 UTC
Description of problem:
fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64 prevents Fedora 30 Workstation netinst to be installed. Anaconda log says:

11:29:27,909 INF packaging: Installed: fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64 1553266664 d823335a181d54a7e468a10f0f28a229d674410dda44268f38acc36c19cece80
11:29:27,924 INF packaging: Configuring (running scriptlet for): fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64 1553266664 d823335a181d54a7e468a10f0f28a229d674410dda44268f38acc36c19cece80
11:29:27,947 ERR dnf.rpm: Error in POSTIN scriptlet in rpm package fuse-overlayfs
11:36:52,311 Level 8 dnf: RPM transaction over.

There's no more detail in the logs, but when I try the same thing in mock, I see an extra error message:

  Installing       : fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64                                              2/2 
  Running scriptlet: fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64                                              2/2 
/var/tmp/rpm-tmp.JsYA6R: line 1: modprobe: command not found
warning: %post(fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64) scriptlet failed, exit status 127

Error in POSTIN scriptlet in rpm package fuse-overlayfs


It seems it's trying to use modprobe without making sure modprobe is available.


Version-Release number of selected component (if applicable):
fuse-overlayfs-0.3-6.dev.git8ec68ae.fc30.x86_64

How reproducible:
always 

Steps to Reproduce:
1. install the package in a clean mock

Comment 1 Giuseppe Scrivano 2019-03-25 11:03:56 UTC
do we need a dependency on kmod?

Comment 2 Adam Williamson 2019-03-25 14:43:07 UTC
a 'Requires(post): kmod', yes. dwalsh broke this in -6, it looks like.

As this breaks default Workstation network install it's a significant issue; can you please either unpush the update or update it with a fixed build quickly? Thanks!

Comment 3 Giuseppe Scrivano 2019-03-25 15:04:02 UTC
unpushed and working on a fix.

Would something like this work for using modprobe but not fail the installation if it cannot be used: modprobe fuse > /dev/null 2>&1 || true ?

Comment 4 Adam Williamson 2019-03-25 15:13:09 UTC
The packaging guidelines recommend `|| :`

https://docs.fedoraproject.org/en-US/packaging-guidelines/Scriptlets/#_syntax

Comment 5 Fedora Update System 2019-03-25 15:32:12 UTC
fuse-overlayfs-0.3-7.dev.git8ec68ae.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d33db08f06

Comment 6 Fedora Update System 2019-03-25 18:54:49 UTC
fuse-overlayfs-0.3-7.dev.git8ec68ae.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d33db08f06

Comment 7 Daniel Walsh 2019-03-26 10:34:37 UTC
lgtm

Comment 8 Fedora Update System 2019-03-28 18:39:27 UTC
fuse-overlayfs-0.3-8.dev.gita6958ce.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-27e521d26f

Comment 9 Fedora Update System 2019-03-29 00:13:07 UTC
fuse-overlayfs-0.3-8.dev.gita6958ce.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-27e521d26f

Comment 10 Fedora Update System 2019-04-02 00:01:55 UTC
fuse-overlayfs-0.3-8.dev.gita6958ce.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.