Bug 1692418 - openshift-ansible fails with AnsibleUndefinedVariable: 'dict object' has no attribute 'annotations'"
Summary: openshift-ansible fails with AnsibleUndefinedVariable: 'dict object' has no a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.z
Assignee: Joseph Callen
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-25 14:52 UTC by Jason Montleon
Modified: 2019-06-11 09:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 09:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0786 None None None 2019-06-11 09:30:59 UTC

Description Jason Montleon 2019-03-25 14:52:45 UTC
Description of problem:

Version-Release number of the following components:
openshift-ansible-3.10.129-1.git.0.7eeeb52.el7.noarch
ansible-2.5.15-1.el7ae.noarch

How reproducible:
Seems always with this version

Steps to Reproduce:
1. Try to install openshift 3.10

Actual results:
    default: TASK [openshift_persistent_volumes : Deploy PersistentVolume definitions] ******
    default: fatal: [192.168.121.250.nip.io]: FAILED! => {"changed": false, "msg": "AnsibleUndefinedVariable: 'dict object' has no attribute 'annotations'"}


Expected results:
Install works

Additional info:
openshift-ansible-3.10.127-1.git.0.131da09.el7.noarch worked

Comment 3 Joseph Callen 2019-03-29 18:34:08 UTC
Submitted PR: https://github.com/openshift/openshift-ansible/pull/11428

Comment 4 Joseph Callen 2019-03-29 19:22:31 UTC
There was already a PR submitted and merged to fix
https://github.com/openshift/openshift-ansible/pull/11429

Comment 5 Joseph Callen 2019-04-01 12:39:42 UTC
In build openshift-ansible-3.10.134-1

Comment 6 Gaoyun Pei 2019-04-08 05:50:13 UTC
QE could reproduce this issue with openshift-ansible-3.10.129-1, when installing a 3.10 cluster with NFS host, it would failed as below:

TASK [openshift_persistent_volumes : Deploy PersistentVolume definitions] ******
Monday 08 April 2019  11:19:49 +0800 (0:00:00.036)       0:22:22.615 ********** 
fatal: [ec2-54-81-200-28.compute-1.amazonaws.com]: FAILED! => {"changed": false, "failed": true, "msg": "AnsibleUndefinedVariable: 'dict object' has no attribute 'annotations'"}


Tried openshift-ansible-3.10.134-1.git.0.776828e.el7.noarch.rpm with a same installation, the issue was fixed.

Comment 9 errata-xmlrpc 2019-06-11 09:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0786


Note You need to log in before you can comment on or make changes to this bug.