Bug 169244 - kernel panic - not syncing: Attempting to kill init
kernel panic - not syncing: Attempting to kill init
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-25 22:34 EDT by chuck nicholas
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-19 15:05:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chuck nicholas 2005-09-25 22:34:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 (ax)

Description of problem:
I have an Optiplex GX 620 with BIOS that has been upgraded to A03(09/20/05)

System did load from the RH Enterprise 4 install CD's, installed kernel 2.1.9-5.ELSMP and will boot with the SATA bios setting to "compatibility mode", i.e. not native.  (the installation initially failed with an error message of no hard drives found until I switched to compatibility mode).

Once loaded, the system did do updates, inlcuding kernel update to 2.1.11.  The new (2.1.11) kernel fails to boot with the following error messages: 

Uncompressing Linux,  OK booting the kernel
Audit (1127465168.889:0): initialzed
ide0: I/O restore 0x1F0-0x1F7 not free
ide0: ports already in use, skipping probe
Red Hat nash version 4.2.1.3 starting
mkrootdev: label / not found
mount: error 2 mounting ext3
mount: error 2 mounting non
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not syncing: Attempt to kill init

We went back into grub to force the system to load the 2.1.9 version.  We have also tried toggling the SATA setting in the BIOS with the only result being that the 2.1.9 kernel will fail with the same error messages if the BIOS is set to native SATA support.  2.1.11 will not boot no matter what the BIOS is set to.


Version-Release number of selected component (if applicable):
kernel-2.1.11

How reproducible:
Always

Steps to Reproduce:
1.restart machine
2.edit grub loader to choose 2.1.11 kernel
3.boot
  

Actual Results:  System locks, key caps and num caps lights on keyboard start flashing.  System has to be physically powered down to restart.

Additional info:

System is suppsoed to have the Intel 945G chipset.  When trying to install in native SATA mode and no drives were found, I tried loading the SATA drivers manually.  I did not see a driver set from Intel that matched.  I tried loading every other SATA driver I found on the install CD.
Comment 1 Jason Baron 2005-09-27 14:18:45 EDT
hmmm. can you please try the u2 beta kernel: http://people.redhat.com/~jbaron/rhel4/
Comment 2 chuck nicholas 2005-09-28 13:26:17 EDT
(In reply to comment #1)
> hmmm. can you please try the u2 beta kernel:
http://people.redhat.com/~jbaron/rhel4/

I hope I'm not being too dense, but which one is the u2 beta?  I opened the
link, should I be using this one: kernel-smp-2.6.9-22.EL.i686.rpm?
Comment 3 Suzanne Hillman 2005-10-11 15:39:42 EDT
Chuck - I think that they are all the U2 beta kernel, just for different archs
and such. Presuming that you were using i386 and smp before, then the one you
mentioned above is the one I would try.

Alternately, since U2 is out now, I would just try up2dating your kernel and
trying what that gives you.
Comment 4 Jason Baron 2005-12-16 09:58:02 EST
any updates?
Comment 5 chuck nicholas 2005-12-16 10:07:45 EST
Clear it.  We had to load one machine from the Update 2 disks to get around the
problem.  Once this was done we were able to patch the other computer without
reloading by using missing files from the one that worked.

Note You need to log in before you can comment on or make changes to this bug.