Bug 169245 - yum.repos.d files should turn on development repos not others
yum.repos.d files should turn on development repos not others
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 01:30 EDT by Jens Petersen
Modified: 2013-01-09 20:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 21:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2005-09-26 01:30:29 EDT
Description of problem:
When one installs rawhide, yum is configured to pull packages from
fc4 repos not devel repos.  It is annoying to have to correct this each
time after installing.

How reproducible:
Every time.

Steps to Reproduce:
1. Install rawhide.
2. Look at which repos are enabled in /etc/yum.repos.d/
  
Actual results:
Core, Updates and Extras repos for fc4 are enabled.

Expected results:
Core and Extras Devel repos only to be enabled.
Comment 1 Jesse Keating 2006-01-23 20:31:25 EST
This would have to be changed in fedora-release.  I'll try to remember to change
this in FC5Test3.  However I do feel that until we have a test release, the
previous release should remain enabled.  Rawhide isn't self sustaining at first.
 Perhaps the change should be flipped at test1 timeframe.  I want to discuss
this w/ the engineers.
Comment 2 Warren Togami 2006-01-23 20:50:31 EST
There is no reason why a FC5test install should be pointing at FC4 repos.  I
made sure it was pointing at devel for test1 but didn't check it before test2,
sorry about the inconvenience. =(

Comment 3 Jens Petersen 2006-01-23 21:09:06 EST
Sorry, why is rawhide not "self-sustaining"?  Doesn't it pull from
FC updates from the last release?
Comment 4 Warren Togami 2006-01-23 21:23:25 EST
FC5 earlier in its development pulled in FC4 + updates if packages were not
rebuilt in FC5.  By this point we *should* have rebuilt everything at least once
and FC5 should be self-hosting.  However parent collections and yum.repos.d are
actually different things.

This bug is really about forgetting to enable the development repo and disable
FC4 in test2.
Comment 5 Warren Togami 2006-01-23 23:07:38 EST
To be clear, I mean that rawhide and test installs should always enable
development by default in yum.repos.d.
Comment 6 Jesse Keating 2006-01-24 00:00:38 EST
It looks like development is enabled, but the base is still enabled.  So not
only is it pulling from the development repo, its also pulling from whatever yum
figures is the $release, in this case FC4.  I agree that base should be disabled
in test releases, I'm just not sure about rawhide itself.  Prior to Test1,
rawhide could be just a bunch of FCX + updates packages, including
fedora-release.  At that point, rawhide is just a set of updates to a given FC
release, not a release in itself.

Am I totally off base?
Comment 7 Warren Togami 2006-01-24 00:16:22 EST
Yes. =)

Rawhide may contain packages that are exactly the same as those in FC4 (it still
does today), however rawhide has a copy of the latest-pkg for the entire
collection within its own yum repo.  This is due to collection inheritance.


Comment 8 Jesse Keating 2006-01-24 02:35:05 EST
Right, but is it worth it to respin redhat-release each time the rawhide tree
moves on from a release?  Is the cost worth the effort?
Comment 9 Jens Petersen 2006-01-24 03:18:37 EST
I'm still confused: is there any good reason why rawhide yum shouldn't
always pull just from FC/FE devel repos by default?
Comment 10 Jesse Keating 2006-01-24 13:01:41 EST
The FC/FE Devel should be.  I suppose that fedora-release would have to be
touched in order ot make this happen anway, so at the same time we're touching
that, we could turn off the base repo.
Comment 11 Jesse Keating 2006-02-22 18:24:00 EST
I'll look into this for the FC6 development.  It is too late in FC5 development
to make any changes.
Comment 12 Warren Togami 2006-02-23 00:57:22 EST
Did we release FC5test3 with this same problem?

(Yes, too late now, but just curious.)
Comment 13 David Lawrence 2006-03-09 16:38:00 EST
INVESTIGATE state has been obsoleted. Moving bugs to ASSIGNED.
Comment 14 Jesse Keating 2006-04-17 21:50:46 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.