Bug 169246 - Webalizer will not output anything to stdout or stderr
Webalizer will not output anything to stdout or stderr
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
4
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Russell Coker
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 01:31 EDT by Jeremy Rode
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.27.1-2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 22:23:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Rode 2005-09-26 01:31:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
On FC4 webalizer runs but refuses to output anything on stdout/stderr regardless of quiet/reallyquiet options.  I tried to downgrade to the FC3 version of webalizer, but couldn't as libdb-4.2.so isn't present.

The bug affects a system with a clean install of FC4.  I have another box running FC4 that is an upgrade from FC3/FC2/FC1 where the bug is not present.

Version-Release number of selected component (if applicable):
webalizer-2.01_10-28

How reproducible:
Always

Steps to Reproduce:
1. webalizer -V

Actual Results:  Nothing

Expected Results:  Print version information on stdout

Additional info:

This does not stop webalizer from working, it only makes finding problems a chore, as error messages are not present.
Comment 1 Joe Orton 2005-09-26 04:33:46 EDT
This is due to the SELinux policy, it seems, and is probably expected behaviour.

# webalizer -V | cat
Comment 2 Daniel Walsh 2005-09-27 15:43:57 EDT
Fixed in selinux-policy-targeted-1.27.1-2.3

Note You need to log in before you can comment on or make changes to this bug.