Bug 1692637 - ASB Operator update/delete customer resource automationbroker failed occasionally
Summary: ASB Operator update/delete customer resource automationbroker failed occasion...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Broker
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.1.0
Assignee: Jesus M. Rodriguez
QA Contact: Zihan Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-26 05:48 UTC by Zhang Cheng
Modified: 2019-06-04 10:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:33 UTC

Comment 2 Zhang Cheng 2019-03-27 05:19:23 UTC
Furthermore, automationbroker/ansible-service-broker cannot be deleted while hit this problem.

Comment 3 Jesus M. Rodriguez 2019-03-29 20:09:20 UTC
*** Bug 1662282 has been marked as a duplicate of this bug. ***

Comment 8 Shawn Hurley 2019-04-15 13:09:26 UTC
The broker is telling you that you have the incorrect set up: 

\"msg\": \"Failed to create object: {\\\"kind\\\":\\\"Status\\\",\\\"apiVersion\\\":\\\"v1\\\",\\\"metadata\\\":{},\\\"status\\\":\\\"Failure\\\",\\\"message\\\":\\\"clusterrolebindings.rbac.authorization.k8s.io \\\\\\\"ansible-service-broker-openshift-ansible-service-broker-admin\\\\\\\" is forbidden: user \\\\\\\"system:serviceaccount:openshift-ansible-service-broker:automation-broker-operator\\\\\\\" (groups=[\\\\\\\"system:serviceaccounts\\\\\\\" \\\\\\\"system:serviceaccounts:openshift-ansible-service-broker\\\\\\\" \\\\\\\"system:authenticated\\\\\\\"]) is attempting to grant RBAC permissions not currently held:\

Please add the correct CRB (ClusterRoleBinding) to the operators SVCACCT so that it can complete correctly.

Comment 11 errata-xmlrpc 2019-06-04 10:46:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.