Bug 1692677 - IP not configured after initial-setup
Summary: IP not configured after initial-setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: armhfp
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-26 08:43 UTC by Alessio
Modified: 2019-04-11 02:14 UTC (History)
9 users (show)

Fixed In Version: anaconda-30.25.5-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 02:14:10 UTC
Type: Bug


Attachments (Terms of Use)
snippet of journalctl after restarting NetworkManager (3.23 KB, text/plain)
2019-03-26 08:43 UTC, Alessio
no flags Details

Description Alessio 2019-03-26 08:43:30 UTC
Created attachment 1547945 [details]
snippet of journalctl after restarting NetworkManager

Description of problem:

I don't know if "initial-setup" is the right component. Maybe the right one is network-manager?
BTW
On a Rasperry Pi 3, using Fedora-Minimal-armhfp-30_Beta-1.7-sda.raw.xz, I configure the network during initial setup.
I insert a static IP address, the netmask, gateway, I set "ignore" to IPv6, and so on.
In addition I select 
7) [x] Connect automatically after reboot
8) [x] Apply configuration in installer

Then I continue and exit from the initial setup.


Actual results:

After the login, issuing the command "ip a", the eth0 doesn't have an IPv4 address. (I don't have a DHCP in the network).

nmcli dev
DEVICE         TYPE      STATE         CONNECTION         
eth0           ethernet  connected     Wired connection 1 

Also restarting NetworkManager, "systemctl restart NetworkManager", the eth0 doesn't have an IP.

"grep -r" the IP address in /etc/NetworkManager/ doesn't return any result.

"grep -r" the IP address in /etc/sysconfig returns
/etc/sysconfig/network-scripts/ifcfg-Wired_connection_1


At the end of the day, after rebooting the system, the network is configured as expected.

Comment 1 Martin Kolman 2019-03-26 11:50:50 UTC
The code of the network spoke is provided by Anaconda and that's most likely where the fix will land, so switching to the anaconda component. :)

Comment 2 Alessio 2019-03-27 08:42:11 UTC
A little followup.
Issuing these commands, instead of rebooting the system,

sudo nmcli con down UUID
sudo nmcli con up UUID

then eth0 got the configured IP.

Comment 3 Radek Vykydal 2019-04-04 18:15:05 UTC
This seems to be related to this change:
https://github.com/rhinstaller/anaconda/commit/1740cc1e39e8a2e1de2fb8b69d141545dd9323ea
and affects also tui network configuration (static) in installer.

The root cause is updating NM connection (and checking consistency of configuration values) after each change of value - this should be done at once after all values are set in UI, as it used to be before the change abovre. When setting static IP there is an error recorded (https://github.com/rhinstaller/anaconda/commit/1740cc1e39e8a2e1de2fb8b69d141545dd9323ea#diff-bcdb5eebebb63c1f958b91c139ed52eaR552) for non-dhcp connection without netmask set at some point (which is bound to happen because the check and connection update is done after each value change) and as a result the connection is not activated later because of the recorded error (https://github.com/rhinstaller/anaconda/commit/1740cc1e39e8a2e1de2fb8b69d141545dd9323ea#diff-bcdb5eebebb63c1f958b91c139ed52eaR552).

I'll come with a patch shortly.

Comment 4 Radek Vykydal 2019-04-05 12:32:10 UTC
https://github.com/rhinstaller/anaconda/pull/1936

Comment 5 Fedora Update System 2019-04-09 16:03:49 UTC
anaconda-30.25.5-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e2e3cfdb2b

Comment 6 Fedora Update System 2019-04-10 14:37:54 UTC
anaconda-30.25.5-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e2e3cfdb2b

Comment 7 Fedora Update System 2019-04-11 02:14:10 UTC
anaconda-30.25.5-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.