Bug 169268 - pcmcia generates error with kernel 2.6.13-1.1524_FC4
pcmcia generates error with kernel 2.6.13-1.1524_FC4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 06:41 EDT by Robert Bertram
Modified: 2015-01-04 17:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 01:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
2.6.13-1.1526_FC4 startup messages w/ I/O error on cardmgr start (28.43 KB, text/plain)
2005-10-01 06:14 EDT, James
no flags Details
lspci for machine w/ cardmgr error on 2.6.13-1.1526_FC4 (1.80 KB, text/plain)
2005-10-01 06:16 EDT, James
no flags Details

  None (edit)
Description Robert Bertram 2005-09-26 06:41:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Description of problem:
On start up pcmcia generates an error message when using the kernel from updates-testing(2.6.13-1.1524_FC4). Booting into the older kernel sees normal startup for pcmcia.

[root@eyrie ~]# uname -r
2.6.13-1.1524_FC4
[root@eyrie ~]# dmesg -c >> /dev/null
[root@eyrie ~]# service pcmcia restart
Shutting down PCMCIA services: done.
Starting PCMCIA services: cardmgr[2719]: watching 1 socket
cardmgr[2719]: could not adjust resource: IO ports 0x3d3-0x3d3: Input/output error
done.
[root@eyrie ~]# dmesg
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0x800-0x8ff: clean.
cs: IO port probe 0x100-0x4ff: excluding 0x170-0x177 0x370-0x377
cs: IO port probe 0xa00-0xaff: clean.
[root@eyrie ~]#

Version-Release number of selected component (if applicable):
2.6.13-1.1524_FC4

How reproducible:
Always

Steps to Reproduce:
1.restart pcmcia with new kernel
2.restart pcmcia with old kernel
3.
  

Actual Results:  error message on starting pcmcia

Expected Results:  no error message

Additional info:
Comment 1 Matthias Hensler 2005-09-29 10:04:08 EDT
fixed for me with 2.6.13-1.1526_FC4
Comment 2 Pete Zaitcev 2005-09-29 14:19:29 EDT
Robert? Does it work now?
Comment 3 Walter Neumann 2005-09-29 21:13:30 EDT
Same problem with 2.6.13-1.1524_FC4 also fixed for me in 2.6.13-1.1526_FC4
Comment 4 Robert Bertram 2005-09-30 05:44:13 EDT
Sorry, had some family problems and forgot about this.

Looks good to me as well.
Comment 5 James 2005-10-01 06:11:29 EDT
I still see something similar in 2.6.13-1.1526_FC4. At boot, when the cardmgr
service starts, it prints a message to the effect of "could not reserve
resources 0xa0000000 - 0xa0ffffff: input/output error" (apologies for not having
the exact text). It doesn't show up if I subsequently restart the pcmcia
service. I don't know if this affects anything since I have no PCMCIA devices
with which to test.
Comment 6 James 2005-10-01 06:14:50 EDT
Created attachment 119502 [details]
2.6.13-1.1526_FC4 startup messages w/ I/O error on cardmgr start
Comment 7 James 2005-10-01 06:16:25 EDT
Created attachment 119503 [details]
lspci for machine w/ cardmgr error on 2.6.13-1.1526_FC4
Comment 8 Walter Neumann 2005-10-01 13:30:23 EDT
I too see problems 2.6.13-1.1526_FC4 that were not in 2.6.12:

I see no log errors, but my pcmcia wireless card is only recognised on every
second insertion. First, third, fifth etc insertions do not start up the card
and generate nothing in the logs (this did not happen with older kernels). Card
starts  OK if present on boot, but then fails to start if removed and
reinserted, and then on every second try after that.

Note You need to log in before you can comment on or make changes to this bug.