Bug 1692700 - The ruby module has broken dependencies and cannot be installed.
Summary: The ruby module has broken dependencies and cannot be installed.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: ruby
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jun Aruga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1705543
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-26 09:27 UTC by Lukas Ruzicka
Modified: 2019-05-29 19:31 UTC (History)
4 users (show)

Fixed In Version: module-ruby-2.5-2920190514135654-6c81f848
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-29 19:31:53 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2019-03-26 09:27:48 UTC
Description of problem:

Ruby cannot be installed from a module, because the dependecies are broken.

Version-Release number of selected component (if applicable):

Name        : ruby
Stream      : master
Version     : 20181003163715
Context     : a5b0195c
Profiles    : default
Repo        : updates-testing-modular
Summary     : An interpreter of object-oriented scripting language
Description : Ruby is the interpreted scripting language for quick and easy object-oriented programming.  It has many features to process text files and to do system management tasks (as in Perl).  It is simple, straight-forward, and extensible.
Artifacts   : ruby-0:2.5.1-100.module_2189+93ac0776.x86_64
            : ruby-devel-0:2.5.1-100.module_2189+93ac0776.x86_64
            : ruby-doc-0:2.5.1-100.module_2189+93ac0776.noarch
            : ruby-irb-0:2.5.1-100.module_2189+93ac0776.noarch
            : ruby-libs-0:2.5.1-100.module_2189+93ac0776.x86_64
            : rubygem-abrt-0:0.3.0-5.module_2189+93ac0776.noarch
            : rubygem-abrt-doc-0:0.3.0-5.module_2189+93ac0776.noarch
            : rubygem-bigdecimal-0:1.3.4-100.module_2189+93ac0776.x86_64
            : rubygem-bson-0:4.3.0-4.module_2189+93ac0776.x86_64
            : rubygem-bson-doc-0:4.3.0-4.module_2189+93ac0776.noarch
            : rubygem-bundler-0:1.16.1-4.module_2189+93ac0776.noarch
            : rubygem-bundler-doc-0:1.16.1-4.module_2189+93ac0776.noarch
            : rubygem-did_you_mean-0:1.2.0-100.module_2189+93ac0776.noarch
            : rubygem-io-console-0:0.4.6-100.module_2189+93ac0776.x86_64
            : rubygem-json-0:2.1.0-100.module_2189+93ac0776.x86_64
            : rubygem-minitest-0:5.10.3-100.module_2189+93ac0776.noarch
            : rubygem-mongo-0:2.6.2-1.module_2189+93ac0776.noarch
            : rubygem-mongo-doc-0:2.6.2-1.module_2189+93ac0776.noarch
            : rubygem-mysql2-0:0.5.2-1.module_2189+93ac0776.x86_64
            : rubygem-mysql2-doc-0:0.5.2-1.module_2189+93ac0776.noarch
            : rubygem-net-telnet-0:0.1.1-100.module_2189+93ac0776.noarch
            : rubygem-openssl-0:2.1.0-100.module_2189+93ac0776.x86_64
            : rubygem-pg-0:1.1.3-1.module_2225+420254da.x86_64
            : rubygem-pg-doc-0:1.1.3-1.module_2225+420254da.noarch
            : rubygem-power_assert-0:1.1.1-100.module_2189+93ac0776.noarch
            : rubygem-psych-0:3.0.2-100.module_2189+93ac0776.x86_64
            : rubygem-rake-0:12.3.0-100.module_2189+93ac0776.noarch
            : rubygem-rdoc-0:6.0.1-100.module_2189+93ac0776.noarch
            : rubygem-test-unit-0:3.2.7-100.module_2189+93ac0776.noarch
            : rubygem-xmlrpc-0:0.3.0-100.module_2189+93ac0776.noarch
            : rubygems-0:2.7.6-100.module_2189+93ac0776.noarch
            : rubygems-devel-0:2.7.6-100.module_2189+93ac0776.noarch


How reproducible:

Always


Steps to Reproduce:
1. dnf module install ruby
2. dnf module install ruby:master
3. dnf module install ruby:master/default

Actual results:

Installation fails.

Expected results:

Installation should be possible.

Additional info:

[root@localhost test]# dnf module install ruby:master/default
Last metadata expiration check: 0:01:56 ago on Tue 26 Mar 2019 10:20:31 AM CET.
Error: 
 Problem: conflicting requests
  - package ruby-2.5.1-100.module_2189+93ac0776.i686 requires libruby.so.2.5, but none of the providers can be installed
  - package ruby-2.5.1-100.module_2189+93ac0776.i686 requires ruby-libs(x86-32) = 2.5.1-100.module_2189+93ac0776, but none of the providers can be installed
  - package ruby-2.5.1-100.module_2189+93ac0776.x86_64 requires libruby.so.2.5()(64bit), but none of the providers can be installed
  - nothing provides libreadline.so.7 needed by ruby-libs-2.5.1-100.module_2189+93ac0776.i686
  - nothing provides libreadline.so.7()(64bit) needed by ruby-libs-2.5.1-100.module_2189+93ac0776.x86_64
  - package ruby-libs-2.5.1-100.module_2208+c4843ca5.x86_64 is excluded
  - nothing provides libreadline.so.7()(64bit) needed by ruby-libs-2.5.1-100.module_2208+c4843ca5.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 1 Jun Aruga 2019-04-10 13:38:32 UTC
>  Problem: conflicting requests
  - package ruby-2.5.1-100.module_2189+93ac0776.i686 requires libruby.so.2.5, but none of the providers can be installed

I suspect 2.5 ruby.yaml is still version 1, and maybe need "multilib: [x86_64]" like 2.6.

https://src.fedoraproject.org/modules/ruby/blob/2.5/f/ruby.yaml

```
version: 1
```

https://src.fedoraproject.org/modules/ruby/blob/2.6/f/ruby.yaml

```
version: 2
...
	
    components:
        # SRPMs
        rpms:
            ruby:
                # From ruby.spec Summary
                rationale: An interpreter of object-oriented scripting language
                multilib: [x86_64]	
                buildorder: 101
...
```

Comment 2 Jun Aruga 2019-04-10 13:53:43 UTC
Now I am building it.


Note You need to log in before you can comment on or make changes to this bug.