Bug 169273 - iscsi multipath devices not visible at startup
iscsi multipath devices not visible at startup
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Marzinski
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 08:18 EDT by sanjiv
Modified: 2010-01-11 21:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 23:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sanjiv 2005-09-26 08:18:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
I'm trying to use device mapper multipathing with software iSCSI initiator, unlike the device mapper with FCP , the device nodes are not created under /dev/mapper for the iSCSI devices at bootup. If I run multipath manually it creates the devices, since it doesnt do it at bootime my LVMs on the iSCSI devices do not get imported.
I'm trying to get device mapper to create the devices nodes under /dev/mapper at boot up time.

Version-Release number of selected component (if applicable):
iscsi-initiator-utils-4.0.3.0-2 ; device-mapper-multipath-0.4.5-5.2.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. Setup iSCSI Luns 
2. Run multipath to create the device mapper devices 
3. Use LVM tool likes pvcreate, vgcreate and lvcreate to create the LVMs
4. Reboot the system 
  

Actual Results:  the iSCSI devices nodes are not created under /dev/mapper 

Expected Results:  it should have listed the the iSCSI devices when the command multipath -l is issued.

Additional info:
Comment 2 Ben Marzinski 2005-10-17 11:49:37 EDT
I suspect that this is because the iSCSI devices come online after /etc/sysinit.rc
is run.  This script is what loads the multipath devices. If you want multipath
to automatically try and set itself up on devices loaded after this, you can
uncomment the bottom four lines in /etc/dev.d/block/multipath.dev

#if /sbin/lsmod | /bin/grep "^dm_multipath" > /dev/null 2>&1 && \
#   [ "${ACTION}" = "add" -a "${DEVPATH:7:3}" != "dm-" ] ; then
#
#fi

This will cause multipath to run whenever a new block device is added.  This may
cause devices that you did not intend to be multipathed.  If this happens, you
need to edit /etc/multipath.conf to blacklist those devices.

Let me know if this fixes your problem.
Comment 3 Dave Wysochanski 2005-11-07 19:58:11 EST
I didn't try LVM (yet).

But this seems to fix the basic automounting problem with a single LUN (2 paths)
with an ext3 filesystem on it and a LABEL= _netdev entry in /etc/fstab.

Can we safely recommend this procedure to customers for iSCSI on RHEL4 U2 and
dm-multipath?
Comment 4 Dave Wysochanski 2005-11-07 20:08:24 EST
The reason I ask this is because by default all devices are blacklisted anyway,
so it's not clear why the above 4 lines are commented out.
Comment 5 Ben Marzinski 2005-11-29 23:11:10 EST
Yes. They will be uncommented by default for U3 

Note You need to log in before you can comment on or make changes to this bug.