Bug 169290 - cpufreq driver not working with em64t processors
cpufreq driver not working with em64t processors
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 13:20 EDT by Rich Wohlstadter
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 18:25:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Wohlstadter 2005-09-26 13:20:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
Running on an ibm 8843 blade in their bladecenter chassis which has 2 Intel em64t Xeon 3.6ghz processors.  I am trying to use cpufreq on_demand govenor.  It appears that the kernel does not recognize that the cpu has enhanced speedstep technology and I cannot use cpufreq.  There are no entries for cpufreq in /sys/devices/system/cpu subtree for cpufreq.  If I look in /proc/cpuinfo I do see the the speedstep flag (est) listed in the flags field so it appears the kernel does know the processor is capable of speedstep.  I have also tried vanilla kernels compiled according to intel instructions for enabling speedstep with no luck.  Are the em64t processors not supported yet by the kernel or is it some BIOS issue?  According to Intel, it should work with kernel version 2.6.9+

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. look in /sys/devices/system/cpu/cpu0 and there is no entry for cpufreq
2.
3.
  

Additional info:
Comment 1 Dave Jones 2005-09-27 18:25:38 EDT
even the upstream driver still doesn't support speedstep in Xeons.
The best bet right now for these systems is using cpufreq-acpi

Until someone finds out where Intel has hidden the documents detailing the
tables of frequencies these CPUs support, there's not a lot we can do.

Note You need to log in before you can comment on or make changes to this bug.