Bug 1693 - PCMCIA module load causes total hang on TI Travelmate 5200 laptop.
PCMCIA module load causes total hang on TI Travelmate 5200 laptop.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-23 11:09 EST by Jason M. Sullivan
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason M. Sullivan 1999-03-23 11:09:05 EST
I recently tried to upgrade to 5.2 from 5.1, and had some
problems with the boot and supplimentary disks hanging when
they tried to enable the PCMCIA port on my laptop.  Using
the 5.1 boot and supp disks, I was able to load 5.2, only
to discover that the PCMCIA problems in the boot disks were
also present in the Kernel.

Checking the messages file when I do load the module (but
before the system hangs), reveals little except the
following laboriously re-typed messages (cause no PCMCIA ==
no network)...

Linux PCMCIA Card Services 3.0.5
  kernel build: 2.0.36 unknown
  options: [pci] [cardbus]
Intel PCIC probe:
  Cirrus PD672x at port 0x3e0 ofs 0x00, 2 sockets
    host opts [0]: [ring] [65/6/0] [1/15/0]
    host opts [1]: [ring] [65/6/0] [1/15/0]
    ISA irqs (default) = 3,4,7,9,10,11 status change on irq
11

...and then the cardmgr starts, and then the system hangs.
Comment 1 Anonymous 1999-03-31 14:30:59 EST
If necessary, I can bring the laptop in for verification, since I'm in
the RTP, NC area.
Comment 2 Anonymous 1999-03-31 15:30:59 EST
This happens with the 2.0.36-3 kernel and associated modules.  I
haven't tried the 2.2 kernel yet.
Comment 3 mrt 1999-04-13 19:44:59 EDT
This also happens on a NEC READY 330T. 5.1 works perfectly. Don't
think this is tied to any one machine
Comment 4 Anonymous 1999-05-11 09:59:59 EDT
I just now tried the 6.0 disks, and got the same thing  (along with
another interesting wrinkle that seems unrelated).  Is there going to
be any forward movement on this bug?  Like I said, I can bring in the
laptop for investigation, no problem.  What looks like is happening
is that the IO probe part of PCMCIA startup is tickling an unrelated
port on the TI and causing it to hang (at least, that's what the
PCMCIA howto says).   The question I have, is how do I restrict PCMCIA
port probing in a boot disk situation?
Comment 5 Anonymous 1999-05-11 10:33:59 EDT
Scratch that, it's a different problem under 6.0.  It looks like from
the boot log, that the card services do not match when cardmgr starts.
Does that mean that the PCMCIA system was complied incorrectly?
Should I open another bug in the system to make sure this new thing is
looked at?

Note You need to log in before you can comment on or make changes to this bug.