Bug 1693051 - Unused CRD clusteroperators.operatorstatus.openshift.io should be removed
Summary: Unused CRD clusteroperators.operatorstatus.openshift.io should be removed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cluster Version Operator
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Abhinav Dahiya
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 03:21 UTC by Liang Xia
Modified: 2019-06-04 10:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:37 UTC

Description Liang Xia 2019-03-27 03:21:28 UTC
Description of problem:
We are not using CRD clusteroperators.operatorstatus.openshift.io, so it should be removed.


Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-25-180911

How reproducible:
Always

Steps to Reproduce:
1. Check the file /manifests/0000_00_cluster-version-operator_01_clusteroperator.crd.yaml in CVO pod.


Actual results:
Unused CRD clusteroperators.operatorstatus.openshift.io exist.

Expected results:
Only used CRDs exist.

Additional info:
https://github.com/openshift/cluster-version-operator/blob/master/install/0000_00_cluster-version-operator_01_clusteroperator.crd.yaml#L44

Comment 1 Abhinav Dahiya 2019-03-27 18:20:06 UTC
PR removing the deprecated CRD.
https://github.com/openshift/cluster-version-operator/pull/149

Comment 4 Liang Xia 2019-04-03 08:17:56 UTC
Verified the issue has been fixed with 4.0.0-0.nightly-2019-04-02-133735

$ oc -n openshift-cluster-version rsh cluster-version-operator-56996f5846-2wm2m
sh-4.2# cat /manifests/0000_00_cluster-version-operator_01_clusteroperator.crd.yaml 
kind: CustomResourceDefinition
apiVersion: apiextensions.k8s.io/v1beta1
metadata:
  name: clusteroperators.config.openshift.io
spec:
  additionalPrinterColumns:
  - JSONPath: .status.versions[?(@.name=="operator")].version
    description: The version the operator is at.
    name: Version
    type: string
  - JSONPath: .status.conditions[?(@.type=="Available")].status
    description: Whether the operator is running and stable.
    name: Available
    type: string
  - JSONPath: .status.conditions[?(@.type=="Progressing")].status
    description: Whether the operator is processing changes.
    name: Progressing
    type: string
  - JSONPath: .status.conditions[?(@.type=="Failing")].status
    description: Whether the operator is failing changes.
    name: Failing
    type: string
  - JSONPath: .status.conditions[?(@.type=="Available")].lastTransitionTime
    description: The time the operator's Available status last changed.
    name: Since
    type: date
  group: config.openshift.io
  names:
    kind: ClusterOperator
    listKind: ClusterOperatorList
    plural: clusteroperators
    singular: clusteroperator
    shortNames:
    - co
  scope: Cluster
  subresources:
    status: {}
  version: v1
  versions:
  - name: v1
    served: true
    storage: true

Comment 6 errata-xmlrpc 2019-06-04 10:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.