Bug 169310 - corruption of larger files in software RAID 1
corruption of larger files in software RAID 1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 17:10 EDT by Shafer Stockton
Modified: 2013-07-02 22:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 17:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shafer Stockton 2005-09-26 17:10:07 EDT
Description of problem:

When copying four 600MB+ files (ISO's) from one section of the filesystem to
another at least one file is damaged.


Version-Release number of selected component (if applicable):

Seems to happen on all FC4 kernels and even the FC3 rescuecd kernel.


Steps to Reproduce:

1. I downloaded 4 ISO's via bittorrent (it took a while for the files to
checksum correctly, my first hint of problems)
2. Copy correctly checksummed files to another location on the FS (/tmp)
3. Check copies with sha1sum or md5sum (depending on the provided info for
correct checksums)

Additional info:

If I don't start the software RAID and interact with just half the mirror I can
copy files around without a problem.

I'm using software RAID 1 on two disk attached via the sata_via driver. The
motherboard is an ASUS A7V600-X with VIA VT8237 driving the Serial ATA. I tested
my memory for one full pass with memtest86 and things came out clean. I also ran
SeaTools full test on both my disks and they passed.
Comment 1 Dave Jones 2005-09-26 17:54:47 EDT
what is the newest kernel you've tried that exhibits this problem ?
There was a raid1 corruption problem fixed recently.
Comment 2 Shafer Stockton 2005-09-26 18:08:03 EDT
2.6.12-1.1456_FC4 which I'm fairly certain is the latest kernel (at least via
yum).  I tried it after I noticed the corruption with 2.6.12-1.1447_FC4.

Checking the testing directory just now I see a newer kernel. Is that the one
with the fix?

If it is I'll certainly try it. Guess I should have added CLOSED to my bugzilla
searches. Oops.
Comment 3 Dave Jones 2005-09-26 18:17:36 EDT
2.6.12-1.1456_FC4 has the fix I was thinking of, so this is a different problem.
Reassigning to SATA maintainer.
Comment 4 Shafer Stockton 2005-09-27 02:13:50 EDT
I had the fixed kernel installed and thought I had tested against it. Foolhardy
of me to think such things when I can't access the machine to double check
before replying.

The kernel is present and when used does indeed fix the corruption problem.

My apologies for crying wolf.

Comment 5 Dave Jones 2005-09-27 17:57:26 EDT
ok, thanks for double checking :-)

Note You need to log in before you can comment on or make changes to this bug.