Bug 1693127 - no output when running oc explain ClusterDNS --api-version=dns.openshift.io/v1alpha1
Summary: no output when running oc explain ClusterDNS --api-version=dns.openshift.io/v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Daneyon Hansen
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 08:32 UTC by Hongan Li
Modified: 2019-06-04 10:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:37 UTC
Github openshift cluster-dns-operator pull 87 None None None 2019-04-09 12:55:20 UTC

Description Hongan Li 2019-03-27 08:32:39 UTC
Description of problem:
no output when running oc explain ClusterDNS --api-version=dns.openshift.io/v1alpha1

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-26-072833

How reproducible:
100%

Steps to Reproduce:
1. $ oc get clusterdnses.dns.openshift.io/default -o yaml
apiVersion: dns.openshift.io/v1alpha1
kind: ClusterDNS
---

2. oc explain ClusterDNS --api-version=dns.openshift.io/v1alpha1


Actual results:
no any output

Expected results:
should show description of each fields.

Additional info:

Comment 1 Dan Mace 2019-04-09 12:55:20 UTC
OpenAPI specs should fixed as of https://github.com/openshift/cluster-dns-operator/pull/87. Note the API group/version/kind to use is now `dns --api-version=dns.operator.openshift.io/v1`.

Comment 3 Hongan Li 2019-04-12 06:32:53 UTC
maybe hit other regression issue but now `oc explain` cannot work for many CR with `--api-version=operator.openshift.io/v1`. 

$ oc explain dns --api-version=operator.openshift.io/v1
error: Couldn't find resource for "operator.openshift.io/v1, Kind=DNS"

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-04-10-182914   True        False         29h     Cluster version is 4.0.0-0.nightly-2019-04-10-182914

similar bug of master: https://bugzilla.redhat.com/show_bug.cgi?id=1688638#c5

move to assigned just for investigation

Comment 4 Daneyon Hansen 2019-04-16 23:25:56 UTC
I am not experiencing this bug:

$ oc explain dns --api-version=operator.openshift.io/v1
KIND:     DNS
VERSION:  operator.openshift.io/v1

DESCRIPTION:

FIELDS:
   apiVersion	<string>
     APIVersion defines the versioned schema of this representation of an
     object. Servers should convert recognized schemas to the latest internal
     value, and may reject unrecognized values. More info:
     https://git.k8s.io/community/contributors/devel/api-conventions.md#resources

   kind	<string>
     Kind is a string value representing the REST resource this object
     represents. Servers may infer this from the endpoint the client submits
     requests to. Cannot be updated. In CamelCase. More info:
     https://git.k8s.io/community/contributors/devel/api-conventions.md#types-kinds

   metadata	<Object>
     Standard object's metadata. More info:
     https://git.k8s.io/community/contributors/devel/api-conventions.md#metadata

   spec	<map[string]>
     spec is the specification of the desired behavior of the DNS.

   status	<Object>
     status is the most recently observed status of the DNS.

$ oc get clusterversion
NAME      VERSION                         AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.1.0-0.okd-2019-04-16-184709   True        False         3h59m     Cluster version is 4.1.0-0.okd-2019-04-16-184709
$

Comment 5 Hongan Li 2019-04-17 02:30:05 UTC
Yes, it also works with CI build

$ oc get clusterversion
NAME      VERSION                        AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.ci-2019-04-16-221411   True        False         59m     Cluster version is 4.0.0-0.ci-2019-04-16-221411

$ oc explain dns.status --api-version=operator.openshift.io/v1
KIND:     DNS
VERSION:  operator.openshift.io/v1

RESOURCE: status <Object>

DESCRIPTION:
     status is the most recently observed status of the DNS.

FIELDS:
   clusterDomain	<string>
     clusterDomain is the local cluster DNS domain suffix for DNS services. This
     will be a subdomain as defined in RFC 1034, section 3.5:
     https://tools.ietf.org/html/rfc1034#section-3.5 Example: "cluster.local"
     More info:
     https://kubernetes.io/docs/concepts/services-networking/dns-pod-service

   clusterIP	<string>
<---snip--->

seems not only DNS but other resources also have problem with nightly build (see #Comment 3), so I'm going to move it to verified.

Comment 7 errata-xmlrpc 2019-06-04 10:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.