Bug 1693142 - NetworkManager kills teamd on assumed device when the link goes down
Summary: NetworkManager kills teamd on assumed device when the link goes down
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
: 1738543 (view as bug list)
Depends On:
Blocks: 1711952
TreeView+ depends on / blocked
 
Reported: 2019-03-27 08:54 UTC by Beniamino Galvani
Modified: 2019-11-05 22:29 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1711952 (view as bug list)
Environment:
Last Closed: 2019-11-05 22:29:37 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3623 None None None 2019-11-05 22:29:56 UTC

Description Beniamino Galvani 2019-03-27 08:54:12 UTC
Description of problem:
NetworkManager kills teamd on assumed device when the link goes down.

Version-Release number of selected component (if applicable):
NetworkManager-1.14.0-14.el8

How reproducible:
always

Steps to Reproduce:

 setenforce permissive
 ip link add veth0 type veth peer name veth1
 teamd -d -c "{\"device\":\"team0\",\"runner\":{\"name\":\"lacp\"},\"link_watch\":{\"name\":\"ethtool\"},\"ports\":{\"veth0\":{}}}"
 ip link set team0 up; ip link set team0 down; sleep 2
 ip link set team0 up; ip link set team0 down; sleep 2
 ps aux |grep teamd

Actual results:
NM kills teamd
 <debug> [1553674909.1709] device[0xa794a0] (team0): deactivating device (reason 'connection-assumed') [41]
 <debug> [1553674909.1711] device[0xa794a0] (team0): running: /usr/bin/teamd -k -t team0

Expected results:
teamd is not killed

Comment 3 Beniamino Galvani 2019-09-20 12:26:32 UTC
*** Bug 1738543 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2019-11-05 22:29:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3623


Note You need to log in before you can comment on or make changes to this bug.