Bug 1693169 - Different memory usage units are used under "Home - Status"
Summary: Different memory usage units are used under "Home - Status"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 09:29 UTC by Junqi Zhao
Modified: 2020-01-23 11:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
Different CPU usage units are used under "Home - Status" (205.17 KB, image/png)
2019-03-27 09:29 UTC, Junqi Zhao
no flags Details
memory usage under "Home -> Projects" does not use binary bytes (95.76 KB, image/png)
2019-10-29 07:07 UTC, Junqi Zhao
no flags Details
memory usage for node/pod/build overview use binary bytes (236.56 KB, application/gzip)
2019-10-29 07:09 UTC, Junqi Zhao
no flags Details
memory usage under "Home -> Projects" now uses binary bytes (95.55 KB, image/png)
2019-11-04 03:03 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3112 None None None 2019-10-27 16:55:11 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:04:13 UTC

Description Junqi Zhao 2019-03-27 09:29:26 UTC
Created attachment 1548469 [details]
Different CPU usage units are used under "Home - Status"

Description of problem:
See the attached picture, there is only one pod under openshift-apiserver-operator namespace, "Memory Usage" chart shows value 42M, but the "Memory Usage by Pod (Top 10)" shows 40.34 MiB

Prometheus expression: namespace:container_memory_usage_bytes:sum{namespace='openshift-apiserver-operator'} 

42M from "Memory Usage" chart is because 
namespace:container_memory_usage_bytes:sum{namespace='openshift-apiserver-operator'} / 1000 /1000 = 42M

the "Memory Usage by Pod (Top 10)" shows 40.34 MiB is because
namespace:container_memory_usage_bytes:sum{namespace='openshift-apiserver-operator'} / 1024 /1024 = 40.34 MiB

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-26-215932

How reproducible:
Always

Steps to Reproduce:
1. Check "Home - Status"
2.
3.

Actual results:
Different CPU usage units are used under "Home - Status"

Expected results:
CPU usage units should be the same

Additional info:

Comment 4 Junqi Zhao 2019-10-29 07:06:07 UTC
Tested with 4.3.0-0.nightly-2019-10-28-222147, see the picture, only memory usage under "Home -> Projects" does not use binary bytes

Comment 5 Junqi Zhao 2019-10-29 07:07:04 UTC
Created attachment 1630035 [details]
memory usage under "Home -> Projects" does not use binary bytes

Comment 6 Junqi Zhao 2019-10-29 07:09:10 UTC
Created attachment 1630036 [details]
memory usage for node/pod/build overview use binary bytes

Comment 8 Junqi Zhao 2019-11-04 03:03:39 UTC
Created attachment 1632374 [details]
memory usage under "Home -> Projects" now uses binary bytes

Comment 9 Junqi Zhao 2019-11-07 01:08:52 UTC
As per Comment 6 and 7, move to VERIFIED

Comment 11 errata-xmlrpc 2020-01-23 11:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.