Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1693180 - MachineSet and Machine pages need Event page for resources page consistency
Summary: MachineSet and Machine pages need Event page for resources page consistency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.2.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 09:52 UTC by XiaochuanWang
Modified: 2019-10-16 06:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing of component that is adding Event page tab, on the MachineSet and Machine details pages. Consequence: Missing Event tab on MachineSet and Machine details pages. Fix: Add missing component. Result: MachineSet and Machine details pages contain Events tab.
Clone Of:
Environment:
Last Closed: 2019-10-16 06:27:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:28:10 UTC

Description XiaochuanWang 2019-03-27 09:52:48 UTC
Description of problem:
MachineSet and Machine pages need Event page for consistency among resource pages. 

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-25-180911

How reproducible:
Always

Steps to Reproduce:
1. Cluster admin user create a MachineSet and Machines, or check existed Machineset/Machine.
2. oc describe machineset example-ms
3. oc describe machine


Actual results:
1. There is no Event sub-page for MachineSet / Machine 
2. $ oc describe machineset example-ms
Name:         example-ms
Namespace:    xiaocwan-admin
...
Events:                    <none>

3. Same as step2

Expected results:
2&3. Both MachineSet/Machine should have Event page, showing the reason why there is any error or warning.

Additional info:

Comment 1 Samuel Padgett 2019-03-27 19:39:37 UTC
This is simple to add if machines and machine sets have events, and we should be showing it to be consistent with other resources. I'm going to make this a low severity bug to investigate.

Comment 2 Jakub Hadvig 2019-07-17 08:46:32 UTC
Fixing PR: https://github.com/openshift/console/pull/2018

Comment 4 Yadan Pei 2019-07-18 05:55:23 UTC
Hi Jakub,

From PR conversation, it looks like we're not back-porting this fix to 4.1.z, can you help double confirm?

If that's the truth, I would like to change Target Release from 4.1.z to 4.2.0

Comment 5 Yadan Pei 2019-07-19 03:16:58 UTC
Assign back since fixes were not merged into 4.1.z

Comment 8 XiaochuanWang 2019-07-22 03:01:37 UTC
Both MachineSet and Machine pages have Event tab and correctly shows the steam.
Verified on 4.2.0-0.nightly-2019-07-21-222447

Comment 9 errata-xmlrpc 2019-10-16 06:27:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.