This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 169327 - xmaxima not shown in KDE menu
xmaxima not shown in KDE menu
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: maxima (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 22:27 EDT by Kevin Kofler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 09:49:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2005-09-26 22:27:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90; H010818)

Description of problem:
xmaxima does not appear in the desktop menu in the stock Fedora KDE 3.4.2.

I think this is due to the categories in xmaxima.desktop:
Categories=Application;Scientific;Education;Math;
The Red Hat menu contains none of these categories. (Note that I'm running the official Fedora KDE packages, not the ones from the KDE-RedHat project.)

This may or may not affect GNOME as well (it probably does).

Version-Release number of selected component (if applicable):
maxima-gui-5.9.1.9rc1-4.fc4

How reproducible:
Always

Steps to Reproduce:
1. Open the KDE menu (in stock Fedora packages of KDE 3.4.2).
2. Check all the categories, looking for xmaxima.
  

Actual Results:  Xmaxima should be shown in one of the categories.

Expected Results:  Xmaxima is nowhere to be found.

Additional info:

If my analysis is correct, then the solution to this problem is to add a valid category to the Categories list. I'd suggest one of "Office;", "Utility;" or maybe "Development;". (Yes, ideally, redhat-menus would have some category for scientific apps rather than having to stuff them all into some vaguely-fitting section, but...) "Office;" contains Kile and Lyx, most other Math-related stuff is in "Utility;".
Comment 1 Rex Dieter 2005-09-27 09:49:25 EDT
Items with 
Category=Education
(should) appear in the top-level "Edutainment" menu.
Comment 2 Kevin Kofler 2005-09-27 09:56:48 EDT
I've checked redhat-menus and indeed there should be such a category. I guess I 
have a mess because this system is upgraded all the way from RHL 7.3 (7.3->FC1-
>FC2->FC3->FC4). I'll clean my mess up. ;-)

Sorry for the useless bug report.
Comment 3 Kevin Kofler 2005-09-28 18:09:59 EDT
In case anybody has the same problem: look in your ~/.config/menus for a stale 
kmenuedit-generated applications-kmenuedit.menu. Unfortunately, kmenuedit not 
only saves what you have changed (and I made a few changes back in the days to 
work around bugs like Kate not being shown in the menu, which are fixed now) 
but also a lot of things you haven't changed, which then don't get updated as 
the distribution gets upgraded. (~/.local/share/applications should also get 
cleaned up regularly, that's also written to by kmenuedit.) That solved my 
problem.

So I can confirm the problem was on my side. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.