Bug 169329 - infinite retry with RAID1 with a single disk that has bad blocks
infinite retry with RAID1 with a single disk that has bad blocks
Status: CLOSED WONTFIX
Product: Fedora Legacy
Classification: Retired
Component: kernel (Show other bugs)
fc2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
Brian Brock
DEFER
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 23:56 EDT by David Ellsworth
Modified: 2007-04-18 13:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 10:41:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages output showing problem (35.46 KB, text/plain)
2005-09-26 23:59 EDT, David Ellsworth
no flags Details

  None (edit)
Description David Ellsworth 2005-09-26 23:56:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Fedora/1.7.6-1.2.5

Description of problem:
I had a RAID 1 mirror when one disk failed.  When backing up the data on the remaining disk, I found that it had bad blocks for a few files -- i.e. it had errors when trying to read the files.  The RAID1 kernel driver repeatedly tried to retry the failed read until the system was rebooted.  No I/O errors were returned.  Mounting the partition without using the RAID software just tried to read the blocks once and then returned an I/O error.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.10-1.771_FC2

How reproducible:
Always

Steps to Reproduce:
1. Get a disk with bad blocks.
2. Set it up as a RAID 1 disk with only one disk (i.e. one failed disk, one running one)
3. Somehow allocate a file that uses those bad blocks.
4. Read the file (cat it).
  

Additional info:

See /var/log/messages in the attachment.  The lines with
    raid1: hdc4: rescheduling sector 36551664
and
    raid1: hdc4: redirecting sector 36551664 to another mirror
point to a problem in the kernel in drivers/md/raid1.c where it doesn't
check to see if there is only one disk in the set before retrying a
failed I/O operation.  

Also, from comparing raid1.c from 2.6.10-1.771_FC2smp and kernel.org's 
2.6.13.2, it appears that the bug is also in the mainline kernel.
Comment 1 David Ellsworth 2005-09-26 23:59:24 EDT
Created attachment 119287 [details]
/var/log/messages output showing problem
Comment 2 Pekka Savola 2005-11-16 08:30:33 EST
This doesn't seem to be important enough to fix just on its own, so mark it DEFER.
Comment 3 Jesse Keating 2006-08-13 10:41:44 EDT
Not a security issue.

Note You need to log in before you can comment on or make changes to this bug.