Bug 169335 - /usr/share/pkgconfig is not owned by any package
/usr/share/pkgconfig is not owned by any package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pkgconfig (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 01:20 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 14:46:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-09-27 01:20:34 EDT
Description of problem:
/usr/share/pkgconfig is not owned by any package

Version-Release number of selected component (if applicable):
pkgconfig-0.15.0-6

How reproducible:
# rpm -qf /usr/share/pkgconfig
file /usr/share/pkgconfig is not owned by any package

Expected results:
/usr/share/pkgconfig should be owned.

As /usr/share/pkgconfig is pretty much useless without pkgconfig, adding
/usr/share/pkgconfig to the pkgconfig-rpm probably would be a feasible solution.
Comment 1 Matthias Clasen 2005-09-29 14:46:48 EDT
Not worth an FC4 update, but fixed in Rawhide
Comment 2 Ralf Corsepius 2005-09-29 21:54:40 EDT
On a second thought, is using /usr/share/pkgconfig correct at all?

I am not sure. Shouldn't all *.pc's be installed into %{_libdir}/pkgconfig?

I.e. shouldn't all packages installing their *.pcs to /usr/share/pkgconfig be
considered broken, because *.pcs contain cflags, libs etc => Unless very
carefully handcrafted, in general *.pc's aren't architecture independent and
therefore probably should never be installed to /usr/share/* at all?
Comment 3 Matthias Clasen 2005-10-12 10:05:10 EDT
/usr/share/pkgconfig is used for .pc files describing noarch things.

Note You need to log in before you can comment on or make changes to this bug.