Bug 1693388 - libreoffice-langpack-de depends on retired mythes-de [NEEDINFO]
Summary: libreoffice-langpack-de depends on retired mythes-de
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 30
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On: 1692584
Blocks: F30FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-27 17:57 UTC by Adam Williamson
Modified: 2019-03-31 00:04 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-03-31 00:04:33 UTC
redhat-bugzilla: needinfo? (caolanm)


Attachments (Terms of Use)

Description Adam Williamson 2019-03-27 17:57:55 UTC
libreoffice-langpack-de depends on mythes-de, which was retired in Fedora 30+ due to being orphaned for longer than six weeks:

https://src.fedoraproject.org/rpms/mythes-de/c/54d7b0a263c4960bae3caa69a9221e77f4b92542?branch=master

this is a broken dependency on the Server DVD, which means it's an automatic Final blocker:

"Unresolved dependencies on a release-blocking DVD-style (offline installer) image (failures of QA:Testcase_Mediakit_Repoclosure)" - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers

Comment 1 Caolan McNamara 2019-03-27 21:28:27 UTC
orphaned when mstahl left RH. Seeing as orphaned over 8 weeks ago it would need a re-review if I did want to take back ownership of it, which is a tedious process. So looks like the only option is to drop the depend in libreoffice. ~100 million speakers and no one took maintainership, a real shame.

Comment 2 Fedora Update System 2019-03-28 09:59:48 UTC
libreoffice-6.2.1.2-6.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-23af8a1067

Comment 3 Robert Scheck 2019-03-28 23:34:15 UTC
Caolan, do you have some less spare time to perform the re-review in bug #1692584?

Comment 4 Fedora Update System 2019-03-29 00:12:49 UTC
libreoffice-6.2.1.2-6.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-23af8a1067

Comment 5 Caolan McNamara 2019-03-29 09:38:05 UTC
I'll go ahead with the libreoffice without mythes-de dependency cause that unblocks things right now. Later on when/if mythes-de of bug #1692584 comes available in Fedora 30 we can restore it

Comment 6 Fedora Update System 2019-03-31 00:04:33 UTC
libreoffice-6.2.1.2-6.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.