Bug 1693397 - Should conflict with docker-common instead of / in addition to docker
Summary: Should conflict with docker-common instead of / in addition to docker
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: moby-engine   
(Show other bugs)
Version: 30
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: fedora.dm0
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Keywords:
Depends On:
Blocks: F30FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-27 18:16 UTC by Adam Williamson
Modified: 2019-04-02 00:01 UTC (History)
3 users (show)

Fixed In Version: moby-engine-18.06.3-2.ce.gitd7080c1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-04-02 00:01:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Williamson 2019-03-27 18:16:05 UTC
Running https://fedoraproject.org/wiki/QA:Testcase_Mediakit_FileConflicts (a test for conflicts on DVD media) comes up with this:

2 file conflicts found.
1 package conflicts found.

== Package conflicts ==
2:docker-1.13.1-65.git1185cfd.fc30.x86_64
moby-engine-18.06.3-1.ce.gitd7080c1.fc30.x86_64


== File conflicts, listed by conflicting packages ==
2:docker-common-1.13.1-65.git1185cfd.fc30.x86_64
moby-engine-18.06.3-1.ce.gitd7080c1.fc30.x86_64
  /etc/sysconfig/docker
  /usr/bin/docker

I believe the issue there is that there are conflicting files between moby-engine and docker-common, but moby-engine only explicitly conflicts with docker (not docker-common). I think an explicit conflict between moby-engine and docker-common is needed instead of / in addition to the conflict between moby-engine and docker.

This is, I believe, an automatic Final blocker: "File conflicts between two packages on a release-blocking DVD-style (offline installer) image without an explicit Conflicts: tag (failures of QA:Testcase_Mediakit_FileConflicts)" - https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers

Comment 1 Fedora Update System 2019-03-28 16:36:25 UTC
moby-engine-18.06.3-2.ce.gitd7080c1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a96ada07ed

Comment 2 Fedora Update System 2019-03-29 00:13:06 UTC
moby-engine-18.06.3-2.ce.gitd7080c1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a96ada07ed

Comment 3 Fedora Update System 2019-04-02 00:01:54 UTC
moby-engine-18.06.3-2.ce.gitd7080c1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.