Bug 1693428 - Trying to set a static IP address in Ignition config requires a restart of the machine to apply it.
Summary: Trying to set a static IP address in Ignition config requires a restart of th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Yu Qi Zhang
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 19:31 UTC by davis phillips
Modified: 2019-06-04 10:46 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:37 UTC
Github coreos ignition-dracut pull 78 'None' 'closed' '30ignition: remove initramfs networking' 2019-12-03 04:23:28 UTC

Description davis phillips 2019-03-27 19:31:33 UTC
Description of problem:
Trying to set a static IP address in ingnition config requires a restart of the machine to apply it. 

As per Stephen Lowrie:
The flow should be that networking is brought up inside of the initramfs and the kcmdline args apply, ignition runs and applies down the requested config for the real root, the network is brought down, it pivots from the initramfs to the real root, networking is brought up using the configuration that ignition applied

Version-Release number of selected component (if applicable):
rhcos-410.8.20190326.0-vmware.ova

How reproducible:
Everytime. Apply a file for ifcfg-eth0. The network will be configured after a reboot. 

Steps to Reproduce:
1. Create ifcfg-eth0 in ignition config.
2. Attempt to use that IP.

Actual results:
1. DHCP address is the only response.

Expected results:
Static IP assigned.

Comment 3 Alex Crawford 2019-04-25 22:54:36 UTC
https://jira.coreos.com/browse/RHCOS-148 doesn't appear to exist. I was going to comment over there, but Ignition isn't responsible for bringing up the network so it shouldn't be responsible for taking it down either. That will need to be done by the adjacent processes in the initramfs. Subtle, but important distinction.

Comment 4 Micah Abbott 2019-04-26 13:33:17 UTC
(In reply to Alex Crawford from comment #3)
> https://jira.coreos.com/browse/RHCOS-148 doesn't appear to exist. I was
> going to comment over there, but Ignition isn't responsible for bringing up
> the network so it shouldn't be responsible for taking it down either. That
> will need to be done by the adjacent processes in the initramfs. Subtle, but
> important distinction.

Sorry Alex, that one was deleted because it was a duplicate card.  You can comment in the future on https://jira.coreos.com/browse/RHCOS-111

Comment 10 errata-xmlrpc 2019-06-04 10:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.