Bug 1693429 - [regression] nova console-log throws an error: ERROR (TypeError): write() argument must be str, not bytes
Summary: [regression] nova console-log throws an error: ERROR (TypeError): write() arg...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Stephen Finucane
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks: 1696786
TreeView+ depends on / blocked
 
Reported: 2019-03-27 19:35 UTC by Alexander Chuzhoy
Modified: 2019-09-26 10:49 UTC (History)
14 users (show)

Fixed In Version: python-novaclient-13.0.0-0.20190610133151.62bf880.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1696786 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:20:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1823287 0 None None None 2019-04-05 06:54:51 UTC
OpenStack gerrit 650235 0 None None None 2019-04-05 06:54:51 UTC
OpenStack gerrit 650363 0 None None None 2019-04-11 11:14:36 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:27 UTC

Description Alexander Chuzhoy 2019-03-27 19:35:29 UTC
nova console-log throws an error: ERROR (TypeError): write() argument must be str, not bytes  

Environment:
python3-novaclient-13.0.0-0.20190312082821.62bf880.el8ost.noarch                                                                                                                          
puppet-nova-14.4.0-0.20190323002255.aa4a911.el8ost.noarch  

Steps to reproduce:
1. Deploy overcloud
2. Launch an instance
3. Run:

(overcloud) [stack@undercloud-0 ~]$ nova list                                                                                                                                             
| ID                                   | Name         | Status | Task State | Power State | Networks                               |                                                      +--------------------------------------+--------------+--------+------------+-------------+----------------------------------------+                                                      | d6392ee5-49f2-4204-80d0-40b797c7f883 | after_deploy | ACTIVE | -          | Running     | tenantgeneve=192.168.32.61, 10.0.0.254 |                                                      


(overcloud) [stack@undercloud-0 ~]$ nova console-log after_deploy                                                                                                                         ERROR (TypeError): write() argument must be str, not bytes

Comment 3 Stephen Finucane 2019-04-05 06:56:22 UTC
Patches proposed upstream. I imagine there could be some discussion about this, given that unicode in Python 2 (a patch for which introduced this issue) is a complicated area, so expect some slow progress.

Comment 11 Alexander Chuzhoy 2019-06-07 13:59:25 UTC
FailedQA

Environment: python3-novaclient-13.0.0-0.20190416130354.62bf880.el8ost.noarch

Running nova console-log returns ERROR (TypeError): write() argument must be str, not bytes

Comment 15 Joe H. Rahme 2019-07-27 21:21:19 UTC
$ nova console-log testvm

Starting dropbear sshd: OK
GROWROOT: CHANGED: partition=1 start=18432 old: size=71647 end=90079 new: size=2078687,end=2097119
/run/cirros/datasource/data/user-data was not '#!' or executable
=== system information ===
Platform: Red Hat OpenStack Compute
Container: none
Arch: x86_64
CPU(s): 1 @ 2199.998 MHz
Cores/Sockets/Threads: 1/1/1
Virt-type: 
RAM Size: 46MB
Disks:
NAME  MAJ:MIN       SIZE LABEL         MOUNTPOINT
vda   253:0   1073741824               
vda1  253:1   1064287744 cirros-rootfs /
vda15 253:15     8388608               
=== sshd host keys ===
-----BEGIN SSH HOST KEY KEYS-----
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCPwDO8tqqjX48NquyYpQrnKFLR6rkvoBajxLGQQyH9IqFZAwKuKURH8BDBWmbiyujNqnDbrh0CS+Ux03kiUnS/T6hE4Neret6UxZAmo6wIQGML3L40kInPYetWPOmK4OqU00W8Oqey31mPyeBY9x26R8c2ODHz0ls/yZH2wQdvFJb6PB3wvqnJWo6CrK4vT3dI4dTrAYclD7JG8aekIMK7ZyzW42S+Glvv+M7XpqUXdlPsFeWrTbUShM095jjgiX4lJItY0Ss7uj/gIo7bNhdsskfsxDZdbjWui9tcQLP9UPPcn4YOQP+xgSwXUYw6qUI4lRlrQ1fNSsXBhSn5cxe9 root@devstack
ssh-dss AAAAB3NzaC1kc3MAAACBAKVV7IEK/g4Ytur5Xy2yLQLOBFbll3bjWzsLQWSA4U+60tv8TmPA6UczRdtmB7uvCbxfjsKGKDfyXNmMzV25bl/mgA1bBRWYr5jtuwVqbe3Nkw07SXpH0Bx+uD+tbkUhxzP7Ra+XuKBabj8bsGygUOx8LiEIzM9TokbZsEAyJ4kDAAAAFQDOvLPqnuitZjG34kzVwoJmO+AsmwAAAIANT/ccFJmxojXeKMnKkY9jpC7a9h2T7zfUklj51IQMDM3rWeUMdb9QfqD8c/ykJudBNhUUIcgVHpr0x7Xn0bERLZXoLbQJNdQsk2Ic50gTZthyNoAC46xFffIY7O5lt40TFuEp7QYQwyf6C5rxy6UWveEfzedfdRG/sIY7hUbiQAAAAIBUmto7sHdpV2aI6L7yvy9bZD+V0yx4ipf+ZAAXyPH+rCbqx7hpbIYxP/J1NpX87w0gDepDBUJuEDSxK8Jio+IUeh/cR27xC9i0CrP5vYnru9b2Lz7JXVfxOv/ajr6pcRzknf5NKF+LC/tYixoCQMQMdFMsZ68uvMlMk8LmVWUK7A== root@devstack
-----END SSH HOST KEY KEYS-----
=== network info ===
if-info: lo,up,127.0.0.1,8,,
if-info: eth0,up,192.168.100.90,24,fe80::f816:3eff:fe6b:e963/64,
if-info: eth1,down,,24,,
ip-route:default via 192.168.100.1 dev eth0 
ip-route:169.254.169.254 via 192.168.100.2 dev eth0 
ip-route:192.168.100.0/24 dev eth0  src 192.168.100.90 
ip-route6:fe80::/64 dev eth0  metric 256 
ip-route6:unreachable default dev lo  metric -1  error -101
ip-route6:ff00::/8 dev eth0  metric 256 
ip-route6:unreachable default dev lo  metric -1  error -101
=== datasource: ec2 net ===
instance-id: i-00000005
name: N/A
availability-zone: nova
local-hostname: devstack
launch-index: 0
=== cirros: current=0.4.0 uptime=5.95 ===
/dev/root resized successfully [took 0.27s]
  ____               ____  ____
 / __/ __ ____ ____ / __ \/ __/
/ /__ / // __// __// /_/ /\ \ 
\___//_//_/  /_/   \____/___/ 
   http://cirros-cloud.net


login as 'cirros' user. default password: 'gocubsgo'. use 'sudo' for root.
devstack login: [  381.918234] random: nonblocking pool is initialized

Comment 19 errata-xmlrpc 2019-09-21 11:20:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.