Bug 1693449 - dnf install '*xorg*' produced error msg "nothing provides xorg-x11-server-Xorg(x86-64)"
Summary: dnf install '*xorg*' produced error msg "nothing provides xorg-x11-server-Xor...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorgxrdp
Version: 31
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-27 20:52 UTC by George R. Goffe
Modified: 2020-01-19 00:35 UTC (History)
12 users (show)

Fixed In Version: xorgxrdp-0.2.12-4.fc30 xorgxrdp-0.2.12-2.fc31 xorgxrdp-0.2.12-2.el8 xorgxrdp-0.2.12-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-12 01:16:04 UTC
Type: Bug


Attachments (Terms of Use)

Description George R. Goffe 2019-03-27 20:52:14 UTC
Description of problem: attempting to install missing xorg components produced this message "nothing provides xorg-x11-server-Xorg(x86-64)"


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.20.4-2.fc31.x86_64

How reproducible:
always

Steps to Reproduce:
1.dnf install '*xorg*'
2.
3.

Actual results:
see below

Expected results:


Additional info:

dnf install '*xorg*'
Last metadata expiration check: 0:47:20 ago on Wed 27 Mar 2019 01:00:09 PM PDT.
Package abrt-addon-xorg-2.12.0-2.fc30.x86_64 is already installed.
Package xorg-x11-apps-7.7-24.fc30.x86_64 is already installed.
Package xorg-x11-drv-ati-19.0.1-1.fc31.x86_64 is already installed.
Package xorg-x11-drv-evdev-2.10.6-4.fc30.x86_64 is already installed.
Package xorg-x11-drv-fbdev-0.5.0-3.fc30.x86_64 is already installed.
Package xorg-x11-drv-intel-2.99.917-41.20180618.fc30.x86_64 is already installed.
Package xorg-x11-drv-libinput-0.28.2-1.fc30.x86_64 is already installed.
Package xorg-x11-drv-nouveau-1:1.0.15-7.fc30.x86_64 is already installed.
Package xorg-x11-drv-openchrome-0.6.0-7.fc30.x86_64 is already installed.
Package xorg-x11-drv-qxl-0.1.5-11.fc30.x86_64 is already installed.
Package xorg-x11-drv-vesa-2.4.0-5.fc30.x86_64 is already installed.
Package xorg-x11-drv-vmware-13.2.1-9.fc30.x86_64 is already installed.
Package xorg-x11-drv-wacom-0.36.1-6.fc30.x86_64 is already installed.
Package xorg-x11-drv-wacom-serial-support-0.36.1-6.fc30.x86_64 is already installed.
Package xorg-x11-font-utils-1:7.5-41.fc30.x86_64 is already installed.
Package xorg-x11-fonts-100dpi-7.5-21.fc30.noarch is already installed.
Package xorg-x11-fonts-75dpi-7.5-21.fc30.noarch is already installed.
Package xorg-x11-fonts-ISO8859-1-100dpi-7.5-21.fc30.noarch is already installed.
Package xorg-x11-fonts-ISO8859-1-75dpi-7.5-21.fc30.noarch is already installed.
Package xorg-x11-fonts-ISO8859-15-100dpi-7.5-21.fc30.noarch is already installed.
Package xorg-x11-fonts-Type1-7.5-21.fc30.noarch is already installed.
Package xorg-x11-fonts-misc-7.5-21.fc30.noarch is already installed.
Package xorg-x11-proto-devel-2018.4-3.fc30.noarch is already installed.
Package xorg-x11-server-Xephyr-1.20.4-2.fc31.x86_64 is already installed.
Package xorg-x11-server-Xorg-1.20.4-2.fc31.x86_64 is already installed.
Package xorg-x11-server-Xvfb-1.20.4-2.fc31.x86_64 is already installed.
Package xorg-x11-server-common-1.20.4-2.fc31.x86_64 is already installed.
Package xorg-x11-server-utils-7.7-29.fc31.x86_64 is already installed.
Package xorg-x11-utils-7.5-30.fc30.x86_64 is already installed.
Package xorg-x11-xauth-1:1.0.9-14.fc30.x86_64 is already installed.
Package xorg-x11-xbitmaps-1.1.1-16.fc30.noarch is already installed.
Package xorg-x11-xinit-1.4.0-4.fc30.x86_64 is already installed.
Package xorg-x11-xkb-utils-7.7-29.fc30.x86_64 is already installed.
Error: 
Problem: conflicting requests
- nothing provides xorg-x11-server-Xorg(x86-64) = 1.20.3 needed by xorgxrdp-0.2.9-2.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 1 George R. Goffe 2019-03-27 20:56:58 UTC
Attempting to install xorgxrdp produced the same message. I suspect that this problem belongs to xorgxrdp and not the server.


dnf install xorgxrdp
Last metadata expiration check: 0:53:58 ago on Wed 27 Mar 2019 01:00:09 PM PDT.
Error: 
Problem: conflicting requests
- nothing provides xorg-x11-server-Xorg(x86-64) = 1.20.3 needed by xorgxrdp-0.2.9-2.fc30.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

Comment 2 Ben Cotton 2019-08-13 16:59:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 3 Ben Cotton 2019-08-13 19:29:52 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 4 Fedora Update System 2020-01-03 20:37:40 UTC
FEDORA-2020-4cc57c1cc9 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4cc57c1cc9

Comment 5 Fedora Update System 2020-01-03 20:37:40 UTC
FEDORA-2020-61786117f7 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-61786117f7

Comment 6 Fedora Update System 2020-01-03 20:37:42 UTC
FEDORA-EPEL-2020-7f62b9c67c has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7f62b9c67c

Comment 7 Fedora Update System 2020-01-03 20:37:43 UTC
FEDORA-EPEL-2020-7dc6a9e9e5 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7dc6a9e9e5

Comment 8 Fedora Update System 2020-01-04 20:24:28 UTC
xorgxrdp-0.2.12-2.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7dc6a9e9e5

Comment 9 Fedora Update System 2020-01-04 20:35:47 UTC
xorgxrdp-0.2.12-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-7f62b9c67c

Comment 10 Fedora Update System 2020-01-04 21:18:37 UTC
xorgxrdp-0.2.12-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-61786117f7

Comment 11 Fedora Update System 2020-01-04 22:24:50 UTC
xorgxrdp-0.2.12-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4cc57c1cc9

Comment 12 Fedora Update System 2020-01-12 01:16:04 UTC
xorgxrdp-0.2.12-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2020-01-12 01:42:58 UTC
xorgxrdp-0.2.12-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2020-01-19 00:19:49 UTC
xorgxrdp-0.2.12-2.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2020-01-19 00:35:30 UTC
xorgxrdp-0.2.12-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.