Bug 1693546 - CLO and EO pod are CrashLoopBackOff .
Summary: CLO and EO pod are CrashLoopBackOff .
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-28 06:54 UTC by Qiaoling Tang
Modified: 2019-06-04 10:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:37 UTC
Github operator-framework community-operators pull 225 None None None 2019-03-28 12:30:15 UTC

Description Qiaoling Tang 2019-03-28 06:54:20 UTC
Description of problem:
Deploy logging via OLM, the CLO and EO pod are in CrashLoopBackOff status, 

$ oc get pod
NAME                                        READY   STATUS             RESTARTS   AGE
cluster-logging-operator-86dc48b6fd-jjspc   0/1     CrashLoopBackOff   3          93s
$ oc logs cluster-logging-operator-86dc48b6fd-jjspc
time="2019-03-28T06:19:41Z" level=info msg="Go Version: go1.10.3"
time="2019-03-28T06:19:41Z" level=info msg="Go OS/Arch: linux/amd64"
time="2019-03-28T06:19:41Z" level=info msg="operator-sdk Version: 0.0.7"
time="2019-03-28T06:19:41Z" level=info msg="Watching logging.openshift.io/v1, ClusterLogging, openshift-logging, 5000000000"
time="2019-03-28T06:19:41Z" level=error msg="failed to get resource client for (apiVersion:logging.openshift.io/v1, kind:ClusterLogging, ns:openshift-logging): failed to get resource type: failed to get the resource REST mapping for GroupVersionKind(logging.openshift.io/v1, Kind=ClusterLogging): no matches for kind \"ClusterLogging\" in version \"logging.openshift.io/v1\""
panic: failed to get resource type: failed to get the resource REST mapping for GroupVersionKind(logging.openshift.io/v1, Kind=ClusterLogging): no matches for kind "ClusterLogging" in version "logging.openshift.io/v1"

goroutine 1 [running]:
github.com/operator-framework/operator-sdk/pkg/sdk.Watch(0x11bb7ff, 0x17, 0x11b31e9, 0xe, 0xc420042070, 0x11, 0x12a05f200, 0x0, 0x0, 0x0)
	/go/src/github.com/openshift/cluster-logging-operator/_output/src/github.com/operator-framework/operator-sdk/pkg/sdk/api.go:49 +0x4a8
main.main()
	/go/src/github.com/openshift/cluster-logging-operator/cmd/cluster-logging-operator/main.go:33 +0x29a

$ oc get pod -n openshift-operators
NAME                                      READY   STATUS             RESTARTS   AGE
elasticsearch-operator-5b4977987d-l82mr   0/1     CrashLoopBackOff   5          4m22s
$ oc logs -n openshift-operators elasticsearch-operator-5b4977987d-l82mr
time="2019-03-28T06:22:14Z" level=info msg="Go Version: go1.10.3"
time="2019-03-28T06:22:14Z" level=info msg="Go OS/Arch: linux/amd64"
time="2019-03-28T06:22:14Z" level=info msg="operator-sdk Version: 0.0.7"
time="2019-03-28T06:22:14Z" level=info msg="Watching logging.openshift.io/v1, Elasticsearch, , 5000000000"
time="2019-03-28T06:22:14Z" level=error msg="failed to get resource client for (apiVersion:logging.openshift.io/v1, kind:Elasticsearch, ns:): failed to get resource type: failed to get the resource REST mapping for GroupVersionKind(logging.openshift.io/v1, Kind=Elasticsearch): no matches for kind \"Elasticsearch\" in version \"logging.openshift.io/v1\""
panic: failed to get resource type: failed to get the resource REST mapping for GroupVersionKind(logging.openshift.io/v1, Kind=Elasticsearch): no matches for kind "Elasticsearch" in version "logging.openshift.io/v1"

goroutine 1 [running]:
github.com/operator-framework/operator-sdk/pkg/sdk.Watch(0x12054e3, 0x17, 0x11fafab, 0xd, 0xc420040010, 0x0, 0x12a05f200, 0x0, 0x0, 0x0)
	/go/src/github.com/openshift/elasticsearch-operator/_output/src/github.com/operator-framework/operator-sdk/pkg/sdk/api.go:49 +0x4a8
main.Main(0xc420096058)
	/go/src/github.com/openshift/elasticsearch-operator/cmd/elasticsearch-operator/main.go:118 +0x33e
main.main()
	/go/src/github.com/openshift/elasticsearch-operator/cmd/elasticsearch-operator/main.go:125 +0x22

Version-Release number of selected component (if applicable):
quay.io/openshift/origin-elasticsearch-operator@sha256:52f2f11a47ed7c9fc1568467b98e8c74e5d63bdba917a618d522083f749a3a8e
quay.io/openshift/origin-cluster-logging-operator@sha256:f1c2cd35883437743d918cd3c96278d3a017753629e79605e125058669a9e45a
4.0.0-0.nightly-2019-03-28-030453

How reproducible:
Always

Steps to Reproduce:
1. Deploy logging via OLM
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Qiaoling Tang 2019-03-28 09:20:27 UTC
These PR merged: https://github.com/openshift/cluster-logging-operator/pull/136 https://github.com/openshift/elasticsearch-operator/pull/106 https://github.com/openshift/cluster-logging-operator/pull/130, the api version has changed to "logging.openshift.io/v1" in operators, but https://github.com/operator-framework/community-operators/pull/225 hasn't merged yet, in the clusterlogging and elasticsearch-operator csv, the apiversion is still v1alpha1.

Tried to edit csv, the apiversion can't be changed.

Comment 3 Qiaoling Tang 2019-03-29 00:48:23 UTC
Verified in 4.0.0-0.nightly-2019-03-28-210640, images are:

quay.io/openshift/origin-cluster-logging-operator@sha256:0cd885863329d0ff093221d48534fe95c21c014850f9a9e461dbce48f697351d
quay.io/openshift/origin-elasticsearch-operator@sha256:0dc14667f52824bda1cebe4a42be2f2c8f23056fdbb41a12cee2f11ab22ec653

Comment 5 errata-xmlrpc 2019-06-04 10:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.