Bug 1693551 - Problem with dnf copr disable command
Summary: Problem with dnf copr disable command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Rohel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1691965 1694872 1696851 1697178 1704436 1704952 1705245 1707572 1711568 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-28 07:15 UTC by Peng Wu
Modified: 2019-06-18 06:12 UTC (History)
20 users (show)

Fixed In Version: dnf-plugins-core-4.0.7-1.fc30 dnf-plugins-core-4.0.7-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-23 17:48:53 UTC


Attachments (Terms of Use)

Description Peng Wu 2019-03-28 07:15:02 UTC
Description of problem:

I tried to use dnf copr disable command, but it failed.

I enable dnf copr by using:
# dnf copr enable pwu/pango

Version-Release number of selected component (if applicable):
dnf-plugins-core-4.0.6-1.fc29.noarch

How reproducible:
Try to enable the Fedora copr, then disable the copr.

Steps to Reproduce:
1. Enable the Fedora copr by using dnf copr enable pwu/pango
2. Disable the Fedora copr by using dnf copr disable pwu/pango
3.

Actual results:
Some Traceback printed.


Expected results:
The Fedora copr repo is disabled.


Additional info:

Comment 1 Peng Wu 2019-03-28 07:23:24 UTC
Here are the Traceback log:

# dnf copr disable pwu/pango
Traceback (most recent call last):
  File "/usr/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 192, in user_main
    errcode = main(args)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.7/site-packages/dnf/cli/main.py", line 115, in cli_run
    cli.run()
  File "/usr/lib/python3.7/site-packages/dnf/cli/cli.py", line 1128, in run
    return self.command.run()
  File "/usr/lib/python3.7/site-packages/dnf-plugins/copr.py", line 266, in run
    self._disable_repo(copr_username, copr_projectname)
  File "/usr/lib/python3.7/site-packages/dnf-plugins/copr.py", line 521, in _disable_repo
    self.base.conf.substitutions, {"enabled": 0})
  File "/usr/lib/python3.7/site-packages/dnf/conf/config.py", line 198, in write_raw_configfile
    parser.setValue(section_id, name, value)
  File "/usr/lib64/python3.7/site-packages/libdnf/conf.py", line 1855, in setValue
    return _conf.ConfigParser_setValue(self, *args)
NotImplementedError: Wrong number or type of arguments for overloaded function 'ConfigParser_setValue'.
  Possible C/C++ prototypes are:
    libdnf::ConfigParser::setValue(std::string const &,std::string const &,std::string const &,std::string const &)
    libdnf::ConfigParser::setValue(std::string const &,std::string const &,std::string const &)
    libdnf::ConfigParser::setValue(std::string const &,std::string &&,std::string &&,std::string &&)
    libdnf::ConfigParser::setValue(std::string const &,std::string &&,std::string &&)





Additional info:

Maybe use the following code helps?
self.base.conf.substitutions, {"enabled": "0"})

Comment 3 Marek Blaha 2019-04-03 05:16:52 UTC
*** Bug 1694872 has been marked as a duplicate of this bug. ***

Comment 4 Marek Blaha 2019-04-08 05:30:22 UTC
*** Bug 1696851 has been marked as a duplicate of this bug. ***

Comment 5 Marek Blaha 2019-04-08 05:35:41 UTC
*** Bug 1697178 has been marked as a duplicate of this bug. ***

Comment 6 Daniel Alley 2019-05-01 23:00:04 UTC
Problem also exists on Fedora 30, FYI

Comment 7 Marek Blaha 2019-05-06 11:09:34 UTC
*** Bug 1704436 has been marked as a duplicate of this bug. ***

Comment 8 Marek Blaha 2019-05-06 11:11:49 UTC
*** Bug 1704952 has been marked as a duplicate of this bug. ***

Comment 9 Marek Blaha 2019-05-06 11:20:43 UTC
*** Bug 1705245 has been marked as a duplicate of this bug. ***

Comment 10 Randy Barlow 2019-05-07 19:45:19 UTC
*** Bug 1707572 has been marked as a duplicate of this bug. ***

Comment 11 Marek Blaha 2019-05-20 11:31:05 UTC
*** Bug 1711568 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2019-05-21 12:11:12 UTC
dnf-plugins-core-4.0.7-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-9be1aa31d1

Comment 13 Fedora Update System 2019-05-21 12:11:16 UTC
dnf-plugins-core-4.0.7-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6689a8e2b1

Comment 14 Colin J Thomson 2019-05-21 16:55:27 UTC
The COPR disable command works fine now after updating to 4.0.7-1 on my FC30 Box.

Comment 15 Fedora Update System 2019-05-22 01:44:15 UTC
dnf-plugins-core-4.0.7-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6689a8e2b1

Comment 16 Fedora Update System 2019-05-22 12:29:23 UTC
dnf-plugins-core-4.0.7-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9be1aa31d1

Comment 17 Fedora Update System 2019-05-23 17:48:53 UTC
dnf-plugins-core-4.0.7-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-06-07 16:33:37 UTC
dnf-plugins-core-4.0.7-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Jaroslav Rohel 2019-06-18 06:12:23 UTC
*** Bug 1691965 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.