Bug 169356 - devlabel shows different UUID for multipathed devices
devlabel shows different UUID for multipathed devices
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: devlabel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
http://evuraan.blogspot.com/2005/09/d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 09:51 EDT by Anu Matthew
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 15:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anu Matthew 2005-09-27 09:51:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
devlabel was failing to add symlinks to both of multipathed devices, but didnt, and I found this issue during troubleshooting:

devlabel should print the similar UUID/Page 80 identifiers for multipathed devices when queried with printid option. In this case, devlabel showed different outputs when the two paths to the same device where queried. 

devlabel calls scsi_unique_id, and in this scsi_unique_id is showing different page80 identifiers when I queried those devices. 

I've uploaded the details at this URL : http://evuraan.blogspot.com/2005/09/devlabel-shows-different-page80.html


Version-Release number of selected component (if applicable):
devlabel: 0.48.03

How reproducible:
Always

Steps to Reproduce:
1.Create multipathed devices 
2.Query using "devlabel printid -d $DEV1 and devlabel printid -d $DEV2 
3.Or, query your alt paths using scsi_unique_id $DEV1 and scsi_unique_id $DEV2
  

Actual Results:  Attached scsi disk sdb at scsi0, channel 0, id 0, lun 2
Attached scsi disk sdg at scsi1, channel 0, id 0, lun 2

sdb and sdg are alt paths to the same device. Querying using devlabel gave: 

# devlabel printid -d /dev/sdb
S80:373031303731303231303330EMCSYMMETRIX

# devlabel printid -d /dev/sdg
S80:373031303731303231333031EMCSYMMETRIX

They are being treated as two different devices. 

Expected Results:  Their page80 identifiers should have been the same like this o/p from a different machine (where sdv and sdk are the alt devices)

# devlabel printid -d /dev/sdv
S80:373230393737363534303030EMCSYMMETRIX

# devlabel printid -d /dev/sdk
S80:373230393737363534303030EMCSYMMETRIX

# scsi_unique_id /dev/sdv
model: EMC     SYMMETRIX
page80: 373230393737363534303030
page83 type6: 00018772097753594d363534...

# scsi_unique_id /dev/sdk
model: EMC     SYMMETRIX
page80: 373230393737363534303030
page83 type6: 00018772097753594d363534....

Additional info:

I've uploaded the same info at http://evuraan.blogspot.com/2005/09/devlabel-shows-different-page80.html
Comment 1 Anu Matthew 2005-09-27 15:36:42 EDT
C-bit of Symmetrix  was turned off, and hence this problem. 

Note You need to log in before you can comment on or make changes to this bug.