Bug 169366 - named -v does not work.
named -v does not work.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 11:22 EDT by Dave Starnes
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 12:53:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Starnes 2005-09-27 11:22:48 EDT
Description of problem:
Command "named -v" returns nothing - should be version number.

Version-Release number of selected component (if applicable):
RPM bind-9.2.4-2. 

How reproducible:
Easily, every time.

Steps to Reproduce:
1. Just type "named -v" on terminal command line.
2.
3.
  
Actual results:
Nothing (no output).

Expected results:
Something like "BIND 9.2.N...".

Additional info:
Works OK on RH EL 3 (32-bit - simulated i686 athlon, actually in a VMware VM on 
Windows). Thereon returns "BIND 9.2.4rc6". 
RHEL4 "man named" page still contains "-v" option.
Comment 1 Jason Vas Dias 2005-09-27 11:59:34 EDT
Actually, I think you'll find this due to an SELinux issue - by default,
no network daemon with root privilege has the capability to write to any
terminal device.
If you do:
# getenforce
it says
'Enforcing', no ?
And doing
# named -v | cat
should show the named version ?
And doing
# setenforce 0
# named -v
# setenforce 1
Should allow named to emit its version ?
This issue is fixed with the selinux-policy-targeted-1.17.30-2.110 of RHEL-4-U2.
What version of selinux-policy-targeted are you using ?
Comment 2 Dave Starnes 2005-09-27 12:45:18 EDT
You are correct:- 
    getenforce = Enforcing,
    named -v | cat works, as does doing setenforce 0.
rpm -q selinux-policy-targeted shows version 1.17.30-2.88.
Thanks.
 
Comment 3 Dave Starnes 2005-09-27 13:10:40 EDT
Sorry, I am new to this aspect of RH (admin.). 
My system (/etc/redhat-release file) says ES release 4 (Nahant Update 1).
I presume that you meant me to install Update 2.
I have gone to the download site for the relevant product (RH EL ES 4 AMD64).
There I see two entries. These are headed "... ES4 Update 1" and "... ES4". I 
presume that the first is what I already have and the second is the original 
issue of release 4. Is this correct? Is Update 2 available elsewhere or coming 
shorly?
Comment 4 Jason Vas Dias 2005-09-27 13:52:45 EDT
Yes, RHEL-4 Update 2 will be released in the next couple of weeks. 
Meanwhile, you can work around this problem by piping named output through cat.

Note You need to log in before you can comment on or make changes to this bug.