Bug 1693676 - dnf Failed to synchronize cache for repo 'updates-testing' ppc64le f30
Summary: dnf Failed to synchronize cache for repo 'updates-testing' ppc64le f30
Status: ON_QA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 30
Hardware: powerpc
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2019-03-28 13:10 UTC by Michel Normand
Modified: 2019-04-02 15:20 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)
dnf.log (15.84 KB, text/plain)
2019-03-28 13:10 UTC, Michel Normand
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Fedora Pagure https://pagure.io/fedora-infrastructure issue 7672 None None None 2019-03-28 15:33 UTC

Description Michel Normand 2019-03-28 13:10:48 UTC
Created attachment 1549024 [details]
dnf.log

dnf Failed to synchronize cache for repo 'updates-testing' ppc64le f30

error reported by openQA test
https://openqa.stg.fedoraproject.org/tests/505045#step/modularity_module_list/8


the dnf.log extracted error:
===
2019-03-26T15:38:10Z DEBUG repo: downloading from remote: updates-testing
2019-03-26T15:38:10Z DEBUG error: Status code: 404 for http://dl.phx2.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml (http://dl.phx2.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml).
2019-03-26T15:38:10Z DEBUG error: Status code: 404 for http://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml (http://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml).
2019-03-26T15:38:10Z DEBUG error: Status code: 404 for https://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml (https://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml).
2019-03-26T15:38:10Z DEBUG Cannot download 'https://mirrors.fedoraproject.org/metalink?repo=updates-testing-f30&arch=ppc64le': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried.
2019-03-26T15:38:10Z ERROR Failed to synchronize cache for repo 'updates-testing'
===

dnf seems to look for delta repo, while only 'normal' repo:
=== url tried by dnf:
https://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml
http://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/drpms/os/repodata/repomd.xml
=== only accessible url (no drpms)
https://dl.fedoraproject.org/pub/fedora-secondary/updates/testing/30/Everything/ppc64le/repodata/repomd.xml
===

Comment 1 Dan Horák 2019-03-28 15:27:49 UTC
I'll reopen as infra ticket, it's mirrormanager misconfiguration.

Comment 2 Michel Normand 2019-03-29 10:10:22 UTC
As reported in referenced issue 7672, changes have been done in repo. And despite what is said there, those changes are sufficient for verification of the test in my local openQA instance.So set this bug as on_qa waiting for next compose to verify on openqa.stg


Note You need to log in before you can comment on or make changes to this bug.