Bug 169373 - documentation issue in pam_console
Summary: documentation issue in pam_console
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-27 17:03 UTC by Felix Schwarz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 13:37:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Felix Schwarz 2005-09-27 17:03:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:

When calling "man 8 pam_console" it references a file named "/var/run/console.lock" (under FILES).

Also the same manpage says the following:
"pam_console.so  is  designed to give users at the physical console (virtual terminals and local xdm-managed X sessions by default, but that is configurable) capabilities that they would not otherwise have, and to take those capabilities away when the are no longer logged in at the console."

But the man page doesn't tell me how to configure which users should be considered as console users nor does it point to the appropriate configuration files (which is the task I actually wanted to get done so if you can give me any pointers for that one I would be glad, too).

fs



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
man 8 pam_console

Additional info:

Comment 1 Tomas Mraz 2005-09-30 13:37:05 UTC
It doesn't tell which should be considered as console users simply because ANY
user which logs in on the physical console (text one or gdm/xdm/kdm) becomes
console user if the console lock is not held by another user.

So it is not configurable.


Comment 2 Felix Schwarz 2005-10-01 21:40:18 UTC
The location of the console.lock file was changed from /var/run/ to
/var/run/console/. That change should be reflected in the docs.

After all, I figured out how to implement the behavior I liked by changing
(/etc/security/{console.handlers, console.perms}) because it is configurable
which users are considered as console users.

fs

Comment 3 Tomas Mraz 2005-10-04 13:09:33 UTC
I'm really curious how did you configure which users are considered console users.

I'll fix the path in man page in the development version of pam.



Note You need to log in before you can comment on or make changes to this bug.