Bug 169377 - (t1lib) Update t1lib to 5.1.0
Update t1lib to 5.1.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: t1lib (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Roozbeh Pournader
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2005-09-27 13:50 EDT by Michael A. Peters
Modified: 2009-03-27 16:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 10:34:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)
rpm spec file for new version (3.78 KB, text/plain)
2005-09-27 13:52 EDT, Michael A. Peters
no flags Details
Destdir Patch (464 bytes, patch)
2005-09-27 13:55 EDT, Michael A. Peters
no flags Details | Diff

  None (edit)
Description Michael A. Peters 2005-09-27 13:50:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
Upstream version has been updated, back in may.
Changes include:

- Check against MultipleMasterFonts somewhat more tolerant, so that
  Type 1 Fonts automatically created from Multiple Master Fonts (e.g.
  using Mmpfb) should now be acceptable.

- Added IsoLatin9.enc to distribution.


- Subsetting extended so that it works for SEAC-constructed composites
  even if no AFM composite character information is available


- Somewhat more intelligent defaults for subsetting when composite
  characters are included in the subset.

- Fix for outline code on 64bit systems. This involves a redefinition
  of the T1_PATHPOINT struct. This should be uncritical because for 32bit
  systems there is no difference, whereas on 64bit systems, this has never 
  worked correctly before.


Version-Release number of selected component (if applicable):
t1lib-5.0.2-3

How reproducible:
Always

Steps to Reproduce:
1.N/A
2.N/A
3.N/A
  

Actual Results:  N/A

Expected Results:  N/A

Additional info:

This package is on the orphan list.

I'll attached a spec file that builds the newer version, and a single small patch.

Specfile builds in mock and is rpmlint clean except for a few errors that I believe can be safely ignored.
Comment 1 Michael A. Peters 2005-09-27 13:52:56 EDT
Created attachment 119311 [details]
rpm spec file for new version

The shared library did not version, should be safe to update existing systems
Comment 2 Michael A. Peters 2005-09-27 13:55:03 EDT
Created attachment 119312 [details]
Destdir Patch

Upstream added DESTDIR support but missed on place where its needed.
Comment 3 Roozbeh Pournader 2006-01-17 10:34:29 EST
Updated in CVS with a few more fixes, built successfully for FC4 and Rawhide.

Thanks for the patches Michael. I would appreciate if you could test the new RPMs.
Comment 4 Patrice Dumas 2008-01-04 04:45:21 EST
I use this bug for cvs request since I don't see any review in 
bugzilla

Package Change Request
======================
Package Name: t1lib
New Branches: EL-5
Updated EPEL Owners: jamatos, pertusus
Comment 5 Kevin Fenzi 2008-01-04 13:43:35 EST
Does jamatos wish to maintain this in epel?
Comment 6 Patrice Dumas 2008-01-04 16:35:21 EST
Yes, I said:

Do you want comaintainance help for tilib and grace in EPEL?

He responded
  Yes, please. :-)

  We need t1lib also for grace.

Implying that I am a comaintainer. He also said that it is hard for
him to use plague from the university, so I'll certainly do most of
the work.
Comment 7 Kevin Fenzi 2008-01-04 20:14:25 EST
Excellent... thanks for the reply and sorry for the delay. 
cvs done.
Comment 8 José Matos 2009-03-27 15:33:23 EDT
Using this for the same purpose as before.

Package Change Request
======================
Package Name: t1lib
New Branches: EL-4
Updated EPEL Owners: jamatos, pertusus
Comment 9 Kevin Fenzi 2009-03-27 16:40:52 EDT
cvs done.

Note You need to log in before you can comment on or make changes to this bug.